LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 01-05-2014, 11:38 PM   #1
weinerwad3000
Member
 
Registered: Aug 2013
Posts: 61

Rep: Reputation: Disabled
Fedora 20 no built-in audio


I've spent hours trying to fix this problem. I had audio working but after installing nVidia drivers my built in speakers don't work. I have them selected in pulseaudio and the bar moves like there's sound but nothing comes out of the speakers. Will post any info requested.
Attached Thumbnails
Click image for larger version

Name:	Screenshot from 2014-01-05 22:32:47.png
Views:	58
Size:	229.6 KB
ID:	14412  
 
Old 01-06-2014, 12:14 AM   #2
aus9
LQ Guru
 
Registered: Oct 2003
Distribution: Fedora 25 Gnome (Wayland)
Posts: 5,132

Rep: Reputation: Disabled
Hi

can you first click on chrome's youtube speaker icon and ensure its maxed out
---I know you have but we are not mind readers

2) click on playback and pulldown streams and confirm chrome is playing back as per image

3) can you describe this hw a bit pls?

is this a tower or a laptop/portable

if a tower, does it have front speakers?

3) since I know you are good at images can you show snapshot of relevant analog (likely to be card index=0)

Code:
alsamixer -co
change -c0 to -c1 if relevant etc

also output of

aplay -l
aplay -L


4) are you using system wide pulseaudio (PA) configs or home user?

b) if any changed what are your new configs pls

upload them to a file sharing site/text site and link to them

5) install paman

check when running it, that sink shows *-analog-stereo

6) I wonder if you are running KDE?

if so you need to setup phonon
http://userbase.kde.org/Phonon

I use E17 but you are prolly looking for something like
Also, under KDE System Settings.... I can go to Multimedia-->Phonon and select the order if device preference.
Attached Thumbnails
Click image for larger version

Name:	chrome.jpg
Views:	30
Size:	82.9 KB
ID:	14413  

Last edited by aus9; 01-06-2014 at 12:30 AM.
 
Old 01-06-2014, 06:31 PM   #3
weinerwad3000
Member
 
Registered: Aug 2013
Posts: 61

Original Poster
Rep: Reputation: Disabled
1.) Actually that's firefox but it's irrelevent, because audio doesn't work in any application. I've tried rythmbox, firefox, and vlc and none of them work.

3a.) This is a laptop with intel card which is card 0 device 0 and nvidia card 1 device 3,7,8,9

3b.) alsamixer -c0 in picture below. alsamixer -c1 is irrelevent because hdmi audio works fine. aplay -l & aplay -L are here http://pastebin.com/huUHSvUN

4.) I am the only user on this computer so systemwide I suppose. I do have pulse audio and I added these lines
#load-module module-alsa-source device=hw:0,0
#set-default-sink 14
to /etc/pulse/default.pa because of what I read here https://wiki.archlinux.org/index.php..._Output_Source

5.) Not sure what you wanted in paman so I have a screen cap of it below.

6.) I'm using gnome.

I appreciate your reply. Please let me know if you need any more info.
Attached Thumbnails
Click image for larger version

Name:	Screenshot from 2014-01-06 17:09:23.png
Views:	22
Size:	22.4 KB
ID:	14422   Click image for larger version

Name:	Screenshot from 2014-01-06 17:27:47.png
Views:	29
Size:	67.3 KB
ID:	14423  
 
Old 01-07-2014, 04:46 AM   #4
aus9
LQ Guru
 
Registered: Oct 2003
Distribution: Fedora 25 Gnome (Wayland)
Posts: 5,132

Rep: Reputation: Disabled
Hi

the alsamixer -c0......did you truncate the window as I can't see any mixer controls>

if that is a true image.....you have that reason for no sound for analog

1) can you confirm pls

2) sorry don't use gnome but the arch wiki claims
Quote:
GNOME

As of GNOME 3, GNOME fully integrates with PulseAudio and no extra configuration is needed.
so we can eliminate phonon

3) you may need a model=string to fix up the analog if you confirm (1)

leaping ahead the string options are:

ALC66x/67x/892
==============
mario Chromebook mario model fixup
asus-mode1 ASUS
asus-mode2 ASUS
asus-mode3 ASUS
asus-mode4 ASUS
asus-mode5 ASUS
asus-mode6 ASUS
asus-mode7 ASUS
asus-mode8 ASUS
inv-dmic Inverted internal mic workaround
dell-headset-multi Headset jack, which can also be used as mic-in


####################

for the moment can you remove all of your changes to default.pa and full reboot

test sound

---I assume you still have analog selected in pavucontrol config

----I assume you still have no sound

re=check alsamixer -c0

if no mixer controls we try this

look for a folder called
/etc/modprobe.d

if you have it create a file with an unique name....for the moment as we can delete the whole blinking thing if it borks you

suggested file name asus.conf in that folder needs root powers

contents

Quote:
options snd_hda_intel model=asus-mode1
full reboot and retest

look at the alsamixer -c0 output

BTW thats -c(zero and not OHH)

if mixer sliders appear but not quite right then try a diff string with a full reboot

good luck

Last edited by aus9; 01-07-2014 at 04:49 AM.
 
Old 01-07-2014, 05:31 PM   #5
weinerwad3000
Member
 
Registered: Aug 2013
Posts: 61

Original Poster
Rep: Reputation: Disabled
Haha after I typed in the command apparently the window truncated itself. I expanded it and these are the results. \/
Attached Thumbnails
Click image for larger version

Name:	Screenshot from 2014-01-07 16:27:36.png
Views:	30
Size:	42.0 KB
ID:	14436  
 
Old 01-07-2014, 05:53 PM   #6
aus9
LQ Guru
 
Registered: Oct 2003
Distribution: Fedora 25 Gnome (Wayland)
Posts: 5,132

Rep: Reputation: Disabled
thanks

ok since you know how to right hand arrow to auto mute
go there and use the up or down arrow to disable auto mute pls

------this won't affect pulseaudio-----which has its own mute module
-----------but we don't want two of the blighters

2) I am little surprised you have 2 headphone sliders
since you have a laptop........this is wrong-----------------I suggest you have only one headphone socket (jack)

and re-enforces my view that your model=string is wrong but I will wait to see if you are prepared to follow up
on my suggestion you create
/etc/modprobe.d/asus.conf

contents
options snd_hda_intel model=asus-mode1

then change the model and reboot until you get one slider for headphone etc
 
Old 01-07-2014, 05:58 PM   #7
weinerwad3000
Member
 
Registered: Aug 2013
Posts: 61

Original Poster
Rep: Reputation: Disabled
actually I do have 2 headphone ports. I believe it's for when you have a set of headphones with two jacks (which I used to have) so it sets one to left audio and one to right audio. I'm not sure exactly how it works though, because if I use regular headphones they work in either port in left and right ear.

Not sure if it helps but I have an Alienware m11x laptop.
 
Old 01-07-2014, 05:59 PM   #8
aus9
LQ Guru
 
Registered: Oct 2003
Distribution: Fedora 25 Gnome (Wayland)
Posts: 5,132

Rep: Reputation: Disabled
forgot to mention

unmute first headphone by arrow to it and press m key

raise both volumes to about 80% for both headphones
do you have sound?
 
Old 01-07-2014, 06:01 PM   #9
aus9
LQ Guru
 
Registered: Oct 2003
Distribution: Fedora 25 Gnome (Wayland)
Posts: 5,132

Rep: Reputation: Disabled
ahh your reply 7 written as I typed

the reason for that is pulseaudio is setup as 2 channel rather than surround
for the moment 2 ch is easier to trouble shoot so leave it that way pls
 
Old 01-07-2014, 06:06 PM   #10
weinerwad3000
Member
 
Registered: Aug 2013
Posts: 61

Original Poster
Rep: Reputation: Disabled
I'm wondering if pcm is the built in speaker. It doesn't have a mute option so it must not be enabled? It has the speaker option on there so I'm wondering if it thinks I have a connection for external speakers. Just my two cents. I'm a newb so I could be completely wrong.
 
Old 01-07-2014, 06:14 PM   #11
aus9
LQ Guru
 
Registered: Oct 2003
Distribution: Fedora 25 Gnome (Wayland)
Posts: 5,132

Rep: Reputation: Disabled
hi

your PCM does affect sound but it shows at 100%

if you look at my signature there are at least 2 images to show model=string makes a diff

https://lh5.googleusercontent.com/Q6...YTKoijSa7OjSNE

versus

https://lh5.googleusercontent.com/yV...SdfFLdA7J0HLlI
 
Old 01-07-2014, 06:17 PM   #12
aus9
LQ Guru
 
Registered: Oct 2003
Distribution: Fedora 25 Gnome (Wayland)
Posts: 5,132

Rep: Reputation: Disabled
can you name this laptop pls

make and model

2) show the output to

Code:
lsmod | grep snd
 
Old 01-07-2014, 06:19 PM   #13
aus9
LQ Guru
 
Registered: Oct 2003
Distribution: Fedora 25 Gnome (Wayland)
Posts: 5,132

Rep: Reputation: Disabled
ahh forgot to mention

vlc

vlc default is output to alsa but you have pulseaudio running you need to go into
tools -> preferences -> audio -> pulldown output module and choose pulseaudio

exit vlc and restart it

test sound and report
 
Old 01-07-2014, 06:31 PM   #14
weinerwad3000
Member
 
Registered: Aug 2013
Posts: 61

Original Poster
Rep: Reputation: Disabled
You might not have noticed but I edited an earlier post about make and model. Anyway it's an Alienware m11x.

lsmod | grep snd
snd_hda_codec_hdmi 41070 4
snd_hda_codec_realtek 56591 1
snd_hda_intel 48171 6
snd_hda_codec 183375 3 snd_hda_codec_realtek,snd_hda_codec_hdmi,snd_hda_intel
snd_hwdep 13554 1 snd_hda_codec
snd_seq 60752 0
snd_seq_device 14136 1 snd_seq
snd_pcm 98141 3 snd_hda_codec_hdmi,snd_hda_codec,snd_hda_intel
snd_page_alloc 18268 2 snd_pcm,snd_hda_intel
snd_timer 28698 2 snd_pcm,snd_seq
snd 75313 21 snd_hda_codec_realtek,snd_hwdep,snd_timer,snd_hda_codec_hdmi,snd_pcm,snd_seq,snd_hda_codec,snd_hda_i ntel,snd_seq_device
soundcore 14491 1 snd

vlc was set to automatic but I changed it to pulse and still no sound.
 
Old 01-07-2014, 07:36 PM   #15
aus9
LQ Guru
 
Registered: Oct 2003
Distribution: Fedora 25 Gnome (Wayland)
Posts: 5,132

Rep: Reputation: Disabled
no I did not notice thanks for the heads up

ok it looks like a fancy laptop, too good for you,
better send it to me? giggles

ok stop jokes

it looks like this has a lot of bios and hardware switches that I was not aware of
pls read the link......especially the video section for bios stuff

https://wiki.archlinux.org/index.php...are_M11x#Sound

2) altho I don't have a realtek, it looks like you have soundcore -> snd -> and hardware and codec modules for realtek

pls report what you can see for sound stuff in bios
especially which R (number) do you have

I am guessing R3
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
where are elf files of the in-built applications of fedora 8? krisonearth Linux - Software 3 08-26-2009 02:39 PM
Audio Hotkeys No Longer Work and Audio is Fuzzy - Fedora 10 dudeman41465 Linux - Hardware 2 01-20-2009 03:54 PM
no 5.1 channel audio in built in realtek ALC888 sound card kunalghosh SUSE / openSUSE 2 05-30-2008 08:18 PM
Built-in AC'97 Audio, can I make it work? szmartby Linux - Hardware 3 09-19-2003 09:58 PM
Built In audio CS4232 help cronikus Linux - General 2 07-14-2003 10:46 AM


All times are GMT -5. The time now is 12:07 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration