LinuxQuestions.org
Review your favorite Linux distribution.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 06-30-2013, 01:41 PM   #1
100Rambo
LQ Newbie
 
Registered: Oct 2009
Location: USA
Distribution: Fedora 12
Posts: 16

Rep: Reputation: 0
Fedora 18 Updating Problem


I been trying to update my system with the latest updates but every time that i run yum update i get an error which is the following: Error: Package: sudo-1.8.3p1-7.fc17.x86_64 (@updates)
Requires: libsss_sudo.so.0(EXPORTED)(64bit)
Removing: libsss_sudo-1.8.6-1.fc17.x86_64 (@updates)
libsss_sudo.so.0(EXPORTED)(64bit)
Updated By: libsss_sudo-1.9.4-2.fc17.x86_64 (updates)
Not found
Available: libsss_sudo-1.8.2-10.fc17.x86_64 (fedora)
libsss_sudo.so.0(EXPORTED)(64bit)
Error: Package: sugar-ruler-31-1.fc17.noarch (updates)
Requires: sugar >= 0.97.6
Installed: sugar-0.96.3-1.fc17.noarch (@updates)
sugar = 0.96.3-1.fc17
Available: sugar-0.96.1-2.fc17.noarch (fedora)
sugar = 0.96.1-2.fc17
Error: Package: sudo-1.8.3p1-7.fc17.x86_64 (@updates)
Requires: libsss_sudo.so.0()(64bit)
Removing: libsss_sudo-1.8.6-1.fc17.x86_64 (@updates)
libsss_sudo.so.0()(64bit)
Updated By: libsss_sudo-1.9.4-2.fc17.x86_64 (updates)
Not found
Available: libsss_sudo-1.8.2-10.fc17.x86_64 (fedora)
libsss_sudo.so.0()(64bit)
You could try using --skip-broken to work around the problem
** Found 116 pre-existing rpmdb problem(s), 'yum check' output follows:
PyQt4-4.10-1.fc17.x86_64 is a duplicate with PyQt4-4.9.1-2.fc17.x86_64
akonadi-1.9.1-1.fc17.x86_64 is a duplicate with akonadi-1.8.1-1.fc17.x86_64
akonadi-mysql-1.9.1-1.fc17.x86_64 is a duplicate with akonadi-mysql-1.8.1-1.fc17.x86_64
ark-4.10.1-1.fc17.x86_64 is a duplicate with ark-4.9.5-1.fc17.x86_64
ark-libs-4.10.1-1.fc17.x86_64 is a duplicate with ark-libs-4.9.5-1.fc17.x86_64
audiocd-kio-4.10.1-1.fc17.x86_64 is a duplicate with audiocd-kio-4.9.5-1.fc17.x86_64
audiocd-kio-libs-4.10.1-1.fc17.x86_64 is a duplicate with audiocd-kio-libs-4.9.5-1.fc17.x86_64
bash-4.2.39-3.fc17.x86_64 is a duplicate with bash-4.2.39-2.fc17.x86_64
dbusmenu-qt-0.9.2-1.fc17.x86_64 is a duplicate with dbusmenu-qt-0.9.0-3.fc17.x86_64
firefox-19.0.2-1.fc17.x86_64 is a duplicate with firefox-19.0-1.fc17.x86_64
1:gnome-games-3.4.2-2.fc17.x86_64 is a duplicate with 1:gnome-games-3.4.2-1.fc17.x86_64
1:gnome-games-help-3.4.2-2.fc17.noarch is a duplicate with 1:gnome-games-help-3.4.2-1.fc17.noarch
gwenview-4.10.1-1.fc17.x86_64 is a duplicate with gwenview-4.9.5-1.fc17.x86_64
gwenview-libs-4.10.1-1.fc17.x86_64 is a duplicate with gwenview-libs-4.9.5-1.fc17.x86_64
ibus-qt-1.3.2-1.fc17.x86_64 is a duplicate with ibus-qt-1.3.1-8.fc17.x86_64
2:irqbalance-1.0.3-7.fc17.x86_64 is a duplicate with 2:irqbalance-1.0.3-6.fc17.x86_64
kaccessible-4.10.1-1.fc17.x86_64 is a duplicate with kaccessible-4.9.5-1.fc17.x86_64
kaccessible-libs-4.10.1-1.fc17.x86_64 is a duplicate with kaccessible-libs-4.9.5-1.fc17.x86_64
kactivities-4.10.1-1.fc17.x86_64 is a duplicate with kactivities-4.9.5-1.fc17.x86_64
kamera-4.10.1-1.fc17.x86_64 is a duplicate with kamera-4.9.5-1.fc17.x86_64
kate-part-4.10.1-1.fc17.x86_64 is a duplicate with kate-part-4.9.5-1.fc17.x86_64
kcalc-4.10.1-1.fc17.x86_64 is a duplicate with kcalc-4.9.5-1.fc17.x86_64
kcharselect-4.10.1-1.fc17.x86_64 is a duplicate with kcharselect-4.9.5-1.fc17.x86_64
kcm_colors-4.10.1-2.fc17.x86_64 is a duplicate with kcm_colors-4.9.5-7.fc17.x86_64
kcolorchooser-4.10.1-1.fc17.x86_64 is a duplicate with kcolorchooser-4.9.5-1.fc17.x86_64
kde-baseapps-4.10.1-1.fc17.x86_64 is a duplicate with kde-baseapps-4.9.5-1.fc17.x86_64
kde-baseapps-libs-4.10.1-1.fc17.x86_64 is a duplicate with kde-baseapps-libs-4.9.5-1.fc17.x86_64
kde-runtime-4.10.1-1.fc17.x86_64 is a duplicate with kde-runtime-4.9.5-1.fc17.x86_64
kde-runtime-drkonqi-4.10.1-1.fc17.x86_64 is a duplicate with kde-runtime-drkonqi-4.9.5-1.fc17.x86_64
kde-runtime-flags-4.10.1-1.fc17.noarch is a duplicate with kde-runtime-flags-4.9.5-1.fc17.noarch
kde-runtime-libs-4.10.1-1.fc17.x86_64 is a duplicate with kde-runtime-libs-4.9.5-1.fc17.x86_64
kde-workspace-4.10.1-2.fc17.x86_64 is a duplicate with kde-workspace-4.9.5-7.fc17.x86_64
kde-workspace-libs-4.10.1-2.fc17.x86_64 is a duplicate with kde-workspace-libs-4.9.5-7.fc17.x86_64
kdeartwork-kxs-4.10.1-1.fc17.x86_64 is a duplicate with kdeartwork-kxs-4.9.5-1.fc17.x86_64
kdegraphics-strigi-analyzer-4.10.1-1.fc17.x86_64 is a duplicate with kdegraphics-strigi-analyzer-4.9.5-1.fc17.x86_64
6:kdelibs-4.10.1-1.fc17.x86_64 is a duplicate with 6:kdelibs-4.9.5-2.fc17.x86_64
6:kdelibs-common-4.10.1-1.fc17.x86_64 is a duplicate with 6:kdelibs-common-4.9.5-2.fc17.x86_64
6:kdemultimedia-common-4.10.1-1.fc17.noarch is a duplicate with 6:kdemultimedia-common-4.9.5-1.fc17.noarch
6:kdemultimedia-libs-4.10.1-1.fc17.noarch is a duplicate with 6:kdemultimedia-libs-4.9.5-1.fc17.noarch
7:kdenetwork-common-4.10.1-2.fc17.noarch is a duplicate with 7:kdenetwork-common-4.9.5-1.fc17.noarch
7:kdenetwork-kdnssd-4.10.1-2.fc17.x86_64 is a duplicate with 7:kdenetwork-kdnssd-4.9.5-1.fc17.x86_64
7:kdenetwork-krfb-4.10.1-2.fc17.x86_64 is a duplicate with 7:kdenetwork-krfb-4.9.5-1.fc17.x86_64
7:kdenetwork-krfb-libs-4.10.1-2.fc17.x86_64 is a duplicate with 7:kdenetwork-krfb-libs-4.9.5-1.fc17.x86_64
kdepimlibs-4.10.1-1.fc17.x86_64 is a duplicate with kdepimlibs-4.9.5-1.fc17.x86_64
kdepimlibs-akonadi-4.10.1-1.fc17.x86_64 is a duplicate with kdepimlibs-akonadi-4.9.5-1.fc17.x86_64
kdepimlibs-kxmlrpcclient-4.10.1-1.fc17.x86_64 is a duplicate with kdepimlibs-kxmlrpcclient-4.9.5-1.fc17.x86_64
kdm-4.10.1-2.fc17.x86_64 is a duplicate with kdm-4.9.5-7.fc17.x86_64
kgreeter-plugins-4.10.1-2.fc17.x86_64 is a duplicate with kgreeter-plugins-4.9.5-7.fc17.x86_64
7:kio_msits-4.10.1-1.fc17.x86_64 is a duplicate with 7:kio_msits-4.9.5-3.fc17.x86_64
kmag-4.10.1-2.fc17.x86_64 is a duplicate with kmag-4.9.5-1.fc17.x86_64
kmix-4.10.1-1.fc17.x86_64 is a duplicate with kmix-4.9.5-1.fc17.x86_64
kmousetool-4.10.1-1.fc17.x86_64 is a duplicate with kmousetool-4.9.5-1.fc17.x86_64
kmouth-4.10.1-1.fc17.x86_64 is a duplicate with kmouth-4.9.5-1.fc17.x86_64
kolourpaint-4.10.1-1.fc17.x86_64 is a duplicate with kolourpaint-4.9.5-1.fc17.x86_64
kolourpaint-libs-4.10.1-1.fc17.x86_64 is a duplicate with kolourpaint-libs-4.9.5-1.fc17.x86_64
konsole-4.10.1-1.fc17.x86_64 is a duplicate with konsole-4.9.5-1.fc17.x86_64
konsole-part-4.10.1-1.fc17.x86_64 is a duplicate with konsole-part-4.9.5-1.fc17.x86_64
krb5-libs-1.10.2-9.fc17.x86_64 is a duplicate with krb5-libs-1.10.2-6.fc17.x86_64
krb5-workstation-1.10.2-9.fc17.x86_64 is a duplicate with krb5-workstation-1.10.2-6.fc17.x86_64
kross-interpreters-4.10.1-1.fc17.x86_64 is a duplicate with kross-interpreters-4.9.5-1.fc17.x86_64
kross-python-4.10.1-1.fc17.x86_64 is a duplicate with kross-python-4.9.5-1.fc17.x86_64
kruler-4.10.1-1.fc17.x86_64 is a duplicate with kruler-4.9.5-1.fc17.x86_64
ksnapshot-4.10.1-1.fc17.x86_64 is a duplicate with ksnapshot-4.9.5-1.fc17.x86_64
ksysguard-libs-4.10.1-2.fc17.x86_64 is a duplicate with ksysguard-libs-4.9.5-7.fc17.x86_64
ksysguardd-4.10.1-2.fc17.x86_64 is a duplicate with ksysguardd-4.9.5-7.fc17.x86_64
kwin-gles-libs-4.10.1-2.fc17.x86_64 is a duplicate with kwin-gles-libs-4.9.5-7.fc17.x86_64
libchewing-0.3.4-3.fc17.x86_64 is a duplicate with libchewing-0.3.4-2.fc17.x86_64
libcurl-7.24.0-6.fc17.x86_64 is a duplicate with libcurl-7.24.0-5.fc17.x86_64
libicu-4.8.1.1-5.fc17.x86_64 is a duplicate with libicu-4.8.1.1-4.fc17.x86_64
libkcddb-4.10.1-1.fc17.x86_64 is a duplicate with libkcddb-4.9.5-1.fc17.x86_64
libkcompactdisc-4.10.1-1.fc17.x86_64 is a duplicate with libkcompactdisc-4.9.5-1.fc17.x86_64
libkdcraw-4.10.1-1.fc17.1.x86_64 is a duplicate with libkdcraw-4.9.5-1.fc17.x86_64
libkexiv2-4.10.1-1.fc17.x86_64 is a duplicate with libkexiv2-4.9.5-1.fc17.x86_64
libkface-3.0.0-1.fc17.x86_64 is a duplicate with libkface-2.9.0-3.fc17.x86_64
libkipi-4.10.1-1.fc17.x86_64 is a duplicate with libkipi-4.9.5-1.fc17.x86_64
libksane-4.10.1-1.fc17.x86_64 is a duplicate with libksane-4.9.5-1.fc17.x86_64
libkvkontakte-3.0.0-1.fc17.x86_64 is a duplicate with libkvkontakte-2.9.0-3.fc17.x86_64
libkworkspace-4.10.1-2.fc17.x86_64 is a duplicate with libkworkspace-4.9.5-7.fc17.x86_64
libmediawiki-3.0.0-1.fc17.x86_64 is a duplicate with libmediawiki-2.9.0-3.fc17.x86_64
libmusicbrainz4-4.0.3-3.fc17.x86_64 is a duplicate with libmusicbrainz4-4.0.3-1.fc17.x86_64
libvisio-0.0.25-1.fc17.x86_64 is a duplicate with libvisio-0.0.24-1.fc17.x86_64
1:marble-4.10.1-1.fc17.x86_64 is a duplicate with 1:marble-4.9.5-1.fc17.x86_64
1:marble-libs-4.10.1-1.fc17.x86_64 is a duplicate with 1:marble-libs-4.9.5-1.fc17.x86_64
mdadm-3.2.6-8.fc17.x86_64 is a duplicate with mdadm-3.2.6-7.fc17.x86_64
nepomuk-core-4.10.1-1.fc17.x86_64 is a duplicate with nepomuk-core-4.9.5-1.fc17.x86_64
nepomuk-core-libs-4.10.1-1.fc17.x86_64 is a duplicate with nepomuk-core-libs-4.9.5-1.fc17.x86_64
nspr-4.9.5-2.fc17.x86_64 is a duplicate with nspr-4.9.5-1.fc17.x86_64
nss-3.14.3-1.fc17.x86_64 is a duplicate with nss-3.14.2-2.fc17.x86_64
nss-softokn-3.14.3-1.fc17.x86_64 is a duplicate with nss-softokn-3.14.2-3.fc17.x86_64
nss-softokn-freebl-3.14.3-1.fc17.i686 is a duplicate with nss-softokn-freebl-3.14.2-3.fc17.x86_64
nss-sysinit-3.14.3-1.fc17.x86_64 is a duplicate with nss-sysinit-3.14.2-2.fc17.x86_64
nss-tools-3.14.3-1.fc17.x86_64 is a duplicate with nss-tools-3.14.2-2.fc17.x86_64
nss-util-3.14.3-1.fc17.x86_64 is a duplicate with nss-util-3.14.2-2.fc17.x86_64
okular-libs-4.10.1-1.fc17.x86_64 is a duplicate with okular-libs-4.9.5-3.fc17.x86_64
oxygen-icon-theme-4.10.1-1.fc17.noarch is a duplicate with oxygen-icon-theme-4.9.5-1.fc17.noarch
plasma-scriptengine-python-4.10.1-2.fc17.x86_64 is a duplicate with plasma-scriptengine-python-4.9.5-7.fc17.x86_64
poppler-0.18.4-4.fc17.x86_64 is a duplicate with poppler-0.18.4-3.fc17.x86_64
poppler-glib-0.18.4-4.fc17.x86_64 is a duplicate with poppler-glib-0.18.4-3.fc17.x86_64
poppler-qt-0.18.4-4.fc17.x86_64 is a duplicate with poppler-qt-0.18.4-3.fc17.x86_64
poppler-utils-0.18.4-4.fc17.x86_64 is a duplicate with poppler-utils-0.18.4-3.fc17.x86_64
pykde4-4.10.1-1.fc17.x86_64 is a duplicate with pykde4-4.9.5-1.fc17.x86_64
python-zope-interface-4.0.4-1.fc17.x86_64 is a duplicate with python-zope-interface-4.0.2-3.fc17.x86_64
1:qt-4.8.4-14.fc17.x86_64 is a duplicate with 1:qt-4.8.4-11.fc17.x86_64
1:qt-mysql-4.8.4-14.fc17.x86_64 is a duplicate with 1:qt-mysql-4.8.4-11.fc17.x86_64
1:qt-x11-4.8.4-14.fc17.x86_64 is a duplicate with 1:qt-x11-4.8.4-11.fc17.x86_64
qwt-6.0.1-1.fc17.x86_64 is a duplicate with qwt-5.2.2-6.fc17.x86_64
rpmfusion-free-release-17.0.5-1.noarch is a duplicate with rpmfusion-free-release-17.0.4-1.noarch
rpmfusion-nonfree-release-17.0.5-1.noarch is a duplicate with rpmfusion-nonfree-release-17.0.4-1.noarch
sip-4.14.4-1.fc17.x86_64 is a duplicate with sip-4.13.2-1.fc17.x86_64
soprano-2.9.0-1.fc17.x86_64 is a duplicate with soprano-2.8.0-4.fc17.x86_64
7:squid-3.2.8-2.fc17.x86_64 is a duplicate with 7:squid-3.2.7-1.fc17.x86_64
sudo-1.8.6p7-1.fc17.x86_64 is a duplicate with sudo-1.8.3p1-7.fc17.x86_64
systemtap-sdt-devel-2.1-2.fc17.x86_64 is a duplicate with systemtap-sdt-devel-2.1-1.fc17.x86_64
telepathy-gabble-0.16.5-1.fc17.x86_64 is a duplicate with telepathy-gabble-0.16.3-1.fc17.x86_64
xulrunner-19.0.2-1.fc17.x86_64 is a duplicate with xulrunner-19.0-1.fc17.x86_64
yum-3.4.3-31.fc17.noarch is a duplicate with yum-3.4.3-30.fc17.noarch
[root@localhost Rambo]# Any help is greatly appreciated Thanks
 
Old 06-30-2013, 02:20 PM   #2
John VV
LQ Muse
 
Registered: Aug 2005
Location: A2 area Mi.
Posts: 16,822

Rep: Reputation: 2408Reputation: 2408Reputation: 2408Reputation: 2408Reputation: 2408Reputation: 2408Reputation: 2408Reputation: 2408Reputation: 2408Reputation: 2408Reputation: 2408
this is a bit concerning
Code:
(fedora)
(updates)
(@updates)
and next time please USE the code tags
wrap the code in them
PHP Code:
[code
 
the code you are "copy / pasting " 
[/code
this looks like you installed incompatible repos ( a bit hard to do on fedora these days )

please post the output of this
Code:
su -
yum repolist all
this will list ALL the repos installed and if they are ON or OFF

also try cleaning the database
Code:
su -
yum clean all
rpm --rebuilddb
yum update

Also you might want to change the name on the thread
this looks like you are running "Fedora 17 and not 18 "
it is time to think of "Upgrading"
fedora 17 will hit it's End Of Life in about 40 DAYS

Last edited by John VV; 06-30-2013 at 02:24 PM.
 
Old 06-30-2013, 02:49 PM   #3
100Rambo
LQ Newbie
 
Registered: Oct 2009
Location: USA
Distribution: Fedora 12
Posts: 16

Original Poster
Rep: Reputation: 0
Ok then I will just install fedora 18
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
problem in updating fedora 18 by yum dnskdas Linux - Software 9 06-10-2013 09:57 AM
[SOLVED] updating Fedora 18 problem ms_chevis Linux - General 2 03-22-2013 05:20 PM
problem in installing and updating klamav in Fedora Core-9 Biswajit Ransingh Fedora 0 07-19-2008 06:06 AM
Fedora - Problem updating from repositories Ambrose Linux - Newbie 5 05-26-2008 06:29 PM
Problem while updating Fedora. ianix Linux - Software 6 07-14-2005 03:31 PM


All times are GMT -5. The time now is 08:29 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration