LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices

Reply
 
Search this Thread
Old 03-12-2009, 05:44 PM   #1
Ciprian
LQ Newbie
 
Registered: Mar 2009
Location: Romania
Distribution: Fedora 10
Posts: 5

Rep: Reputation: 0
Fedora 10 x86_64 fresh installation on dual-boot - change boot settings


I'm totally new to Linux. I've read something here and there. Got a fresh installation of Fedora 10 x86_64 on my HP dv7-1070el notebook with previously installed Vista Ultimate 64bit. I have 2 HDDs. The OS are installed on different hard-disks.
The problem: I've chosen to put the boot loader on the first sector [...] on the second HDD (/sdb5) where Fedora is installed, not on MBR /sda1 where is Vista. Now, when I reboot, it goes straight to Vista and I expected to be asked for a boot choice. What I want is to start using Fedora and to be able to choose which OS I want to use when I start my notebook.
I'm not sure I made myself clear since I'm not too familiar with all terms so please correct me so I can learn . This is what I remember from installation. Everything else went great, no installation problems.

Last edited by Ciprian; 03-13-2009 at 05:16 AM.
 
Old 03-13-2009, 12:08 PM   #2
puntjuh
Member
 
Registered: Apr 2006
Location: holland
Distribution: Gentoo / debian / suse / mint
Posts: 558

Rep: Reputation: 41
When it comes to the bootloader, it will automaticly load the "first" one, in this case, the vista bootloader on the first harddisk. What you could do is press "in my case it's F2" during the POST screen, you can choose which device you want to boot from, you don't have to access the BIOS for this, it'll give u a Device Boot Options list. Choose your 2nd harddisk which has Fedora installed on, then it will use that bootloader.

Offcourse the easiest way would be to reinstall the bootloader to the MBR on the first harddisk, then edit it to also give VISTA as a boot option.
 
Old 03-13-2009, 02:23 PM   #3
PTrenholme
Senior Member
 
Registered: Dec 2004
Location: Olympia, WA, USA
Distribution: Fedora, (K)Ubuntu
Posts: 4,151

Rep: Reputation: 331Reputation: 331Reputation: 331Reputation: 331
I have an older HP laptop (a dv9710us), so this problem may not apply to you. But there is a bug in the 2.6.27 kernels (fixed in 2.6.28.7) that causes my notebook to appear to "hang" during the boot process when the "High Precision Event Timer" is accessed to establish disk timings. Since Fedora 10 is still using the older kernel, there are two "work arounds" you can use:

1) If it happens when you boot, press the "shift" key. That "unhangs" the interrupt. (There will be several times during the boot when you'll need to push the shift key.

2) A more permanent "fix" is to add the nohpet option in the kernel line in the GRUB configuration file.

To address your question: You could create a boot.ini file in you Vista C:\ drive and point it to an image of the boot sector you placed on the partition.

My laptop's BIOS does not allow for booting from anything except the MBR, so I installed the alternate boot on the MBR of the second drive. Unfortunately, my second drive is not handled properly by the BIOS, so it's not bootable (although it is usable after booting), but I suspect that it might work on your system.
 
Old 03-13-2009, 02:36 PM   #4
Ciprian
LQ Newbie
 
Registered: Mar 2009
Location: Romania
Distribution: Fedora 10
Posts: 5

Original Poster
Rep: Reputation: 0
I tried what puntjuh said and I can choose to boot only from "Notebook hard drive". So I'm unable to choose to boot from a specific hard-disk. BIOS also specifies only "Notebook hard drive" at boot devices section.

PTrenholme, I don't know what you mean by "hang" to be honest, but I want to mention that I have no problems during booting. Everything goes the same as before installing Fedora, it boot into windows as if there's no other OS installed.
 
Old 03-13-2009, 04:32 PM   #5
puntjuh
Member
 
Registered: Apr 2006
Location: holland
Distribution: Gentoo / debian / suse / mint
Posts: 558

Rep: Reputation: 41
Ok, a pitty your BIOS won't work with us. But that's not a total dissaster imho. There's another way. One way is as following:

Code:
Dual-Boot Setup

Following are the steps to get dual-boot working with GRUB; I figured out how to do this by looking at a similar procedure for LILO. I've verified that this works for Windows 2000 and Windows XP, and this should work on Windows NT (all 3 OSs use the same booting architecture).

   1. Install GRUB on the first sector of the /boot partition. DO NOT INSTALL IT ON THE MBR!.
      If you are performing the Red Hat installation, for the "Boot Loader Installation" screen:
          * Select "Use GRUB as the boot loader"
          * Select Install Boot Loader record on "...First sector of boot partition".
          * After finishing the Red Hat installation, reboot into Linux. If you don't have a boot disk, try booting in linux rescue mode
      If you already have Linux installed:
          * Run the following command (e.g. assuming /boot is /dev/hda2): grub-install /dev/hda2.
            If you don't know which partition contains /boot, run the df command and check the output.
          * Edit /etc/grub.conf and make sure there is an entry for your version of Windows. For reference, here is a copy of my /etc/grub.conf file.
   2. Determine which partition contains the /boot partition by running the df command. You'll see output like this:

      Filesystem           1k-blocks      Used Available Use% Mounted on
      /dev/hda3              8665372   1639580   6585612  20% /
      /dev/hda2                46636      5959     38269  14% /boot
      /dev/hda6               513776    189504    324272  37% /osshare
      none                    256624         0    256624   0% /dev/shm

      From this output, we see that /boot is on /dev/hda2.
   3. Make a copy of the Linux boot sector onto a floppy or onto a FAT32 partition. We'll name this copy linux.bin.
      To make a copy onto a floppy:
          * Mount the floppy drive if it's not mounted (assumes /mnt/floppy exists): mount -t msdos /dev/fd0 /mnt/floppy
          * Run the following command: dd if=/dev/hda2 of=/mnt/floppy/linux.bin bs=512 count=1
            Substitute the path for the if= parameter (the input file) with the appropriate partition from the previous step. E.g., set if= to /dev/hda2.
      To make a copy onto a FAT32 (vfat) partition:
          * Mount the FAT32 partition if it's not mounted yet. If it isn't listed in the df output, it hasn't been mounted yet. Check out steps 3a-3c for mounting a FAT32 partition on the "Share Partitions HOWTO".
          * Run the following command: dd if=/dev/hda2 of=/osshare/linux.bin bs=512 count=1
            Substitute the path for the if= parameter (the input file) with the appropriate partition from the previous step. E.g., set if= to /dev/hda2. Substitute the path for the of= parameter (the output file) with whatever is appropriate for your system. The example here (of=/osshare/linux.bin) is for copying onto a FAT32 partition called osshare.
   4. Reboot into Windows
   5. Copy the linux.bin file to C:\
   6. Run notepad and edit C:\boot.ini. Note that C:\boot.ini is a hidden system file, so it probably won't show up in Windows Explorer. To edit the file, try: Start->Run and enter: notepad C:\boot.ini. Add the following line at the end: c:\linux.bin="Linux"
      If your C: filesystem is NTFS (not FAT32), you must edit C:\boot.ini as a user with administrator-level privileges.
      To make C:\boot.ini writable, you can either :
          * Use Explorer:
                o Go to Tools->Folder Options->View and select Show hidden files and folders and deselect Hide protected operating system files (Recommended).
                o Right-click on the file, view the Properties and uncheck Read-only. You can now edit the file.
                o After editing the file, restore the settings to their original state.
          * Use the command-line:
                o Make the file writable: attrib -R -S -H C:\boot.ini.
                o After you've finished editing the file, put the settings back: attrib +R +S +H C:\boot.ini
      For reference, here is a copy of my boot.ini file.
   7. Reboot again. You should be able to pick either Windows or Linux. Selecting Linux will start GRUB
This is the website that might be easier reading/printing: click me

OR i'd suggest downloading a knoppix cd, boot it, then reinstall grub with it as following:

Code:
sudo mkdir /mnt/temp

sudo mount /dev/hda1 /mnt/temp
(change /dev/hda1 to match your own root partition)

sudo chroot /mnt/temp

sudo grub-install /dev/hda
hda1 will probably be sdb1 for you.
and grub-install /dev/hda will probably be for you as: grub-install /dev/sda.

Then grub is installed to the MBR, and it'll replace your windows MBR. NOTE: "Your windows MBR can ALLWAYS be repaired using your windows CD in recovery mode using the following command : FDISK /MBR."

Once your Grub boots you into linux, edit your grub.conf to also have windows as boot option:

Code:
title=Windows
root (hd0,0) #this means windows is on sda.
chainloader +1
makeactive
That should be all you need to boot windows. Hope this info helps you out!

Last edited by puntjuh; 03-13-2009 at 04:40 PM. Reason: more information
 
Old 03-13-2009, 07:08 PM   #6
Ciprian
LQ Newbie
 
Registered: Mar 2009
Location: Romania
Distribution: Fedora 10
Posts: 5

Original Poster
Rep: Reputation: 0
I managed it using EasyBCD and informations from http://apcmag.com/how_to_dualboot_vi...rst.htm?page=4.
Now I'm getting prompted which OS I want to start.
 
Old 03-13-2009, 07:14 PM   #7
yancek
Senior Member
 
Registered: Apr 2008
Distribution: PCLinux, Ubuntu, Slackware
Posts: 4,964

Rep: Reputation: 785Reputation: 785Reputation: 785Reputation: 785Reputation: 785Reputation: 785Reputation: 785
If you have vista and its bootloader on the first drive and you apparently can't set you laptop to boot from the other drive, you need to configure your vista boot files to boot Fedora. You could download EasyBCD and use that to add Fedora to your bootloader in vista. I've not used it myself as I don't use vista but, apparently it works fairly well.

From what I have read about vista, ntldr, is replaced by three components:

Windows Boot Manager (Bootmgr.exe)
Windows operating system loader (Winload.exe)
Windows resume loader (Winresume.exe)

There is no 'boot.ini' file in vista by default anyway but there is a file called BCDEdit which can be used to edit boot options. The BCDEdit file is what is changed with EasyBCD.

The reason you don't have a boot choice is because you don't have an entry for Fedora in your vista boot files and you have chosen to boot vista by having it in your mbr.
 
Old 03-13-2009, 07:38 PM   #8
Ciprian
LQ Newbie
 
Registered: Mar 2009
Location: Romania
Distribution: Fedora 10
Posts: 5

Original Poster
Rep: Reputation: 0
Yancek, that's exactly what I did I came across the info that there's no boot.ini in veestah and EasyBCD did the job. I succeeded to boot into grub. Now what? :d Still searching...
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
fedora-xp dual boot installation shrinivaskk Fedora 4 08-22-2007 05:28 AM
boot record not found after fresh installation of fedora -- can't fix! punt Fedora - Installation 16 01-24-2006 07:26 AM
Fresh FC3 Install - Dual Boot Fedora Core 3 Workstation/Server Possible ? testguyct Fedora 1 03-15-2005 05:10 AM
Fresh Slackware 9.1 installation requires boot disk to boot smithtodda Slackware - Installation 7 06-23-2004 09:06 PM
Fresh Fedora Installation wont boot up? don_dimo Linux - Software 1 01-19-2004 06:54 PM


All times are GMT -5. The time now is 07:06 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration