LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 05-01-2009, 09:00 AM   #1
beleth
LQ Newbie
 
Registered: Apr 2009
Posts: 7

Rep: Reputation: 0
fedora 10 running slow, need help to get it faster


i'm running an older pc with fedora 10, specs are

Biostar 6886-D MoBo
intel celeron 2.7g P4
2 GB ddr2 533mhz
160g ata hard drive
nvidia 6600 256mb agpx2

i also have compiz-fusion with cube desktop and emerald theme. could be a problem, however its been alittle slow from install. internet explorer opens slow, typing in a webpage lags when i input text. but no lag in terminal. youtube videos are also get a little clippy.

2 problems i *think* could be an issue is -
1) i don't have an 80 conductor ide cable.(it gives me that error at startup)

2) i did the standard install, and it seems that i don't have any swap space as a partition. I have tried linux like 8 or 9 years ago, and i thought that swap was really important to make it more efficient.

now if its the 1st one, thats an easy fix, but if its a swap issue, is there a way to add swap after install, or do you have to re-install??

any other suggestions would be appreciated.
 
Old 05-01-2009, 10:07 AM   #2
ilikejam
Senior Member
 
Registered: Aug 2003
Location: Glasgow
Distribution: Fedora / Solaris
Posts: 3,109

Rep: Reputation: 96
Hi.

It's probably because you're using compiz without the nvidia graphics drivers - you'll be rendering everything in software which is slow as a week in jail.
http://www.nvidia.com/Download/index.aspx?lang=en-us

Swap's not a requirement, and you likely won't see any performance improvement from having it switched on - 2G should be plenty for a normal Fedora desktop.

Dave
 
Old 05-01-2009, 10:20 AM   #3
beleth
LQ Newbie
 
Registered: Apr 2009
Posts: 7

Original Poster
Rep: Reputation: 0
i actually was on nvidia's site, and downloaded and installed "NVIDIA-Linux-x86-180.51-pkg1.run" it said it was for the the 6 series. i didn't install compiz till i had the right drivers, because before i installed the driver i clicked "enable desktop effects" and got a white screen with only a mouse cursor. but i will try that link, maybe i can find a better one.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Fedora Running Dog A$$ Slow vtecturbo13 Fedora 2 12-15-2006 02:35 PM
Fedora Core 5 running desperately slow jatos Linux - General 2 05-14-2006 07:32 PM
doom3 running slow in Fedora core 4 gopi.d Linux - Software 2 03-13-2006 11:48 PM
Fedora 2 running really slow on laptop Mrhat Fedora - Installation 6 12-07-2004 11:45 PM
Fedora Core 2 becoming slow on booting and when running Giant_Robot Linux - Newbie 5 11-04-2004 04:47 AM


All times are GMT -5. The time now is 12:53 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration