LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Newbie (http://www.linuxquestions.org/questions/linux-newbie-8/)
-   -   Fedora 10 com1 port will not connect to router console port using minicom (http://www.linuxquestions.org/questions/linux-newbie-8/fedora-10-com1-port-will-not-connect-to-router-console-port-using-minicom-713993/)

rgjr979 03-24-2009 04:20 AM

Fedora 10 com1 port will not connect to router console port using minicom
 
Hello everyone, I'm posting for the first time.

The problem I'm having is getting my serial port to connect to a Cisco router console port. All of the postings I've seen suggested changing the inittab file. But Fedora 10 no longer uses the inittab for serial configs. From what I understand I should use the /etc/event.d/tty1 if I'm using ttyS0 and I should use mgetty and not mingetty. What do I put into the tty1 file? I'm using minicom without success...

Fedora 10 is installed on an IBM Thinkpad 600X. Prior to installing Fedora the laptop had Windows XP and the com1 port worked with hyperterm without any problem.

cat /proc/tty/driver/serial:
0: uart:16550A port:000003F8 irq:4 tx:0 rx:0 CTS|DSR|CD|RI
Does anyone know how to get rid of the control signals CTS|DSR|CD|RI on the above port? Could they be causing the problem?

setserial -a /dev/ttyS0:
/dev/ttyS0, Line 0, UART: 16550A, Port: 0x03f8, IRQ: 4
Buad_Base: 115200, close delay: 50, divisor: 0
closing_wait: 300
Flags: spd_normal skip_test

Should I use setserial to change the baud_mode of ttyS0 to 9600. In WinXP I used 9600 81N to connect the router to the Thinkpad using hyperterm prior to installing Fedora 10.

Thanks in advance for any help ...

TB0ne 03-24-2009 11:26 AM

Quote:

Originally Posted by rgjr979 (Post 3485827)
Hello everyone, I'm posting for the first time.

The problem I'm having is getting my serial port to connect to a Cisco router console port. All of the postings I've seen suggested changing the inittab file. But Fedora 10 no longer uses the inittab for serial configs. From what I understand I should use the /etc/event.d/tty1 if I'm using ttyS0 and I should use mgetty and not mingetty. What do I put into the tty1 file? I'm using minicom without success...

Fedora 10 is installed on an IBM Thinkpad 600X. Prior to installing Fedora the laptop had Windows XP and the com1 port worked with hyperterm without any problem.

cat /proc/tty/driver/serial:
0: uart:16550A port:000003F8 irq:4 tx:0 rx:0 CTS|DSR|CD|RI
Does anyone know how to get rid of the control signals CTS|DSR|CD|RI on the above port? Could they be causing the problem?

setserial -a /dev/ttyS0:
/dev/ttyS0, Line 0, UART: 16550A, Port: 0x03f8, IRQ: 4
Buad_Base: 115200, close delay: 50, divisor: 0
closing_wait: 300
Flags: spd_normal skip_test

Should I use setserial to change the baud_mode of ttyS0 to 9600. In WinXP I used 9600 81N to connect the router to the Thinkpad using hyperterm prior to installing Fedora 10.

Thanks in advance for any help ...

The inittab settings are for getty's, which are INCOMING terminal sessions to your Linux box.

If you're trying to go from Minicom out to a Cisco router, you should just have to fire up Minicom, set your device to be /dev/ttyS0 (or whatever it's called on your system, for the first serial port), and set the baud/parity/etc/ in there, and have at it. We do it at the office all the time. You shouldn't have to do anything with setserial, and you don't want to get rid of the CTS/DSR/CD/RI either...you need them all for successful serial connections.

Be aware that Linux is case-sensitive. So ttyS0 is different from ttys0. Check which one you have, and if you're using a USB to serial dongle, your serial port will actually be /dev/ttyUSB0....

rgjr979 03-24-2009 03:21 PM

Hello thanks for the quick response ..

I am using the motherboard serial port on ttyS0.
- serial port setup in minicom: /dev/ttyS0 /var/lock 9600 9N1 No No
- modem dialing: nothing in init string and reset string
- auto bps detect=Yes Modem has DCD line=No - When I change Modem has DCD line=Yes the status line shows online 00:00
- I'm using the Cisco (LL97744) cable from the Cisco to Linux box.

The only line enabled in my inittab is id:5:initdefault:

Here is my /etc/event.d/tty1:
start on stopped rc2
start on stopped rc3
start on stopped rc4

stop on runlevel 0
stop on runlevel 1
stop on runlevel 6

respawn
exec /sbin/mgetty tty1

I did a cat /proc/tty/driver/serial after attempting to run minicom:
0: uart:16550A port:000003F8 irq:4 tx:43 rx:0 CTS|DSR|CD|RI

There are always tx: increments but rx: always remains 0

Any ideas ???

TB0ne 03-24-2009 06:31 PM

Quote:

Originally Posted by rgjr979 (Post 3486375)
Hello thanks for the quick response ..

I am using the motherboard serial port on ttyS0.
- serial port setup in minicom: /dev/ttyS0 /var/lock 9600 9N1 No No
- modem dialing: nothing in init string and reset string
- auto bps detect=Yes Modem has DCD line=No - When I change Modem has DCD line=Yes the status line shows online 00:00
- I'm using the Cisco (LL97744) cable from the Cisco to Linux box.

The only line enabled in my inittab is id:5:initdefault:

Here is my /etc/event.d/tty1:
start on stopped rc2
start on stopped rc3
start on stopped rc4

stop on runlevel 0
stop on runlevel 1
stop on runlevel 6

respawn
exec /sbin/mgetty tty1

I did a cat /proc/tty/driver/serial after attempting to run minicom:
0: uart:16550A port:000003F8 irq:4 tx:43 rx:0 CTS|DSR|CD|RI

There are always tx: increments but rx: always remains 0

Any ideas ???

As I said in my first post, the getty's are used for INCOMING connections. If the getty's have the ports locked to them, minicom won't get a lock...hardware contention is taking place. Stop the gettys, all of them. Comment them all out in inittab. Remove don't do anything with the tty's at all....whatever you're doing with the tty1, etc., devices, turn it off. Reboot, and minicom should work.

jbochsler 12-28-2009 06:35 PM

Quote:

Originally Posted by TB0ne (Post 3486571)
As I said in my first post, the getty's are used for INCOMING connections. If the getty's have the ports locked to them, minicom won't get a lock...hardware contention is taking place. Stop the gettys, all of them. Comment them all out in inittab. Remove don't do anything with the tty's at all....whatever you're doing with the tty1, etc., devices, turn it off. Reboot, and minicom should work.

Was using FedoraCore 6, upgraded to FedoraCore 12.
Minicom stopped working.
Looks like console-kit-daemon is holding ttya:

[root@localhost ~]# lsof /dev/tty0
lsof: WARNING: can't stat() fuse.gvfs-fuse-daemon file system /home/jackb/.gvfs
Output information may be incomplete.
COMMAND PID USER FD TYPE DEVICE SIZE/OFF NODE NAME
console-k 892 root 11r CHR 4,0 0t0 2175 /dev/tty0

[root@localhost ~]# ps -aef|grep 892
root 892 1 0 15:11 ? 00:00:00 /usr/sbin/console-kit-daemon
root 1986 1760 0 15:29 pts/1 00:00:00 grep 892
[root@localhost ~]#

If I kill console-kit-daemon, I then get garbage on minicom,
however typing on any pty generates garbage on minicom.

Connection works fine under Windows, so the hw and speed are
correct.

Is there a way to tell console-kit-daemon to leave ttya alone?

thx,
jack


All times are GMT -5. The time now is 11:30 PM.