LinuxQuestions.org
Support LQ: Use code LQ3 and save $3 on Domain Registration
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 08-05-2006, 04:47 AM   #1
michshelly
Member
 
Registered: Feb 2006
Posts: 71

Rep: Reputation: 15
FD5 and Slackware on hdb1-4


Hi,

I have Fedora Core 5 and have just installed Slackware (I think).

Grub was installed with FC.

When I installed Slackware it said Lilo couldn't be installed. I thought that grub would pick up Slackware and give me the option on which OS to boot. It is not.

So could someone please tell me what file to configure or whatever I have to do, so I can load Slackware or FC, please?

Here's what fdisk -l shows:

/dev/hdb1 * 1 2295 83 Linux
/dev/hdb2 2296 4207 83 Linux
/dev/hdb3 4208 4589 82 Linux swap /Solaris
/dev/hdb4 4590 9729 83 Linux (Slackware on here??)

I don't know why Solaris is there or is this normal? Does it have something to do with a usb drive that had rubbish on it?

Should I put Slackware in the grub.conf file along with the Fedora Core info in there?

I'm looking forward to your answers.

Thanks
Michshelly

Last edited by michshelly; 08-05-2006 at 05:33 AM.
 
Old 08-05-2006, 05:47 AM   #2
michshelly
Member
 
Registered: Feb 2006
Posts: 71

Original Poster
Rep: Reputation: 15
I have a thought and wonder if someone can tell me if it's right.

Shall I add the lines below to the grub.conf file?

[HTML]title Slackware (version num)
root (hd0,0)
kernel /boot/vmlinuz-?.?.? ro root= LABEL=/ rhgb quiet
initrd /boot/initrd0?.?.? _SW.im[/HTML]


I'll have to find the version number etc.

Would this work, do you think?

Thanks
Michshelly
 
Old 08-07-2006, 05:50 AM   #3
Tinkster
Moderator
 
Registered: Apr 2002
Location: in a fallen world
Distribution: slackware by choice, others too :} ... android.
Posts: 23,066
Blog Entries: 11

Rep: Reputation: 910Reputation: 910Reputation: 910Reputation: 910Reputation: 910Reputation: 910Reputation: 910Reputation: 910
The recommended way to work this (since the installations don't share /boot)
would be to install lilo in slack into its root-partition, and just chainload
slack from grub.

Something like
Code:
title         Slackware
root          (hd0,3)
makeactive
chainloader   +1
Any grub experts in the house please feel free to chime in on
the numbering ... ;}


Cheers,
Tink
 
Old 08-07-2006, 06:49 AM   #4
michshelly
Member
 
Registered: Feb 2006
Posts: 71

Original Poster
Rep: Reputation: 15
Hello Tinkster,

Thanks so very much for answering me and helping.

I shall have a go at what you said. When I install lilo, can i just execute from where ever it is in Slackware?

I probably won't get a chance to do this until Wed or the weekend. I shall let you know how I go though.

Thanks again

Michshelly
 
Old 08-07-2006, 02:32 PM   #5
Tinkster
Moderator
 
Registered: Apr 2002
Location: in a fallen world
Distribution: slackware by choice, others too :} ... android.
Posts: 23,066
Blog Entries: 11

Rep: Reputation: 910Reputation: 910Reputation: 910Reputation: 910Reputation: 910Reputation: 910Reputation: 910Reputation: 910
If you manage to get into your slackware install via boot-cd make sure that
slacks /etc/lilo.conf boot entry points at "boot = /dev/hdb4", and run lilo.

After that the chainloading via Grub should be all good.


Cheers,
Tink
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Updating FD3 to FD5 pranavojha Fedora 4 04-18-2006 10:16 AM
mounting hdb1-3 (gentoo?) post_break Linux From Scratch 3 03-22-2006 12:51 AM
slackware mount: /dev/hdb1 is not a valid block device piva.francesco Linux - Hardware 7 03-25-2005 12:08 PM
Slackware 10 doesn't see hdb1 in cfdisk emer_son Slackware - Installation 6 07-25-2004 09:04 PM
hdb1 hdb1 spooge Linux - Hardware 12 02-22-2003 07:11 PM


All times are GMT -5. The time now is 11:59 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration