LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 07-10-2007, 01:26 PM   #1
jCash
Member
 
Registered: Sep 2006
Posts: 57

Rep: Reputation: 15
FC6 groupadd useradd Not working


Why can't I issue these command: groupadd, useradd? I am running FC6.

[root@localhost home]# chown -R mysql:mysql /home/me/mysql
chown: `mysql:mysql': invalid user
[root@localhost home]# groupadd mysql
bash: groupadd: command not found
[root@localhost home]# useradd -g mysql mysql
bash: useradd: command not found
 
Old 07-10-2007, 01:39 PM   #2
custangro
Senior Member
 
Registered: Nov 2006
Location: California
Distribution: Fedora , CentOS , RHEL
Posts: 1,977
Blog Entries: 1

Rep: Reputation: 209Reputation: 209Reputation: 209
when you became root did you use the "-"? For example: "su -"

If not then you need to use the "-" in order to inherit the shell. Otherwise you need to use the full path (e.g. /sbin/groupadd)

If neither of the above aplies to you then you might want to do a: which useradd or whereis useradd

Last edited by custangro; 07-10-2007 at 01:42 PM.
 
Old 07-31-2007, 09:37 PM   #3
Linux_Enabled
LQ Newbie
 
Registered: Jul 2007
Location: Richmond, VA
Posts: 2

Rep: Reputation: 0
Thumbs up Thank You!

I had spent hours trying to figure out what the problem was. After reading your response (#2), I was able to do exactly what I wanted to do all day. I'm still learning Linux commands and don't yet have a reference book. You're awesome. Thanks again.
Linux_Enabled
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
useradd not working haora Linux - Newbie 2 04-19-2005 07:37 AM
groupadd and useradd bash commands ph0ngwh0ng Linux - Newbie 1 04-28-2004 11:42 AM
'useradd' not working. reesee Linux - Newbie 1 02-28-2004 12:05 PM
Useradd not working HaZaRdOuS Linux From Scratch 2 11-25-2003 10:08 PM
Groupadd and useradd for RH 8.0 ??? edhan Linux - Newbie 12 10-07-2003 11:08 PM


All times are GMT -5. The time now is 04:28 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration