LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Newbie (http://www.linuxquestions.org/questions/linux-newbie-8/)
-   -   FC4 reports Gnome not operating correctly (http://www.linuxquestions.org/questions/linux-newbie-8/fc4-reports-gnome-not-operating-correctly-416683/)

Mark_in_Hollywood 02-17-2006 06:24 PM

FC4 reports Gnome not operating correctly
 
This post follows up the earlier problem with the subject heading:

Modem attempts during boot.

After "resolving" that problem by unplugging the phone line and re-booting, I have been able to get back onto the 'net.

However, after entering my user/password I receive the following "error" message:

Could not look up internet address of localhost.localdomain. This will prevent Gnome from operating correctly. It may be possible to correct this problem by adding localhost.localdomain to the file /etc/hosts.

[then there are two radio buttons]

Log-in anyway or Re-try.

Re-try does nothing and Log-in gets me to work.

However, I can no longer print from gedit, or OOo.writer. The modem (dial-up) gets lost or something, and I have to re-invoke the Network Device Control by de-activating and then activating the modem. I have no file hosts in /etc/hosts. I can't even tell if the /hosts is a directory and a file or what. Nor whether there is a correlation between the foregoing error message and the printer not printing. And/or whether the modem "losing" it's place on the 'net is related to the printer and/or foregoing error message.

Is there any applet that can be installed that shows the modem connection and the duration of the on-line session?

pljvaldez 02-17-2006 06:43 PM

I believe for gnome you're looking for something like ppp-config for the dialup stuff...

/etc/hosts is a file that exists on most systems and has a few entries to resolve names with IP's. Usually the entry is something like:

127.0.0.1 localhost localhost.localdomain
192.168.0.40 mymachine mymachine.mydomain.net

Where the second line would be what you configured for a hostname when you booted up. This line may not be there if you have a different IP every time you connect to the internet...

Mark_in_Hollywood 02-18-2006 12:18 PM

OK, I've added a file: hosts

The only line in it is:

127.0.0.1 localhost localhost.localdomain

my dial-up isp dynamically issues dns/ip addresses (or something like that) anyway my ip is never the same twice.

Meanwhile, trying to find ppp-config per Mr. Valdez, above, I stumbled a post about wvdial and modem-lights at the gnome.org. I downloaded the GTK version of this from: sourceforge.net/projects/gppp, and (WOW is Linux ever great), once downloaded, the program asked me if I wanted it installed. Yes, I clicked. And off it went. Then trouble, it asked for FC4 disk 2 (which I made 3 days ago). But something blew up because the disk wasn't able to reply to the requester, and I, sadly, had to cancel the install. Yet, the GTKppp is listed in my Panel/Desktop/Internet/

as GTKdial. Nothing happens when called from there.

Next, I looked all over my filessystem for wvdia*.*. Found only wvdial.config files. One of which, because I'm not the owner of, won't even let me read it while I'm logged in as /.

The FC4 cd-rom .iso 's icon is sitting on the desktop, and it can be explored without problem.

The File Browser reports the CD as being named: FC4-i386.disk2.iso.

Any one?

dipenchaudhary 02-18-2006 12:35 PM

hi ..
the error ur getting is due to invalid hostname settings .. okk to be frank i dont get ur doubt regarding modem and all .. but to resolve that issue try this :
be root and issue this command

#hostname

this shud print the host name ... ARE U ON NETWORK ? now if u have a ethernet card with some IP .. then add the entry of ur ethernet card's IP with ur hostname

eg if ur hostname displayed above is ..
mark.codes and ur ethernet ip is .. 192.168.0.1

ur /etc/hosts entry should be like

192.168.0.1 mark.codes mark

keep in mind that if ur network fails to comeup during boot time and u have no IP for ethernet .. it will again show this error

OR .. if u dont have ethernet .. then change ur hostname to localhost.localdomain which is ur loop back interface ....

which shud be done by ... logging into root and issuing this command

#hostname localhost.localdomain

make sure u have a valid /etc/hosts if by any reason u dont have this file .. make one ...

also crosscheck one more thing ... on shell issue this command

# cat /etc/nsswitch.conf

and locate the section called hosts it shud be like this

hosts files dns

this shud solve ur problem with the error .. now regarding modem . i really dont get ur problem .. and if ur asking for a network monitor applet .. then there are two network monitor for ppp0 .. right click on ur panel and select ADD TO PANEL
scroll down and choose network monitor

all the best ... and regarding that printing problem .. are u trying to access printer on network ?

FINALLY LAST RESORT .. even if the command
#hostname localhost.localdomain
does not solve ur problem .. then click on
APPLICATIONS-->SYSTEM SETTINGS ---> NETWORK ---> DNS TAB
change the hostname ... and save ... u shud be root .. if u give any hostname other than localhost.localdomain .. u shud make sure that corresponding interface is working ... which can be checked by

#ifconfig
localhost.localdomain operates on lo
and yehh dont give the address of ur ppp0 coz its dynamic and will change on every boot .. in fact within one session if u disconnect n reconnect

okk if this doesnt solve problem .. post back

all the best

dipenchaudhary 02-18-2006 12:36 PM

by the way .. its not a problem on Gnome but a problem of bad settings ..

Mark_in_Hollywood 02-18-2006 11:17 PM

Dear Mr. Chaudhary (et alia)

I have tried your solutions to no avail. But I have realized how to better explain what is happening.

When I first installed the modem, it worked just fine. So I config'ed the dial-up to dial at boot-time. This was a mistake. I probably don't know how to do this, but it's likely possible. When the computer next booted, it couldn't complete the connection. Fedora hung. I solved that by unplugging the modem and rebooting. That was the first time I got the /etc/hosts error message.

I probably need to figure out how to tell Fedora to stop trying to network at boot. I hope nothing more.

The applet Modem Lights from Add to Panel, even though commanded to connect, fails. That's a non-problem, until I convince FC4 to not look for a network connection at startup.

Any ideas about that, sir?

dipenchaudhary 02-18-2006 11:50 PM

yes dear
there is a work around for that .. login as root .. browse to this path
/etc/sysconfig/network-scripts/
there must be a configuration file something by the name ..ifcfg-ppp
open it in a text editor ...
there will be a option called
ON BOOT = yes
make it no
save it .. and reboot
it wont come up on boot ... but i guess hostname is not related to that ..dont know .. maybe !! did u ever tried to play with ur hostname ...
can u paste me the output of two commands ?

#hostname
and
#cat /etc/hosts

dipenchaudhary 02-18-2006 11:50 PM

dont call me sir !! it piss me off really !!

Mark_in_Hollywood 02-19-2006 12:18 PM

Chaudhary

Here is what you are asking for, I hope. Please bear with me, I can still count the number of days I've been a Linux user on my little hands and toes.

Response to hostname

LAFreeNet

localhost

response to #cat /etc/nsswitch.conf

#
# /etc/nsswitch.conf
#
# An example Name Service Switch config file. T his file should be
# sorted with the most-used services at the beginning.
#
# The entry '[NOTFOUND=return]' means that thesearch for an
# entry should stop if the search in the previous entry turned
# up nothing. Note that if the search failed due to some other reason
# (like no NIS server responding) then the search continues with the
# next entry.
#
# Legal entries are:
#
# nisplus or nis+ Use NIS+ (NIS v ersion 3)
# nis or yp Use NIS (NIS version 2), also called YP
# dns Use DNS (Domain Name Service)
# files Use the local f iles
# db Use the local d atabase (.db) files
# compat Use NIS on compat mode
# hesiod Use Hesiod foruser lookups
# [NOTFOUND=return] Stop searchingif not found so far
#

# To use db, put the "db" in front of "files" f or entries you want to be
# looked up first in the databases
#
# Example:
#passwd: db files nisplus nis
#shadow: db files nisplus nis
#group: db files nisplus nis

passwd: files
shadow: files
group: files

#hosts: db files nisplus nis dns
hosts: files dns

# Example - obey only what nisplus tells us...#services: nisplus [NOTFOUND=return] files
#networks: nisplus [NOTFOUND=return] files
#protocols: nisplus [NOTFOUND=return] files
#rpc: nisplus [NOTFOUND=return] files
#ethers: nisplus [NOTFOUND=return] files
#netmasks: nisplus [NOTFOUND=return] files

bootparams: nisplus [NOTFOUND=return] files

ethers: files
netmasks: files
networks: files
protocols: files
rpc: files
services: files

netgroup: files

publickey: nisplus

automount: files
aliases: files nisplus


Response to #ifconfig

lo Link encap:Local Loopback
inet addr:127.0.0.1 Mask:255.0.0.0
inet6 addr: ::1/128 Scope:Host
UP LOOPBACK RUNNING MTU:16436 Metric:1
RX packets:1382 errors:0 dropped:0 overruns:0 frame:0
TX packets:1382 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:0
RX bytes:1544059 (1.4 MiB) TX bytes:1544059 (1.4 MiB)

ppp0 Link encap:Point-to-Point Protocol
inet addr:66.81.22.40 P-t-P:69.19.219.54 Mask:255.255.255.255
UP POINTOPOINT RUNNING NOARP MULTICAST MTU:1500 Metric:1
RX packets:462 errors:0 dropped:0 overruns:0 frame:0
TX packets:515 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:3
RX bytes:178561 (174.3 KiB) TX bytes:73313 (71.5 KiB)

Next response:

#ifcfg-LAFN_1

# Please read /usr/share/doc/initscripts-*/sysconfig.txt
# for the documentation of these parameters.
ONBOOT=no
USERCTL=yes
PEERDNS=yes
TYPE=Modem
DEVICE=ppp0
BOOTPROTO=dialup
AC=off
BSDCOMP=off
VJCCOMP=off
CCP=off
PC=off
VJ=off
LINESPEED=115200
MODEMPORT=/dev/ttyS14
PROVIDER=LAFN
DEFROUTE=yes
PERSIST=yes
PAPNAME=rlnielsen
WVDIALSECT=LAFN_1
MODEMNAME=Modem0
DEMAND=no
IPV6INIT=no
IDLETIMEOUT=600

Response to ifcfg-LAFN_2

# Please read /usr/share/doc/initscripts-*/sysconfig.txt
# for the documentation of these parameters.
IPV6INIT=no
ONBOOT=no
USERCTL=yes
PEERDNS=yes
TYPE=Modem
DEVICE=ppp1
BOOTPROTO=dialup
AC=off
BSDCOMP=off
VJCCOMP=off
CCP=off
PC=off
VJ=off
LINESPEED=115200
MODEMPORT=/dev/ttyS14
IDLETIMEOUT=600
PROVIDER=LAFN
DEFROUTE=no
PERSIST=yes
PAPNAME=rlnielsen
WVDIALSECT=LAFN_2
MODEMNAME=Modem0
DEMAND=no


Response to ifcfg-LAFN_3

# Please read /usr/share/doc/initscripts-*/sysconfig.txt
# for the documentation of these parameters.
ONBOOT=no
USERCTL=yes
PEERDNS=yes
TYPE=Modem
DEVICE=ppp2
BOOTPROTO=dialup
AC=off
BSDCOMP=off
VJCCOMP=off
CCP=off
PC=off
VJ=off
LINESPEED=115200
MODEMPORT=/dev/ttyS14
PROVIDER=LAFN
DEFROUTE=no
PERSIST=yes
PAPNAME=rlnielsen
WVDIALSECT=LAFN_3
MODEMNAME=Modem0
DEMAND=no
IPV6INIT=no
IDLETIMEOUT=600


Response to ifcfg-lo

DEVICE=lo
IPADDR=127.0.0.1
NETMASK=255.0.0.0
NETWORK=127.0.0.0
# If you're having problems with gated making 127.0.0.0/8 a martian,
# you can change this to something else (255.255.255.255, for example)
BROADCAST=127.255.255.255
ONBOOT=yes
NAME=loopback

and lastly:

[root@LAFreeNet ~]# cat /etc/hostnames
cat: /etc/hostnames: No such file or

[root@LAFreeNet ~]# hostname
localhost

Had lunch. Re-booted linux, received a message to save and report a BUG, which follows:

Component: system-config-network
Version: 1.3.26
Summary: TBf84f50f3 GUI_functions.py:408:gui_run:UnboundLocalError: local variable 'status' referenced before assignment

Traceback (most recent call last):
File "/usr/bin/system-control-network", line 198, in on_configureButton_clicked
(ret, msg) = dev.configure()
File "/usr/src/build/556832-noarch/install/usr/share/system-config-network/netconfpkg/NCDevice.py", line 409, in configure
File "/usr/src/build/556832-noarch/install/usr/share/system-config-network/netconfpkg/NC_functions.py", line 653, in generic_run
File "/usr/src/build/556832-noarch/install/usr/share/system-config-network/netconfpkg/gui/GUI_functions.py", line 408, in gui_run
UnboundLocalError: local variable 'status' referenced before assignment

Local variables in innermost frame:
catchfd: (1, 2)
fderr: []
gtk: <module 'gtk' from '/usr/lib/python2.4/site-packages/gtk-2.0/gtk/__init__.pyc'>
string: <module 'string' from '/usr/lib/python2.4/string.pyc'>
fdout: []
read: 6
errno: 4
fdin: [6]
argv: ['/usr/bin/system-config-network', '']
write: 7
s:
searchPath: 0
command: /usr/bin/system-config-network
closefd: -1
rc: Xlib: connection to ":0.0" refused by server

Xlib: No protocol specified


ERROR: Unable to initialize graphical environment. Most likely cause of failure is that the tool was not run using a graphical environment. Please either start your graphical user interface or set your DISPLAY variable.

msg: Interrupted system call
root: /
os: <module 'os' from '/usr/lib/python2.4/os.pyc'>
childpid: 3129
select: <module 'select' from '/usr/lib/python2.4/lib-dynload/selectmodule.so'>
stdin: 0


All of this because I tried to install GTKdialer. Since my linux can't/won't read the FC$-i386-disk2.iso to install whatever is needed. Any suggestions appreciated.

dipenchaudhary 02-20-2006 05:30 AM

hi
wot are ur current problems ? so now did u stop ur dialup connection from coming on boot ? and for that error of invalid hostname or something
login as root ..
#hostname localhost.localdomain
create a file by the name hosts in /etc with this entry
127.0.0.1 localhost.localdomain localhost
and save !!
also change the file .. /etc/sysconfig/network
NETWORKING=yes
HOSTNAME=localhost.localdomain
like this and save the file
restart and lets see wot happened ?
wot r ur current problems ?

Mark_in_Hollywood 02-20-2006 12:50 PM

OK, so I went to edit the /etc/sysconfig/network file, again. Yes, it says

HOSTNAME=LAFN.org

yet, when I tried to edit, (gedit), the file is READ-ONLY. When I googled gedit read-only I learn that Gnome can't edit this file (or others).

I am trying to track down a text editor.

pljvaldez 02-20-2006 01:02 PM

you probably just need to su to root and then gedit the file or use nano... I'm sure if you ls -l /etc/sysconfig/network, it'll show that it's only editable by root.

Mark_in_Hollywood 02-20-2006 06:49 PM

Tried to change user as:

su

and

su -

neither worked, so far.

pljvaldez 02-20-2006 06:52 PM

Try using one of these:

http://www.yolinux.com/TUTORIALS/Lin...rking.html#GUI

Mark_in_Hollywood 02-20-2006 09:25 PM

Upon completion of suggestons by Chaudhary, the problem of incorrect DNS/Localdomain.local host is resolved.

Thanks to everyone who helped.


All times are GMT -5. The time now is 07:23 PM.