LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Newbie (http://www.linuxquestions.org/questions/linux-newbie-8/)
-   -   FC17 killed ethernet (http://www.linuxquestions.org/questions/linux-newbie-8/fc17-killed-ethernet-4175415905/)

yangou 07-10-2012 09:55 AM

FC17 killed ethernet
 
Hi everyone

I have upgraded from FC16 to FC17 and it seems that FC17 killed my
Ethernet card. :confused:

ifconfig shows:
lo and p37p1

Kustom42 07-10-2012 11:49 AM

This is a new feature, instead of using the traditional eth0 eth1 etc.. it now uses BIOS naming to label interfaces.

If you do a tcpdump on p37p1 interface are you getting traffic?

---------- Post added 07-10-12 at 09:50 AM ----------

Here's some red-hat docs to explain the changes to you.

http://docs.redhat.com/docs/en-US/Re...ce_Naming.html

yangou 07-11-2012 09:54 AM

Hi

Thanks for your reply.

tcpdump -i p37p1 gives me:

tcpdump = WARNING: p37p1 = no IPv4 address assigned.

but if I go to /etc/sysconfig/network-scripts/ there is no p37p1 file to edit.

Should I just create one?

Thanks a lot.

Kustom42 07-11-2012 12:27 PM

You should be able to just rename or copy your ifcfg-eth0 file to be named ifcfg-p37p1 and restart networking.

Some more info on it:

How It Works

biosdevname uses information from the system's BIOS, specifically the type 9 (System Slot) and type 41 (Onboard Devices Extended Information) fields contained within the SMBIOS. If the system's BIOS does not have SMBIOS version 2.6 or higher and this data, the new naming convention will not be used. Most older hardware does not support this feature because of a lack of BIOSes with the correct SMBIOS version and field information. For BIOS or SMBIOS version information, please contact your hardware vendor. For this feature to take effect, the biosdevname package must also be installed. The biosdevname package is part of the "base" package group in RHEL 6.1. All install options, except for "Minimal Install", include this package. It is not installed on upgrades of RHEL 6.0 to RHEL 6.1.
How To Enable/Disable

To disable this feature on Dell systems that would normally have it on by default, pass "biosdevname=0" on the boot command line, both during and after installation. To enable this feature on other system types that meet the minimum requirements (see "How It Works"), pass "biosdevname=1" on the boot command line, both during and after installation. Unless the system meets the minimum requirements, "biosdevname=1" will be ignored and the system will boot with the traditional network interface name format. If the "biosdevname" install option is specified, it must remain as a boot option for the lifetime of the system.
Notes For Administrators

Many system customization files can include network interface names, and thus will require updates if moving a system from the old convention to the new convention. If you use the new naming convention, you will also need to update network interface names in areas such as custom iptables rules, scripts altering irqbalance, and other similar configuration files. Also, enabling this change for installation will require modification to existing kickstart files that use device names via the "ksdevice" parameter; these kickstart files will need updated to use the network device's MAC address or the network device's new name. Red Hat strongly recommends that you consider this feature to be an install-time choice; enabling or disabling the feature post-install, while technically possible, can be complicated and is not recommended. For those system administrators who wish to do so, on a system that meets the minimum requirements, remove the /etc/udev/rules.d/70-persistent-net.rules file and the HWADDR lines from all /etc/sysconfig/network-scripts/ifcfg-* files. In addition, rename those ifcfg-* files to use this new naming convention. The new names will be in effect after reboot. Remember to update any custom scripts, iptables rules, and service configuration files that might include network interface names.

yangou 07-12-2012 05:13 AM

Thanks for the info.

There is not an ifcfg-eth0 file inside /etc/sysconfig/network-scripts to rename.:confused:

I can only see ifcfg-lo which is the loopback thing.

I also tried creating one and entered the following:

DEVICE=ifcfg-p37p1
BOOTPROTO=dhcp
ONBOOT=yes


I then stopped the network service but it failed to start.

If you have anymore suggestions please let me know.

Kustom42 07-12-2012 10:58 AM

Ok well the "DEVICE" directive should be just p37p1 so it may be just that easy to get it to work. Also, since the network is failing to start, review the messages file so we can figure out the exact error, or try using the ifup command so the stderr is redirected to your screen so you can see the actual errors.

yangou 07-13-2012 09:23 AM

Solved
 
Hi again

I am sorry for wasting your time but it turned out the problem to be a bad ethernet cable.
I have changed the DEVICE name to p37p1. The file is still there.
I am not sure if its being used but Internet is back now

Many thanks for your help.


All times are GMT -5. The time now is 08:56 PM.