LinuxQuestions.org
Review your favorite Linux distribution.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices



Reply
 
Search this Thread
Old 05-25-2006, 02:27 PM   #1
stutes
LQ Newbie
 
Registered: Dec 2005
Posts: 4

Rep: Reputation: 0
FC1 Trying to mount second hard drive (HDB7) format ext3 with no luck


Noob here, just installed Fedora Core 1 (believe it is AKA Yarrow?).

My system has a second hardrive that is a Seagate, 160gb. I'm trying to access this, so that I can start storing data on it (in the long run, I'd like this to be my "home", but I'm save that configuring for later).

Right now I just want to get it mounted.

Right now the partitions that reside on hdb are this:
hdb1 ntfs
hdb2 ntfs
hdb3 ext3
hdb4 extended
hdb5 ext3
hdb6 linux-swap
hdb7 ext3

I really have no idea where hdb1-6 came from. I can only guess that they are from installing XP and Fedora Core 1, and that they are being used as swap space of some sort.

As of last night hdb7 was free space (113663mg). I used a mix of info from the site fedoranews.org/tchung/storage and the book "Linux for Non Geeks" to try and figure out how to format and mount the free space.

I think I formatted hdb7 correctly, as it now appears listed as ext3 in the Hardware Browser.

In the terminal, when I enter "df" I get this:
Filesystem 1K-blocks Used Available Use% Mounted on
/dev/hda3 14610964 2737632 11131132 20% /
/dev/hda2 101105 6348 89536 7% /boot
none 386804 0 386804 0% /dev/shm

Not sure what the "none" is.

In the fstab file I have this:
LABEL=/1 / ext3 defaults 1 1
LABEL=/boot1 /boot ext3 defaults 1 2
LABEL=/home2 /home2 ext3 defaults 1 2
none /dev/pts devpts gid=5,mode=620 0 0
none /proc proc defaults 0 0[/url]
none /dev/shm tmpfs defaults 0 0
/dev/hdb6 swap swap defaults 0 0
/dev/hda5 swap swap defaults 0 0
/dev/cdrom /mnt/cdrom udf,iso9660 noauto,owner,kudzu,ro 0 0
/dev/cdrom1 /mnt/cdrom1 udf,iso9660 noauto,owner,kudzu,ro 0 0

Instead of LABEL=/home2... (which does not appear to mount the drive) I've also tried this:
/dev/hdb7 /mnt/home2 ext3 auto,rw,uid=andy,users 1 2
/dev/hdb7 /mnt/home2 ext3 auto,rw,uid=andy,users 0 0
/dev/hdb7 /mnt/home2 ext3 auto,rw,uid=andy,users 1 3

When I do any of the above, I get this error:
mount: wrong fs type, bad option, bad superblock on /dev/hdb7,
or too many mounted file systems

The directory "home2" does exist in the "mnt" directory, btw.

I assume that mounting a second drive is within the realm of Fedora Core 1, so the question is how.

Any help is appreciated.

Andy
 
Old 05-25-2006, 03:15 PM   #2
theNbomr
LQ 5k Club
 
Registered: Aug 2005
Distribution: OpenSuse, Fedora, Redhat, Debian
Posts: 5,396
Blog Entries: 2

Rep: Reputation: 903Reputation: 903Reputation: 903Reputation: 903Reputation: 903Reputation: 903Reputation: 903Reputation: 903
Your ext3 partition may not have the label /home2.

To simplify matters, why not just start with basic commandline stuff:

Code:
su -
mount -t ext3 /dev/hdb7 /mnt/home2
Assuming that works,

Code:
umount /home2
/sbin/e2label /dev/hdb7 /home2
If it doesn't, then come back here with more info and further question(s).

BTW, the line 'none 386804 0 386804 0% /dev/shm' has to do with shared memory block allocation, and isn't related to your issues.

--- rod.
 
Old 05-26-2006, 12:17 AM   #3
stutes
LQ Newbie
 
Registered: Dec 2005
Posts: 4

Original Poster
Rep: Reputation: 0
Rod, thanks for the reply!

The following worked like a charm:
Code:
su -
mount -t ext3 /dev/hdb7 /mnt/home2
For the unmounting I had to do this instead:
Code:
umount /mnt/home2
It wouldn't work like this:
Code:
umount /home2
Next I tried this:
Code:
/sbin/e2label /dev/hdb7 /home2
Not sure how I would test the success of this, so I rebooted to see if the partition would mount automatically. It didn't. I got the error that I'd seen before... "mount: wrong fs type, bad option, bad superblock on /dev/hdb7, or too many mounted file systems"

I then tried right clicking on the desktop and selecting "Disks>home2", but I get the same error as above doing this.

I then went back to terminal and typed in what you suggested earlier:
Code:
mount -t ext3 /dev/hdb7 /mnt/home2
This way it mounts just fine. I see it on the desk top, and can open it to see a directory named "lost+found" (have no clue what that is about).

Do I need to change the fstab? fstab currently reads thus:
LABEL=/1 / ext3 defaults 1 1
LABEL=/boot1 /boot ext3 defaults 1 2
none /dev/pts devpts gid=5,mode=620 0 0
none /proc proc defaults 0 0
none /dev/shm tmpfs defaults 0 0
/dev/hdb6 swap swap defaults 0 0
/dev/hda5 swap swap defaults 0 0
/dev/cdrom /mnt/cdrom udf,iso9660 noauto,owner,kudzu,ro 0 0
/dev/cdrom1 /mnt/cdrom1 udf,iso9660 noauto,owner,kudzu,ro 0 0
/dev/hdb7 /mnt/home2 ext3 auto,rw,uid=andy,users 1 2

Perhaps I didn't format it correctly. I read on another post the following:
Quote:
To format, you should use mke2fs -j /dev/hdbX, where X is the partition number to format. The default filesystem type is ext2. The -j option makes it a journaled filesystem (ext3).
I did not do the above. Instead I did this:
Code:
[root@mm andy]# mkfs.ext3 -L /home2 /dev/hdb7
Would my problem stem from the above method of formatting? Or perhaps my error lies in how I created the partition even?

Again, thanks for the reply!

Andy

Last edited by stutes; 05-26-2006 at 12:48 AM.
 
Old 05-26-2006, 10:29 AM   #4
theNbomr
LQ 5k Club
 
Registered: Aug 2005
Distribution: OpenSuse, Fedora, Redhat, Debian
Posts: 5,396
Blog Entries: 2

Rep: Reputation: 903Reputation: 903Reputation: 903Reputation: 903Reputation: 903Reputation: 903Reputation: 903Reputation: 903
To unmount the partition, you got it right. My bad.

Not sure why the labled partition wouldn't mount in fstab. Your method is just fine anyway. In theory, if you re-arrange your disk hardware so that the drive becomes hdc or hdd, the labled partition should still cause mount/fstab to find and mount it properly. You could try playing with the leading slash on the disk label and in the corresponding fstab entry. I seem to recall being tripped up by that once.

I'm pretty sure your formatting is exactly equivalent to the suggestion you quoted.


--- rod.

Last edited by theNbomr; 05-26-2006 at 10:31 AM.
 
Old 05-26-2006, 10:36 AM   #5
theNbomr
LQ 5k Club
 
Registered: Aug 2005
Distribution: OpenSuse, Fedora, Redhat, Debian
Posts: 5,396
Blog Entries: 2

Rep: Reputation: 903Reputation: 903Reputation: 903Reputation: 903Reputation: 903Reputation: 903Reputation: 903Reputation: 903
Just reviewing your fstab, I think the line referencing the home2 partition should look more like:

Code:
LABEL=/home2 /home2 ext3 defaults 0 0
Try that. Also try

man fstab

--- rod.
 
  


Reply

Tags
ext3, fedora, mount, troubleshoot


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Mount ext3 hard drive with umask=0 trpn Linux - General 6 09-13-2008 08:41 PM
attempting to format second hard drive to ext3 irishxpride Linux - Hardware 8 01-30-2008 04:43 AM
how to mount a external hard drive in ext3 format? kuertensun Linux - Newbie 12 09-06-2005 07:51 PM
Cannot mount ext3 filesystem on damaged hard drive Mathieu_G Linux - Hardware 3 04-01-2005 11:51 PM
Strange Problem: Install freezes on format of HDB7 or copying files to HDB7 cowboy45 Mandriva 0 08-19-2004 12:26 AM


All times are GMT -5. The time now is 11:42 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration