LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices



Reply
 
Search this Thread
Old 08-16-2004, 11:14 AM   #1
BWebb
Member
 
Registered: Jan 2004
Posts: 32

Rep: Reputation: 15
FC-2 / WinXP Dual Boot hangs at GRUB


To My Saviors...

Whenever I have had problems in the past they have been solved here. Hopefully, this will not be the exception. On with the story...

Problem:
After Fedora Core 2 (FC2) install, the GRUB boot loader does not come up after system reboot. Instead, all I get is a black screen with the word 'GRUB' in the upper left corner, along with a blinking cursor that is non-responsive. The only key sequence that works is ctrl+alt+del, which allows me to reboot but has the same result. Note: there were absolutely NO warning/error messages during the FC2 installation.

Background:
I have a Dell PC with Windows XP installed on /dev/hda. I would like to run a dual boot system with Fedora Core 2 (FC2) installed on a separate harddrive. I installed an 80GB Maxtor as a slave drive. Mounted it in one of the 5.25" media bays and hooked it up with the IDE connector in between the mother board and my CD+RW drive. Booted into XP to ensure that the new drive was recognized...it was.

System Hardware:
I have a 100MB Zip drive connected via IDE (same ribbon as XP hard drive), the XP drive connected via IDE, a CD+RW drive connected via IDE (same ribbon as FC2 drive), and the newest FC2 drive on an IDE cable.

Begin FC2 Install:
Shut the system down and booted from FC2 disk 1 to start the installation on the new harddrive. Anaconda started, went through the introductory steps about language and whatnot. When it came to the partitioning options, I chose to let FC2 partition the new drive on its own but opted to verify the partitions in Disk Druid. Anaconda correctly identified my XP drive as /dev/hda (I chose to leave it alone since it is already a working install) and the new 80GB drive as /dev/hdd. I suppose it chose /hdd instead of /hdb because I have two other IDE drives installed in addition to the /hda for XP?

Disk Druid:
FC2 partitioned the new hard drive (and left /hda alone....thank goodness!) in the following manner:
/dev/hdd >
/hdd1 /boot ext3 100MB
/hdd2 / ext3 77.8GB
/hdd3 swap 1024MB

Boot Loader:
I chose to use the GRUB boot loader offered by FC2 simply because I use it on my dual boot systems at work and am very comfortable with it. The GRUB configuration detected/listed both drives as:
Other /dev/hda
Fedora Core 2 /dev/hdd
and I opted to use FC2 as the default.

Continued Install:
Fedora Core 2 ran through all 4 disks with absolutely no error/warning messages and prompted me to remove all media and reboot the system. Upon reboot, however, the GRUB boot loader interface does not appear. Instead, I get a blank screen that just says 'GRUB' along with a blinking cursor that is non-responsive.

Investigation:
Okay, so somewhere in my two-hour Google search last night I stumbled upon some guidance that suggested I install GRUB on the MBR (master boot record). Here's the link if anyone is interested:

Installing GRUB on the MBR

I rebooted my machine with the FC2 disk and entered the 'linux rescue' mode. I followed the steps outlined in the link above:
> chroot /mnt/sysimage
> grub
...Brings up GRUB
grub> find /boot/grub/stage1

Uh-oh...there is no stage1 in /boot/grub. It looks like GRUB didn't properly install itself?

There is, also, another problem that I see in the grub.conf file: under the Fedora Core entry, it has the following line: root (hd1,0). If FC2 recognizes the new harddrive as /hdd and the /boot partition was mounted to /hdd1, then this entry should be changed to read: root (hd3,0)...correct??? This could be a problem but more than likely is not causing the boot loader malfunction...correct???

My only option is to get the GRUB boot loader to work. Any ideas???

Many thanks!

Bret
P.S. Sorry about the lengthy post, but I know how people like specifics. If I had access to the current grub.conf or menu.lst files, I would have posted them as well.
 
Old 08-16-2004, 11:41 AM   #2
NumbSkullMD
LQ Newbie
 
Registered: Aug 2004
Distribution: Slackware 10.0
Posts: 17

Rep: Reputation: 0
I had the EXACT same problem when I was installing Mandrake. What you need to do is enter the bios setup for your computer (I also have a Dell) by pressing F2 when the "Dell" screen appears. When you enter the bios setup, go down to where you see something like 1st and 2nd HardDrive. The first should have some information in it while the second one should say "none". Edit the second one to be on "Auto" and restart your computer. Everything should work fine and dandy .

 
Old 08-16-2004, 11:49 AM   #3
BWebb
Member
 
Registered: Jan 2004
Posts: 32

Original Poster
Rep: Reputation: 15
Thank you very much for the prompt response, NumbSkullMD. I'll try this when I get home and let you know how it turned out.
 
Old 08-16-2004, 12:11 PM   #4
masand
Guru
 
Registered: May 2003
Location: INDIA
Distribution: Ubuntu, Solaris,CentOS
Posts: 5,522

Rep: Reputation: 58
if grub does not work for u

in resecue mode

try out lilo

edit the lilo.conf.anaconda file
save it to lilo.conf

run
#lilo

regards
gaurav
 
Old 08-16-2004, 03:50 PM   #5
BWebb
Member
 
Registered: Jan 2004
Posts: 32

Original Poster
Rep: Reputation: 15
NumbSkullMD was right on the money!!! So much so, in fact, that as soon as I set the new drive to 'Auto' in the BIOS, FC2 booted up just fine. As a matter of fact, I am typing this in Mozilla and running my FC2 distro! Yeee-Haw!

Thanks, all, for the help...as usual. This is the place to come for fast, reliable help.

Cheers and many thanks!

Bret
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Dual boot WinXP/Debian, grub error booting WinXP ChemBot Linux - General 5 02-22-2007 05:13 PM
dual boot hangs - slack & winxp timoioi Linux - Software 5 10-09-2005 11:18 PM
winXP / FC 2.4 GRUB Dual boot problems again jjisnow Linux - Newbie 4 03-23-2004 10:30 AM
I need help with grub and trying to dual boot rh9 and winxp pro slicker Red Hat 2 08-30-2003 11:44 AM
WinXP, Linux 7.2 - dual boot with grub - help! iamvrc Linux - Software 2 01-25-2002 11:28 AM


All times are GMT -5. The time now is 03:55 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration