LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Newbie (http://www.linuxquestions.org/questions/linux-newbie-8/)
-   -   Fatal server error: No screen found (http://www.linuxquestions.org/questions/linux-newbie-8/fatal-server-error-no-screen-found-668005/)

Seyfo 09-06-2008 02:55 PM

Fatal server error: No screen found
 
I am a new student in linux and recently installed fedora(2.6.25-14.fc9.i686)on a vmware workstation 5. I have no trouble installing it, everything went great. I boot the system and login without any problems. When I type Startx it will act like it is going to boot into graphic mode but instead it will quit and display some text with some error messages within it. Notably the following.

(EE) VMWARE(0): Driver can't support depth 24
(EE) Screen(s) found, but none have a usable configuration.
Fatal server error:
No screen found
xinit: Connection refused (erno 111): unable to connect to X server
xinit: No such process (errno 3): server error.

Any kind of help with regards to this problem will be highly appreciated.

Thanks.

odcheck 09-06-2008 03:21 PM

Without vmware-tools installed = "(EE) VMWARE(0): Driver can't support depth 24"

so you'll have to adjust your /etc/X11/xorg.conf probably.

smehra24 09-07-2008 09:54 AM

try to set the DISPLAY variable
edit .bash_profile file in your home dirctory
DISPLAY=:0.0
export DISPLAY

Seyfo 09-07-2008 01:40 PM

fatal server error No screen found
 
Odcheck, I cannot install vmware tools until I got the operating system running.

Seyfo 09-07-2008 01:44 PM

fatal server error No screen found
 
smehra24, How am I going to do this edition.
try to set the DISPLAY variable
edit .bash_profile file in your home dirctory
DISPLAY=:0.0
export DISPLAY

John VV 09-07-2008 04:24 PM

Fedora 9 is so "cutting edge" that a lot of other software will not work with it yet.

i do believe that the video drivers for 9 do not work with the NEW xorg in vmware
however Fedora 8 should

gumuruhsspj 09-27-2008 12:10 PM

after that??
 
what should we do next...??
u didnt give a solution dude!

OMG... help!

gumuruhsspj 09-27-2008 12:37 PM

the simple solution
 
is the switch back...!!


even we want to install the NVIDIA driver
but what we need to do now is switch back first into the GUI
even NVIDIA is not detected yet ,,, again.

so to do that...what i got
is log as root on CLI

then type
Quote:

setup
choose the latest option
which is similar with X Configuration...

something like that will make you reConfigure your monitor-related
settings...

so turn it back into a small resolution for a working one
800 x 600

and the Hardware should be choose as the Standard one there

OK to confirm...
and then reboot.

Normal again, at least u got the GUI back.
Even the NVIDIA driver may not be installed yet, again.


All times are GMT -5. The time now is 08:50 AM.