LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 02-12-2006, 02:33 PM   #1
smiley_lauf
Member
 
Registered: Jan 2006
Location: NY
Distribution: Fedora 15 x64
Posts: 344

Rep: Reputation: 30
FATAL error: root password not recognized


For some freaking reason I am suddenly getting this error message when I try to use SYNAPTIC pm to install packages:
==
Failed to run /usr/bin/gnome-app-install as user root:
Unable to copy the user's Xauthorization file.

====

Any idea to get this working again??

Ubuntu 5.10 BB GNOME

thanks
 
Old 02-12-2006, 05:04 PM   #2
btmiller
Senior Member
 
Registered: May 2004
Location: In the DC 'burbs
Distribution: Arch, Scientific Linux, Debian, Ubuntu
Posts: 4,275

Rep: Reputation: 370Reputation: 370Reputation: 370Reputation: 370
Did it used to work? If so, you changed something that prevents Synaptic from running with root priviliges, which are required to install packages. You could always try opening a terminal, su'ing to root, and running it.
 
Old 02-12-2006, 05:10 PM   #3
gilead
Senior Member
 
Registered: Dec 2005
Location: Brisbane, Australia
Distribution: Slackware64 14.0
Posts: 4,125

Rep: Reputation: 164Reputation: 164
If you're getting this error after you su, try running the following after the su command (username is the user you were prior to the su):
Code:
/usr/X11R6/bin/xauth merge ~username/.Xauthority
I sometimes have to change the ownership of ~username/.Xauthority back to username after doing this, but apart from that it works fine.
 
Old 02-13-2006, 12:18 AM   #4
smiley_lauf
Member
 
Registered: Jan 2006
Location: NY
Distribution: Fedora 15 x64
Posts: 344

Original Poster
Rep: Reputation: 30
Steve]

I rebooted and then it came back to normal; but when I log off and log back in it starts misbehaving. THis has happened after I trigger-happy installed firestarter in Automatix.

But for now I am fine. Will nto log off.
Iwill keep your suggestion at hand, though.
Regards,
Sl
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
How could normal user obtain root password or change root password ckamheng Debian 18 02-18-2009 11:28 PM
Postgresql error FATAL: user "root" does not exist" cgetty Ubuntu 4 06-21-2005 03:11 PM
root password modify error! BRAHmS Linux - General 2 11-23-2004 04:20 PM
fatal error: root partiton corrupted, can't mount it, can't fsck it. schatoor Linux - General 15 01-31-2004 04:48 PM
Root password not recognized (KDE). . . alpha_male Mandriva 1 09-13-2003 08:11 AM


All times are GMT -5. The time now is 08:02 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration