LinuxQuestions.org
Support LQ: Use code LQ3 and save $3 on Domain Registration
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices

Reply
 
Search this Thread
Old 12-03-2005, 12:26 PM   #1
CapCavernaX
LQ Newbie
 
Registered: Nov 2005
Location: Boston
Distribution: Fedora Core 4 ( Will try Suse + slackware next )
Posts: 14

Rep: Reputation: 0
Post FATAL: Error inserting acpi cpufreq in fedora 4


I just finished reinstalling FC4 and first thing I did was update some packages including getting the latest kernel available from FC4. Will post kernel ver at later time when I'm home to check it!!

The problem is, after installing the new kernel I started getting the fatal error above...


FATAL: Error inserting acpi_cpufreq... ...device not found


I have searched a few forums and extensively searched google. I have found a few mentions of the same problem, some dating to FC3. But I have not found a solution. Can anyone assist? Plz!!!

Thanks Fellas

Specs:

P4 3.2GHZ
1G RAM
ATI AIW 9800
LITE ON DVD-R/RW
ABIT IS7 MOBO
 
Old 12-03-2005, 01:23 PM   #2
ethics
Senior Member
 
Registered: Apr 2005
Location: London
Distribution: Arch - Latest
Posts: 1,522

Rep: Reputation: 45
Think it's some module to use ACPI to detect the CPU frequency etc. i guess if the mobo doesn't support it it fails, mine doesn't work, never gave me any problems
 
Old 12-03-2005, 01:46 PM   #3
Xyem
Member
 
Registered: Apr 2005
Distribution: Fedora Core 4
Posts: 100

Rep: Reputation: 15
ACPI + CPU Frequency = CPU Scaling

It allows you to change the speed of your CPU on the fly to reduce temperatures/save power. My motherboard doesn't support it either (so I get the same error) but it all boots up fine so if it's not stopping Linux booting, you can ignore it.

In GNOME you can have the CPU Scaling Monitor which shows you the speed of your CPU. I have it on because I overclock so I like to know how fast it's running, unfortunately it means I get an annoying "CPU Scaling not supported" error everytime GNOME starts :P

Last edited by Xyem; 12-03-2005 at 01:48 PM.
 
Old 12-03-2005, 04:46 PM   #4
CapCavernaX
LQ Newbie
 
Registered: Nov 2005
Location: Boston
Distribution: Fedora Core 4 ( Will try Suse + slackware next )
Posts: 14

Original Poster
Rep: Reputation: 0
I know my motherboard supports it because when I do a clean install I don't get that error message. Its only when I updated to the latest kernel that I started getting said error.

I need this to function because if I don't have it on, Linux won't go to sleep and won't put the HD and Monitor to sleep. This is wasting electricity!!! That is why I want to get this problem solved.

If this thread does not help, I guess I may have to settle on doing a clean install and not updating the kernel. I got to do more testing to see witch update cause the problem. When I updated the kernel I also updated a few other stuff too. So next clean install I will update one thing at a time!!!
 
Old 12-03-2005, 04:51 PM   #5
ethics
Senior Member
 
Registered: Apr 2005
Location: London
Distribution: Arch - Latest
Posts: 1,522

Rep: Reputation: 45
Your machine should still shutdown despite this error, unless there's an acpi error.

I imagine it wasn't in the older kernels, hence no errors
 
Old 12-03-2005, 04:55 PM   #6
CapCavernaX
LQ Newbie
 
Registered: Nov 2005
Location: Boston
Distribution: Fedora Core 4 ( Will try Suse + slackware next )
Posts: 14

Original Poster
Rep: Reputation: 0
Yes it does shut down. It just does not go into sleep mode!

Before updated kernel no error. After updated kernel I starded getting the error!

Last edited by CapCavernaX; 12-03-2005 at 04:57 PM.
 
Old 12-04-2005, 01:59 AM   #7
Xyem
Member
 
Registered: Apr 2005
Distribution: Fedora Core 4
Posts: 100

Rep: Reputation: 15
Possibly the newer kernel cannot use that module version or needs to be passed additional arguments (such as acpi=force)?

It should say which arguments are passed to the kernel after your bootloader (BTW which one are you using? GRUB or LILO?) so try booting your old kernel (if you can) and see if there are any differences.

Not sure if this site is of any use but it does have some references to the CPU scaling and ACPI so it might provide a pointer in the right direction.

Last edited by Xyem; 12-04-2005 at 02:04 AM.
 
Old 12-05-2005, 11:22 AM   #8
CapCavernaX
LQ Newbie
 
Registered: Nov 2005
Location: Boston
Distribution: Fedora Core 4 ( Will try Suse + slackware next )
Posts: 14

Original Poster
Rep: Reputation: 0
Quote:
Originally Posted by Xyem
Possibly the newer kernel cannot use that module version or needs to be passed additional arguments (such as acpi=force)?
Where would I put the acpi=force argument?

Quote:
Originally Posted by Xyem
It should say which arguments are passed to the kernel after your bootloader (BTW which one are you using? GRUB or LILO?) so try booting your old kernel (if you can) and see if there are any differences.
Me using GRUB. I got lost on the rest of this paragraph of yours... could you plz elaborate a little!

Yes I can boot into older kernel... just a little pressed on time... but will do when I'm in front of Linux pc at home!

Quote:
Originally Posted by Xyem
Not sure if this site is of any use but it does have some references to the CPU scaling and ACPI so it might provide a pointer in the right direction.
Could not find solution there

Thanks for effort so far... Plz keep it coming!!!

Last edited by CapCavernaX; 12-05-2005 at 11:23 AM.
 
Old 12-05-2005, 01:21 PM   #9
Xyem
Member
 
Registered: Apr 2005
Distribution: Fedora Core 4
Posts: 100

Rep: Reputation: 15
If you have the graphical grub (like on Fedora Core 4) you can press 'c' at the menu and edit the arguments there, otherwise:

Code:
su
Quote:
vi /boot/grub/grub.conf
You will see something like

Code:
default=0
timeout=3
splashimage=(hd0,5)/grub/splash.xpm.gz
hiddenmenu
title Fedora Core 4 (2.6.14-1.1644_FC4)
        root (hd0,5)
        kernel /vmlinuz-2.6.14-1.1644_FC4 ro root=/dev/VolGroup00/LogVol00 rhgb quiet
        initrd /initrd-2.6.14-1.1644_FC4.img
In this example the arguments are

Code:
rhgb quiet
so just add 'acpi=force' (or any other arguments you feel like) so it reads

Code:
rhgb quiet acpi=force
(BTW You will need to reboot)

Last edited by Xyem; 12-05-2005 at 01:25 PM.
 
Old 12-05-2005, 01:46 PM   #10
CapCavernaX
LQ Newbie
 
Registered: Nov 2005
Location: Boston
Distribution: Fedora Core 4 ( Will try Suse + slackware next )
Posts: 14

Original Poster
Rep: Reputation: 0
Thanks Xyem.

Will try when I get home tonight. If you see this post before my next one, can you tell me what will be the result of forcing ACPI?

I'm afraid of being so forcefull with the poor little kernel. Maybe it may cry foul!!!

Also gotta check if there are any such arguments with the previous kernel ( still available in GRUB ).

Thanks once again!

[EDIT]The force argument did not work. I still get the same error above[/EDIT]

Last edited by CapCavernaX; 12-06-2005 at 09:46 AM.
 
Old 12-06-2005, 09:47 AM   #11
CapCavernaX
LQ Newbie
 
Registered: Nov 2005
Location: Boston
Distribution: Fedora Core 4 ( Will try Suse + slackware next )
Posts: 14

Original Poster
Rep: Reputation: 0
The force argument did not work. I still get the same error above
 
Old 12-06-2005, 05:54 PM   #12
CapCavernaX
LQ Newbie
 
Registered: Nov 2005
Location: Boston
Distribution: Fedora Core 4 ( Will try Suse + slackware next )
Posts: 14

Original Poster
Rep: Reputation: 0
BUMP...

Damn... no help fellas? Anyone experienced in this area??
 
Old 12-17-2005, 01:54 AM   #13
dcatdemon
LQ Newbie
 
Registered: Dec 2005
Posts: 1

Rep: Reputation: 0
This link (www-dot-redhat-dot-com/archives/fedora-list/2005-November/msg03164.html) seems to have the solution.

I've tried it myself (running on FC4) and it worked.

Sorry for the bad link above, they only allow me to post links to other sites after 5 posts. Please change the "-dot-" to a '.'.
 
Old 10-21-2006, 12:30 AM   #14
ResidentOmega
LQ Newbie
 
Registered: Oct 2006
Posts: 5

Rep: Reputation: 0
I have the same error with Fedora saying acpi-cpufreq.ko no such device...when I installed fedora 5 i had 2.6.15 bang the error happend when it updated to 2.6.17 it went away then updated to 2.6.18 bang the error came back... doesn't make any sense to me. The link didn't help either. Could someone help me.

I have an old system so I don't know why it wouldn't work
Motherboard = Asus P3B-F /w selectable jumper free bus
CPU = Pentium 3 866MHZ Slot1 with Slot378 conversion
768Meg Ram
1x 40 Gig Maxtor Harddrive
1x 40 Gig Westen Digital Harddrive
Soundblaster Audigy SE
Nvidia Geforce MX 4000 PCI Graphics 128Meg ram
Fedora 5 2.6-18.1.2200.FC5
 
Old 10-21-2006, 02:01 PM   #15
ResidentOmega
LQ Newbie
 
Registered: Oct 2006
Posts: 5

Rep: Reputation: 0
acpi_cpufreq disables

I did a little digging...the kernel configuration in the boot folder for Fedora 5 has a lot of information...I thought it was interesting because when I was studying the information, I noticed that it was configured for speedstepping. On top of that it was programmed for the wrong kind of processor. I have a slot1 adapter to change from slot1 to slot378. I don't believe Fedora recognizes that kind of configuration. I changed the processor type and disabled all speedstep and cpufreq config settings and it booted up very nicely.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
FATAL: Error inserting ndiswrapper raxxal Mandriva 7 07-06-2007 02:27 PM
modprobe: FATAL: Error inserting hw_random logicalfuzz Linux - General 7 09-14-2005 11:37 PM
modprobe: FATAL: Error inserting apm OneManArmy Linux - Software 2 08-21-2004 08:50 PM
apm vs. acpi ? (modprobe: FATAL: Error inserting apm) OneManArmy Linux - Laptop and Netbook 0 05-12-2004 05:39 PM
What's the deal with ACPI, cpufreq, and powernow-k7 on Emachines m5310 adamis Linux - Laptop and Netbook 10 02-14-2004 02:55 AM


All times are GMT -5. The time now is 07:43 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration