LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 12-05-2003, 10:14 AM   #1
jankerz
LQ Newbie
 
Registered: Dec 2003
Posts: 2

Rep: Reputation: 0
Talking FAT32 and Grub Problems...


God knows that "writing to FAT32" is a hot topic, and reasonably so. I haven't had my distro of linux long (I experimented with several over the summer, then fell back into an Xp groove) and I'm really frustrated by the fact that I cannont write to my FAT32 drive. I've read one message thread here and a couple elsewhere, and none have offered me a solution to my problem. The problem isn't that I can't write to my Fat32 drive (as i misquoted above), it's that I can't do it as anyone accept root. I have no clue how to solve this problem, I'm hoping some one can help, or direct me to somewhere that has an answer.

Secondly, Grub fails to boot Windows Xp for me when I want to. I have two harddrives: one for Xp, and then one for various files and Linux, with them being the master and slave drives respectively. So in my bios I have my computer set to boot my slave/linux drive first, and it loads grub fine. When I want to load windows however, I have to go into my bios and set my master drive to boot up first. Is there some reason why Grub won't let me boot my master drive without having to change my bios setup? It's as if it's telling me XP is horrid, and that I should only use linux.
 
Old 12-05-2003, 11:38 AM   #2
Demonbane
LQ Guru
 
Registered: Aug 2003
Location: Sydney, Australia
Distribution: Gentoo
Posts: 1,796

Rep: Reputation: 47
for second question, try putting this in your grub.conf(while bios is set to boot from second drive):

title WinXP
rootnoverify (hd1,0)
map (hd0) (hd1)
map (hd1) (hd0)
chainloader +1
 
Old 12-05-2003, 12:15 PM   #3
aaa
LQ Guru
 
Registered: Jul 2003
Location: VA
Distribution: Slack 10.1
Posts: 2,194

Rep: Reputation: 46
For first q, add options in the /etc/fstab file for your FAT32 drive's line. If your line looked like this:
#<-this is for comments
#device mnt-point fs-type options dump pass
/dev/hdb1 /mnt/win vfat defaults 0 0
Change it to this:
/dev/hdb1 /mnt/win vfat auto,umask=0,uid=jankerz,gid=users 0 0
The 'umask=0' option sets liberal permissions on the FAT32, letting anyone to anything with it. 'uid=' makes 'jankerz' own the files on the FAT32, 'gid=' makes it also belong to the 'users' group. 'auto' mounts automatically on startup.
 
Old 12-07-2003, 02:37 AM   #4
jankerz
LQ Newbie
 
Registered: Dec 2003
Posts: 2

Original Poster
Rep: Reputation: 0
gracious...
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
grub configure to take it's conf file from a fat32 partition hq4ever Linux - General 1 11-20-2004 05:55 PM
1 NFTS partition to 2 FAT32 partitions, and GRUB failes objorkum Linux - General 2 01-05-2004 09:10 AM
Created new FAT32 partition, after that..GRUB console haunting me..what 2 do??? free_mumia Linux - Newbie 5 01-04-2004 08:02 PM
Loading GRUB from FAT32 partition jucovschi Linux - General 5 12-20-2003 10:12 PM
rh9: mounting fat32 and grub problems psicokhel Linux - General 6 09-17-2003 11:52 PM


All times are GMT -5. The time now is 11:02 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration