LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 04-05-2007, 08:46 AM   #1
kantor_98
Member
 
Registered: Jan 2007
Posts: 68

Rep: Reputation: 15
FAT 32 mount problems


When I used suse 10.2 I automatically could see my ntfs drives, they was automatic mounted into a directory called windows. Also the external HDD appears in the directory media. But I could not write on them (no ntfs driver installed)
Now I installed fedora 6 and I formatted the old ntfs drives in fat 32. But they are invisible now ! I can not found them anywhere !
1.Is fedora weaker than suse in this matter ?
2. Can I manual mount them ?

Thank you
 
Old 04-05-2007, 08:49 AM   #2
avallach
Member
 
Registered: Sep 2006
Location: Silesia
Distribution: Debian GNU/Linux 4.0, ArchLinux, OpenBSD
Posts: 190
Blog Entries: 2

Rep: Reputation: 31
1. No it isn't everything in Linux depends on configuration. Sometimes it is easier sometimes more difficult
2. Yes of course just use mount.
Code:
mount -t vfat /dev/<your_fat_partition> /mnt/<place where you want to mount it>
 
Old 04-05-2007, 05:44 PM   #3
Junior Hacker
Senior Member
 
Registered: Jan 2005
Location: North America
Distribution: Debian testing Mandriva Ubuntu
Posts: 2,687

Rep: Reputation: 61
If you formatted them before installing Fedora, they would be included in /etc/fstab and a mount point probably in /mnt. If you are trying to add them after installing Fedora, you need to create an entry in /etc/fstab to auto-mount upon re-boot. By running commad:
Code:
fdisk -l
You should see which device it/they are, you will need to add a line in fstab and make a mount point in the file system. For instance, if you want to call it "fat1", you need to make a directory where it is most appropriate like /mnt or /media, your choice, like so:
Code:
mkdir /mnt/fat1
Then, if it is device "/dev/hda4", add a line in /etc/fstab like so:
Code:
/dev/hda4       /mnt/fat1       vfat      defaults       0 0
Even for the quick mount suggestion in the prior post you have to make a mount point in the directory structure (file system) if it does not exit.

Last edited by Junior Hacker; 04-05-2007 at 05:48 PM.
 
Old 04-06-2007, 02:56 AM   #4
kantor_98
Member
 
Registered: Jan 2007
Posts: 68

Original Poster
Rep: Reputation: 15
OK, I solved ! I use first the manual command
mount /dev/hda1 /mnt/c_drive -t vfat -rw -o umask=0000
then I write also the fstab and now it is working OK !
Thank you !
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Hmmm, can mount FAT, can't mount FAT32 m_lp_ql_m Linux - Hardware 6 10-05-2006 12:36 AM
Preserving dates in a FAT mount ZalmanYeishLoPants Linux - General 1 03-26-2006 11:07 AM
can mount C not D FAT: invalid media value (0x45) mount: wrong fs type, bad option Emmanuel_uk Linux - Newbie 10 11-29-2005 02:47 AM
mount fat partition MissEileen Linux - General 4 03-02-2005 10:19 AM
Mount a FAT HD onto linux. piglingz Linux - Hardware 2 02-13-2003 09:27 PM


All times are GMT -5. The time now is 04:57 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration