LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 02-28-2011, 11:20 AM   #1
Michael K
LQ Newbie
 
Registered: Feb 2011
Posts: 3

Rep: Reputation: 0
Fan keeps running once started


My problem is that my fan will keep running quite quickly once started. It will keep running till reboot independently of CPU usage and temperature. To check the temperature I installed lm-sensors. Output of temperature related commands and kernel version are below. Shouldnt they all give the temperature? My machine is a Toshiba Satellite pro L300. Eg. at the moment my fan is running quite quickly although CPU usage is 3-4% and the temperature according to lm-sensors is approximately 40-45 degrees Celcius.

Code:
     :~$ acpi --thermal
     Battery 0: Full, 100%
     Thermal 0: ok, 0.0 degrees C

     :~$ cat /proc/acpi/thermal_zone/THRM/temperature
     temperature:             0 C

     :~$ sensors
     acpitz-virtual-0
     Adapter: Virtual device
     temp1:        +0.0C  (crit = +106.0C)                   

     coretemp-isa-0000
     Adapter: ISA adapter
     Core 0:      +40.0C  (high = +100.0C, crit = +100.0C)  

     coretemp-isa-0001
     Adapter: ISA adapter
     Core 1:      +45.0C  (high = +100.0C, crit = +100.0C)  

     :~$ cat /proc/sys/kernel/osrelease
     2.6.28-13-generic
 
Old 02-28-2011, 11:24 AM   #2
corp769
LQ Guru
 
Registered: Apr 2005
Posts: 5,817

Rep: Reputation: 1002Reputation: 1002Reputation: 1002Reputation: 1002Reputation: 1002Reputation: 1002Reputation: 1002Reputation: 1002
Hello and welcome to LQ!

Before going any further, did you run sensors-detect? Just want to verify... Thank,

Josh
 
Old 02-28-2011, 11:30 AM   #3
Michael K
LQ Newbie
 
Registered: Feb 2011
Posts: 3

Original Poster
Rep: Reputation: 0
Yes, I ran sensors-detect choosing the default answer to all questions.
 
Old 02-28-2011, 11:45 AM   #4
corp769
LQ Guru
 
Registered: Apr 2005
Posts: 5,817

Rep: Reputation: 1002Reputation: 1002Reputation: 1002Reputation: 1002Reputation: 1002Reputation: 1002Reputation: 1002Reputation: 1002
What fan keeps running?
 
Old 02-28-2011, 12:19 PM   #5
Michael K
LQ Newbie
 
Registered: Feb 2011
Posts: 3

Original Poster
Rep: Reputation: 0
I am not aware of the machine having more than one fan and looking at pictures online of the machine disassembled doesn't reveal extra fans. Inspecting it here and now, there seems to be only one "fan-channel" for getting rid of air streams. The CPU is dual core.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Fan running at high speed gmartin Slackware 1 09-15-2009 01:30 AM
fan not running on laptop tim615 Linux - Laptop and Netbook 3 02-03-2009 02:14 AM
fan constantly running/how to control it? otoomet Linux - Laptop and Netbook 4 01-26-2009 11:22 AM
Fan not running = problem nappleapple Linux - Laptop and Netbook 3 11-27-2005 04:50 PM
Radeon 9100 Running Without Fan willis3000 Linux - Hardware 1 08-29-2005 05:06 AM


All times are GMT -5. The time now is 11:08 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration