LinuxQuestions.org
Did you know LQ has a Linux Hardware Compatibility List?
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices

Reply
 
Search this Thread
Old 04-17-2007, 03:23 AM   #1
payjoe
LQ Newbie
 
Registered: Apr 2007
Posts: 13

Rep: Reputation: 0
Unhappy Failed to start apache..help please


Hello,
I can not start my apache server nor bind dns server
her the error message.


Failed to start apache :
Starting httpd: [Tue Apr 17 08:14:01 2007] [warn] NameVirtualHost (ip *******:80 has no VirtualHosts
[FAILED

I,m very Green and new to linux (VPS)
 
Old 04-17-2007, 04:05 AM   #2
mether
Member
 
Registered: Mar 2007
Distribution: RHEL, Fedora, Open Suse
Posts: 151

Rep: Reputation: 31
Issue is with the config u hve in httpd.conf .Make sure that you have a name to IP entry in /etc/hosts
 
Old 04-25-2007, 01:44 PM   #3
mcupples
Member
 
Registered: Jun 2006
Location: Orlando
Distribution: FC3, FC5, CentOS4, Ubuntu 6.06
Posts: 57

Rep: Reputation: 15
I have the same issue. Firstly, here is my virtual hosts area of my httpd.conf:

Code:
NameVirtualHost *

<VirtualHost *>
 DocumentRoot /home/[username1]/public_html
 ServerName www.[domain1].com
 ServerAlias [domain1].com
 ScriptAlias /cgi-sys/ /var/www/cgi-sys/
 ScriptAlias /cgi-bin/ /home/[username1]/public_html/cgi-bin/
 <Directory "/home/[username1]/public_html/cgi-bin">
  AllowOverride None
  Options None
  Order allow,deny
  Allow from all
 </Directory>
 CustomLog logs/[domain1].com-access_log combined
 ErrorLog logs/[domain1].com-error_log
</VirtualHost>

<VirtualHost *>
 DocumentRoot /home/[username2]/public_html
 ServerName www.[domain2].info
 ServerAlias [domain2].info
 ScriptAlias /cgi-sys/ /var/www/cgi-sys/
 ScriptAlias /cgi-bin/ /home/[username2]/public_html/cgi-bin/
 <Directory "/home/[username2]/public_html/cgi-bin">
  AllowOverride None
  Options None
  Order allow,deny
  Allow from all
 </Directory>
 CustomLog logs/[domain2].info-access_log combined
 ErrorLog logs/[domain2].info-error_log
</VirtualHost>
Secondly, here is my /etc/hosts file:

Code:
127.0.0.1	localhost.localdomain	localhost
*.*.*.*	[stock name]	[ip with dashes instead of periods]
*.*.*.*	[domain1].com	[username1]
*.*.*.*	[domain2].info	[username2]
I believe that to be correct. Now, I've tried removing the asterisk in the <VirtualHost *> tag and replacing it with <VirtualHost *.*.*.*>, <VirtualHost *.*.*.*:80> and <VirtualHost *:80> all to no avail. Here's my current error:

Code:
[root@mcupples htdocs]# service httpd stop
Stopping httpd: service ht                                 [  OK  ]
[root@mcupples htdocs]# service httpd start
Starting httpd: [Wed Apr 25 11:38:56 2007] [error] VirtualHost _default_:443 -- mixing * ports and non-* ports with a NameVirtualHost address i
s not supported, proceeding with undefined results
                                                           [  OK  ]
That is with just the <VirtualHost *> tag. I get different errors depending on which variation I use - hopefully I'm just missing a minor thing.

Thanks,
Matt
 
  


Reply

Tags
apache, has, start, virtualhosts


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
when i try to start samba pdc's smb service nmbd failed to start . sandeepchau123 Linux - Newbie 2 10-20-2007 01:59 PM
Apache httpd start failed on fedora core 1 k_1701 Linux - Software 10 05-05-2006 07:40 AM
Failed to start apache : Apache does not appear to be running : number11 Slackware 9 02-11-2005 09:51 AM
Why X is failed to start edwin_78 Linux - Software 0 01-26-2005 02:49 AM
Failed to start apache error help SSBN Linux - Networking 2 04-30-2003 07:35 PM


All times are GMT -5. The time now is 10:32 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration