LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 09-27-2012, 05:12 PM   #1
MalikAsim
LQ Newbie
 
Registered: Sep 2012
Posts: 23

Rep: Reputation: Disabled
Failed to setup network access under RHEL 6.1 (VBox)


Hi

I hope someone can help me with this, please !

I have been trying and failing to setup up network access to the internet. After probing a few files as root user I am being denied access to /etc/resolv.conf with a message saying access denied when attempting a few other commands I also get no such file message.

My understanding is this file gets updated with accordance to network configuration settings.

Why would root user be being denied access and why is it also showing as does not exist.

I am running the server in CLI mode but have attempted setup command which took me to the GUI interface and settings seem right.

Have I fudged something without realising ??

Many thanks for reading and hope whatever your working on goes well

Last edited by MalikAsim; 09-27-2012 at 07:39 PM. Reason: choices
 
Old 09-27-2012, 05:15 PM   #2
acid_kewpie
Moderator
 
Registered: Jun 2001
Location: UK
Distribution: Gentoo, RHEL, Fedora, Centos
Posts: 43,417

Rep: Reputation: 1974Reputation: 1974Reputation: 1974Reputation: 1974Reputation: 1974Reputation: 1974Reputation: 1974Reputation: 1974Reputation: 1974Reputation: 1974Reputation: 1974
well as you say it says it doesn't exist too, I think it has to be worth pointing out that it's /etc/resolv.conf, not resolve.conf.

Generally you don't need to modify it directly, but you'd never be stopped form doing so as root, so I'd also wonder exactly how you're doing it.
 
Old 09-27-2012, 05:21 PM   #3
MalikAsim
LQ Newbie
 
Registered: Sep 2012
Posts: 23

Original Poster
Rep: Reputation: Disabled
okay ?

Quote:
Originally Posted by acid_kewpie View Post
well as you say it says it doesn't exist too, I think it has to be worth pointing out that it's /etc/resolv.conf, not resolve.conf.

Generally you don't need to modify it directly, but you'd never be stopped form doing so as root, so I'd also wonder exactly how you're doing it.
)Yep as I said in my post /etx/resolve.conf

And I may be attempting to edit wrong I was using the vi to edit as I have edited files with this in the past and it used to work fine.

I'm not sure if things in this distro version are diff because as you are aware more than likely this type of OS is particulary enhanced on security features.

What do you think I may be doing wrong?
I should add I'm doing this in a Vbox setup

Thank you
 
Old 09-27-2012, 05:30 PM   #4
acid_kewpie
Moderator
 
Registered: Jun 2001
Location: UK
Distribution: Gentoo, RHEL, Fedora, Centos
Posts: 43,417

Rep: Reputation: 1974Reputation: 1974Reputation: 1974Reputation: 1974Reputation: 1974Reputation: 1974Reputation: 1974Reputation: 1974Reputation: 1974Reputation: 1974Reputation: 1974
/etx/resolve.conf ???

SELinux won't stop root editing that file.

I don't know what you're doing wrong, as you've not told us *exactly* what you are doing. can you prove you ARE root when you do this?
 
Old 09-27-2012, 05:35 PM   #5
snowpine
Senior Member
 
Registered: Feb 2009
Posts: 4,037

Rep: Reputation: 1099Reputation: 1099Reputation: 1099Reputation: 1099Reputation: 1099Reputation: 1099Reputation: 1099Reputation: 1099
Since you seem to have some trouble with typing accurately, may I suggest taking advantage of the "tab autocomplete" feature? If you start typing a few letters, for example:

Code:
vi /et
then press TAB key it will autofill:

Code:
vi /etc/
and then you can type:

Code:
vi /etc/res
and press TAB

etc.
 
Old 09-27-2012, 07:03 PM   #6
unSpawn
Moderator
 
Registered: May 2001
Posts: 29,331
Blog Entries: 55

Rep: Reputation: 3529Reputation: 3529Reputation: 3529Reputation: 3529Reputation: 3529Reputation: 3529Reputation: 3529Reputation: 3529Reputation: 3529Reputation: 3529Reputation: 3529
Quote:
Originally Posted by MalikAsim View Post
I have been trying and failing to setup up network access to the internet. (..) I should add I'm doing this in a Vbox setup
As long as the VBox DHCP daemon works OK there should be very little you have to do to get networking going under RHEL. If you have specific settings you can use the "system-config-network" tools or enable networking and edit the host name in /etc/sysconfig/network and /etc/hosts, enable DHCP and related settings in /etc/sysconfig/network-scripts/ifcfg-$DEVICENAME, 'ifconfig up' the device and then run dhclient to get a lease. If it still doesn't work post what you've configured and output of '/sbin/ifconfig -a; /sbin/route -n; cat /var/lib/dhclient/*leases'.

* Note I changed the title of your thread to reflect it's not a security problem and I've moved it to the Linux Newbie forum to help your thread/question get the exposure it deserves.
 
Old 09-27-2012, 07:23 PM   #7
MalikAsim
LQ Newbie
 
Registered: Sep 2012
Posts: 23

Original Poster
Rep: Reputation: Disabled
yep deffinate root login

Quote:
Originally Posted by acid_kewpie View Post
/etx/resolve.conf ???

SELinux won't stop root editing that file.

I don't know what you're doing wrong, as you've not told us *exactly* what you are doing. can you prove you ARE root when you do this?
I enter the system it boots as normal, this is a fresh install jyi.

At login I enter root as login and my password I'll put the screen dumps up in the morning for you.

Then the last login is displayed with the software version details.

I've also tried viewing the file with SU at the start of the command line code.
 
Old 09-27-2012, 07:28 PM   #8
MalikAsim
LQ Newbie
 
Registered: Sep 2012
Posts: 23

Original Poster
Rep: Reputation: Disabled
VBox DHCP seems cool

Quote:
Originally Posted by unSpawn View Post
As long as the VBox DHCP daemon works OK there should be very little you have to do to get networking going under RHEL. If you have specific settings you can use the "system-config-network" tools or enable networking and edit the host name in /etc/sysconfig/network and /etc/hosts, enable DHCP and related settings in /etc/sysconfig/network-scripts/ifcfg-$DEVICENAME, 'ifconfig up' the device and then run dhclient to get a lease. If it still doesn't work post what you've configured and output of '/sbin/ifconfig -a; /sbin/route -n; cat /var/lib/dhclient/*leases'.

* Note I changed the title of your thread to reflect it's not a security problem and I've moved it to the Linux Newbie forum to help your thread/question get the exposure it deserves.
The VBox setup seems to be correct and functioning to its requirements as no problem connecting internet on ubuntu or ubuntu server aswell as Windows 2008 server all mail settings are in correct working order.

I have made a post on this network issue as internet access is required to access repositories.

Thanks
----------------
Asim
________________
 
Old 09-27-2012, 07:33 PM   #9
MalikAsim
LQ Newbie
 
Registered: Sep 2012
Posts: 23

Original Poster
Rep: Reputation: Disabled
editing prob

Quote:
Originally Posted by acid_kewpie View Post
/etx/resolve.conf ???

SELinux won't stop root editing that file.

I don't know what you're doing wrong, as you've not told us *exactly* what you are doing. can you prove you ARE root when you do this?
I understand that and thank you for clarifying it.

RH said the same thing there are however bugs in certain distros which ineffect have prevented root from accessing specific files including the aforementioned however no solutions are documented anywhere in respect to this.

That is also the reason I put it in the security section rather than the networking one
 
Old 09-27-2012, 07:36 PM   #10
MalikAsim
LQ Newbie
 
Registered: Sep 2012
Posts: 23

Original Poster
Rep: Reputation: Disabled
"TAB Autocomplete"

Quote:
Originally Posted by snowpine View Post
Since you seem to have some trouble with typing accurately, may I suggest taking advantage of the "tab autocomplete" feature? If you start typing a few letters, for example:

Code:
vi /et
then press TAB key it will autofill:

Code:
vi /etc/
and then you can type:

Code:
vi /etc/res
and press TAB

etc.
Thank you
 
Old 09-27-2012, 07:47 PM   #11
MalikAsim
LQ Newbie
 
Registered: Sep 2012
Posts: 23

Original Poster
Rep: Reputation: Disabled
I should mention

Quote:
Originally Posted by acid_kewpie View Post
well as you say it says it doesn't exist too, I think it has to be worth pointing out that it's /etc/resolv.conf, not resolve.conf.

Generally you don't need to modify it directly, but you'd never be stopped form doing so as root, so I'd also wonder exactly how you're doing it.
When I type the sys-network-config thing it comes up with no such command I've checked syntax for these commands (as there are a few note: changes in RH5.3 to recent versions) in the manuals PDF files provided by redhat. Quite a few other such commands also get the command error.

After a bit of research on it I thought a possible install of somthing might solve the unrecognized commands issue.

Please excuse if these seem like stupid questions I'm trying to familirize myself with the RedHat install and config procedures.

Many Thanks
 
Old 09-27-2012, 08:10 PM   #12
unSpawn
Moderator
 
Registered: May 2001
Posts: 29,331
Blog Entries: 55

Rep: Reputation: 3529Reputation: 3529Reputation: 3529Reputation: 3529Reputation: 3529Reputation: 3529Reputation: 3529Reputation: 3529Reputation: 3529Reputation: 3529Reputation: 3529
Quote:
Originally Posted by MalikAsim View Post
I have made a post on this network issue as internet access is required to access repositories.
What are you saying?


Quote:
Originally Posted by MalikAsim View Post
there are however bugs in certain distros which ineffect have prevented root from accessing specific files including the aforementioned however no solutions are documented anywhere in respect to this.
...that may be so but unless that was a problem fixed in Update 2 or 3 (I doubt it and BTW you're still running RHEL-6U1) or until you prove otherwise (and so far you've only been talking about problems and you haven't posted anything tangible at all) I maintain it's a user fsck-up.
 
Old 09-27-2012, 10:29 PM   #13
MalikAsim
LQ Newbie
 
Registered: Sep 2012
Posts: 23

Original Poster
Rep: Reputation: Disabled
Exclamation I'm not talking about problems

Quote:
Originally Posted by unSpawn View Post
What are you saying?



...that may be so but unless that was a problem fixed in Update 2 or 3 (I doubt it and BTW you're still running RHEL-6U1) or until you prove otherwise (and so far you've only been talking about problems and you haven't posted anything tangible at all) I maintain it's a user fsck-up.
You seem to misunderstand the english language. I'm not talking about problems I'm trying to seek help from vetran users to solve a problem. I've installed older versions of Red Had in CLI and had absolutly no issues setting up a network connection.

I didn't update the post, was going to do it in the morning but I've done a fresh install on VBox (desktop version) after runing NetManager internet is runing fine, still getting a problem at bas or X11 should I say with the permission thing even though I'm logged in as root user so priveliges should be enabled (?). I don't know what I'm doing wrong in the CLI on my other install as NetManager comes up with command error and so does Sys-Network-config.

Thanks for the help, also bit confused at your tangible remark lol

Please explain

Thanks again
 
Old 09-27-2012, 10:40 PM   #14
MalikAsim
LQ Newbie
 
Registered: Sep 2012
Posts: 23

Original Poster
Rep: Reputation: Disabled
Smile What I am saying ?

Quote:
Originally Posted by unSpawn View Post
What are you saying?



...that may be so but unless that was a problem fixed in Update 2 or 3 (I doubt it and BTW you're still running RHEL-6U1) or until you prove otherwise (and so far you've only been talking about problems and you haven't posted anything tangible at all) I maintain it's a user fsck-up.
Sorry! ?

What I was actually trying to say was that I had made the post in network related topis already the reason I said that is because a moderator I'm not sure if it was yourself or another one sent me a message saying they changed the name of the post from Security issue (as I can't gain access to /etc/resolv.conf) to network related. I was explaining that I'd done that already but thought to myself that I'd learn more from both??

I have had feedback from a few other forum/ blog sites and it seems that its a bit weird. I must be doing something wrong but like I said its runing in desktop environment just not in CLI!!

Also repositories won't work for I'd like it to but I'm messing up the reg it fails to connect.

Thanks

------------------
Asim
__________________
 
Old 09-28-2012, 04:13 AM   #15
acid_kewpie
Moderator
 
Registered: Jun 2001
Location: UK
Distribution: Gentoo, RHEL, Fedora, Centos
Posts: 43,417

Rep: Reputation: 1974Reputation: 1974Reputation: 1974Reputation: 1974Reputation: 1974Reputation: 1974Reputation: 1974Reputation: 1974Reputation: 1974Reputation: 1974Reputation: 1974
Right so we've merged a thread here? Confused a bit...

So again I see user error... "sys-config-network" be "system-config-network", I really get the impression you're just not paying enough attention to detail. are we even officially clear about the name of the /etc/resolv.conf file?? The tab completion advice is VERY useful for both the resolv.conf file AND the system-config-network tool, you'd not be able to get either of these wrong if you used tab completion.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
failed to install vbox addon on Fedora 17 mia_tech Linux - Virtualization and Cloud 1 08-29-2012 03:30 PM
Arch setup? (Vbox) CrazyGuy158 Arch 8 07-17-2012 12:58 PM
[SOLVED] Failed Remmina RDP/VNC setup in a firewalled network shayno90 Linux - Networking 1 07-13-2012 11:02 AM
Samba -- session setup failed: ERRDOS - ERRnoaccess (Access denied.) hmccurdy Linux - Networking 4 04-24-2009 10:41 AM
Auditing failed access to security relevent files .. RHEL 4 nandez Linux - Security 2 07-11-2008 07:17 PM


All times are GMT -5. The time now is 04:56 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration