LinuxQuestions.org
Review your favorite Linux distribution.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 04-04-2012, 06:42 AM   #1
HarryBoy
Member
 
Registered: Apr 2008
Distribution: MontaVista Linux Version 4.0.1, Professional Edition
Posts: 215

Rep: Reputation: 16
Failed to load the JNI shared library


I have downloaded eclipse onto Suse and when I try to launch it I get the following error:

Quote:
Failed to load the JNI shared library "/usr/lib64/jvm/java-1_4_2-ibm-1.4.2/jre/bin/j9vm/libjvm.so"
How do I solve this problem??

Thanks
 
Old 04-04-2012, 06:45 AM   #2
HarryBoy
Member
 
Registered: Apr 2008
Distribution: MontaVista Linux Version 4.0.1, Professional Edition
Posts: 215

Original Poster
Rep: Reputation: 16
I have checked and this file does exist in the above path so I don't understand why its not loading it.

Thanks
 
Old 04-05-2012, 11:08 AM   #3
Enrix
Member
 
Registered: Mar 2012
Location: Aguascalientes, mx
Distribution: Opensuse 12.1 x86-64
Posts: 34

Rep: Reputation: 1
Quote:
Originally Posted by HarryBoy View Post
I have downloaded eclipse onto Suse and when I try to launch it I get the following error:

How do I solve this problem??

Thanks
Hello HarryBoy,

Could you give us some more information, like:
- Suse version & architecture
- Java version (we can say you're working with java ibm-1.4.2)
- Output of java -version & javac-version
- Any other error messages

Any other information can be helpfull
 
Old 04-11-2012, 05:46 AM   #4
HarryBoy
Member
 
Registered: Apr 2008
Distribution: MontaVista Linux Version 4.0.1, Professional Edition
Posts: 215

Original Poster
Rep: Reputation: 16
Thanks for your reply Enrix,

cat /etc/SuSE-release
SUSE Linux Enterprise Server 11 (x86_64)
VERSION = 11
PATCHLEVEL = 2

java -version
java version "1.4.2"
Java(TM) 2 Runtime Environment, Standard Edition (build 2.3)
IBM J9 VM (build 2.3, J2RE 1.4.2 IBM J9 2.3 Linux amd64-64 j9vmxa64142ifx-20110628 (JIT enabled)
J9VM - 20110627_85693_LHdSMr
JIT - 20090210_1447ifx5_r8
GC - 200902_24)


There are no other error messages, just the one I posted.

Thanks
 
Old 04-12-2012, 04:24 PM   #5
Enrix
Member
 
Registered: Mar 2012
Location: Aguascalientes, mx
Distribution: Opensuse 12.1 x86-64
Posts: 34

Rep: Reputation: 1
Would it be possible to update your Java version? at this moment the Oracle one is at version 7 (1.7), and you're using IBM 1.42.
 
Old 06-01-2012, 07:54 AM   #6
HarryBoy
Member
 
Registered: Apr 2008
Distribution: MontaVista Linux Version 4.0.1, Professional Edition
Posts: 215

Original Poster
Rep: Reputation: 16
I don't think It's possible to update my java version but I'll investigate.

I noticed on the command line, before the above error message appears I see the following:

"/usr/lib64/jvm/java-1_4_2-ibm-1.4.2/jre/bin/j9vm/libjvm.so: wrong ELF class: ELFCLASS64"

my machine details are:

uname -a
Linux MyDevelopmentLinux 3.0.13-0.27-default #1 SMP Wed Feb 15 13:33:49 UTC 2012 (d73692b) x86_64 x86_64 x86_64 GNU/Linux.



Thanks
 
Old 06-01-2012, 12:46 PM   #7
rosehosting.com
Member
 
Registered: Jun 2012
Posts: 222

Rep: Reputation: 62
It looks like the issue is related to architecture mismatch, more specifically different bit architectures of java and eclipse.

What bit version of eclipse you're running?

What bit of JAVA is in place?

What's happening if you run eclipse with -vm /path/to/java/bin ?
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Can't load shared library (but it's right there!) brazzle Programming 8 02-17-2011 12:12 AM
Unable to load a shared library vipulspn Linux - Newbie 7 08-26-2009 08:29 AM
JAVA JNI program to access shared library sabliny Programming 3 11-17-2005 06:13 PM
my slack can't load shared library AnhTuan Slackware 6 10-03-2004 10:27 AM
UnsatisfiedLinkError on JNI access to Shared Library Kavinjka Linux - Software 1 08-25-2003 07:08 AM


All times are GMT -5. The time now is 02:52 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration