LinuxQuestions.org
Review your favorite Linux distribution.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 04-26-2009, 10:32 PM   #1
planetplosion
LQ Newbie
 
Registered: Mar 2009
Posts: 9

Rep: Reputation: 0
failed to detect Glib?


error: Failed to detect or find glib-2.0 >= 2.6.4 gthread-2.0 (consider adjusting $PKG_CONFIG_PATH)

I got this error when trying to configure BEAST.... I obviously have Glib somewhere. How might I adjust PKG_CONFIG?
I'm running UBUNTU
 
Old 04-27-2009, 03:22 AM   #2
bathory
LQ Guru
 
Registered: Jun 2004
Location: Piraeus
Distribution: Slackware
Posts: 11,519

Rep: Reputation: 1501Reputation: 1501Reputation: 1501Reputation: 1501Reputation: 1501Reputation: 1501Reputation: 1501Reputation: 1501Reputation: 1501Reputation: 1501Reputation: 1501
I guess that you have glib-2.0, but its version is lower that 2.6.4, that's why ./configure complains. Usually these libraries are installed in /usr/lib and you can run
Code:
 pkg-config --modversion glib-2.0
to find the vesrion.
Use your distro's package manager to see if it's installed and to upgrade to the latest version.
If you have installed the library yourself in a non standard place you can adjust the PKG_CONFIG_PATH like this:
Code:
export PKG_CONFIG_PATH=/path/to/non-standard/libs:$PKG_CONFIG_PATH
Regards
 
Old 04-27-2009, 10:33 AM   #3
knudfl
LQ 5k Club
 
Registered: Jan 2008
Location: Copenhagen, DK
Distribution: pclos2016, Slack14.1 Deb Jessie, + 50+ other Linux OS, for test only.
Posts: 16,276

Rep: Reputation: 3154Reputation: 3154Reputation: 3154Reputation: 3154Reputation: 3154Reputation: 3154Reputation: 3154Reputation: 3154Reputation: 3154Reputation: 3154Reputation: 3154
Still using Ubuntu 8.10 ?

Install package 'libglib2.0-dev' , if you want to
compile with "glib2.0" :

sudo apt-get install libglib2.0-dev
.....

Last edited by knudfl; 04-28-2009 at 08:49 AM.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Failed to detect ethernet card laiyhman Linux - Networking 2 05-13-2007 09:28 AM
Failed to detect SCSI CD-R finite Linux - Hardware 4 12-05-2006 12:07 AM
Failed to detect raid set adamas Linux - Newbie 1 02-16-2006 06:54 AM
Can't get Linux to detect new GLib version! CaptainWonTon Linux - Software 1 01-27-2006 03:52 PM
glib >=2.0 failed dependency kwanc Linux - Software 9 02-09-2003 04:38 AM


All times are GMT -5. The time now is 09:11 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration