LinuxQuestions.org
Review your favorite Linux distribution.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 06-13-2009, 07:17 AM   #1
gitecravirs
Member
 
Registered: Mar 2009
Posts: 40

Rep: Reputation: 15
Wink failed to bring up eth0


Hi everybody,
I am using ubuntu-8.04 with kernel 2.6.24-23-generic.I have two interfaces eth0 and eth1,of these interfaces, on eth0 i have configured ipv6 addr. 2001:468::3 and on eth1 dhcp is there.But, when i restart the network by "#/etc/init.d/networking restart" command then im able to get dhcp on eth1 but im not getting static ipv6 address on eth0.I am getting folling information for eth0---->
ifconfig: can not resolve `up': Unknown host
Failed to bring up eth0.

Please HELP me why im getting this message and how to resolve this.(note- I am able to get dhcp on eth0 interface).
Thanks Alot...
 
Old 06-13-2009, 08:02 AM   #2
repo
LQ 5k Club
 
Registered: May 2001
Location: Belgium
Distribution: Arch
Posts: 8,528

Rep: Reputation: 899Reputation: 899Reputation: 899Reputation: 899Reputation: 899Reputation: 899Reputation: 899
try

Quote:
iface eth0 inet6 static
address 2001:468::3
netmask 64
 
Old 06-14-2009, 11:31 PM   #3
gitecravirs
Member
 
Registered: Mar 2009
Posts: 40

Original Poster
Rep: Reputation: 15
Quote:
Originally Posted by repo View Post
try
YA, i have tried this one already and my /etc/network/interfaces file contents is below----
auto lo
iface lo inet loopback
iface eth1 inet dhcp
auto eth1
#pre-up modprobe ipv6
#iface eth0 inet manual
#up ifconfig $IFACE up
#up ifconfig $IFACE promisc
#up ifconfig $IFACE -arp
#down ifconfig $IFACE down

iface eth0 inet6 static
address 2001:468::3
netmask 64
auto eth0

but still im not getting my interface address as 2001:468::3 on eth0. Help me..
 
Old 06-15-2009, 04:57 AM   #4
peonuser
Member
 
Registered: Mar 2008
Location: Where ever I am.
Distribution: Various
Posts: 177
Blog Entries: 167

Rep: Reputation: 21
Quote:
Originally Posted by gitecravirs View Post
YA, i have tried this one already and my /etc/network/interfaces file contents is below----
auto lo
iface lo inet loopback
iface eth1 inet dhcp
auto eth1
#pre-up modprobe ipv6
#iface eth0 inet manual
#up ifconfig $IFACE up
#up ifconfig $IFACE promisc
#up ifconfig $IFACE -arp
#down ifconfig $IFACE down

iface eth0 inet6 static
address 2001:468::3
netmask 64
auto eth0

but still im not getting my interface address as 2001:468::3 on eth0. Help me..
if you are not in an ipv6 network, you need to change the settings

auto eth0
iface eth0 inet static
address xxx.xxx.xxx.xxx
netmask xxx.xxx.xxx.xxx
network xxx.xxx.xxx.xxx
broadcast xxx.xxx.xxx.xxx
etc..............

Last edited by peonuser; 06-15-2009 at 04:59 AM.
 
Old 06-16-2009, 01:12 AM   #5
gitecravirs
Member
 
Registered: Mar 2009
Posts: 40

Original Poster
Rep: Reputation: 15
Quote:
Originally Posted by peonuser View Post
if you are not in an ipv6 network, you need to change the settings

auto eth0
iface eth0 inet static
address xxx.xxx.xxx.xxx
netmask xxx.xxx.xxx.xxx
network xxx.xxx.xxx.xxx
broadcast xxx.xxx.xxx.xxx
etc..............
No, i have intensionally made it for ipv6 network only.that is why i have used 'inet6' instead of 'inet',so now what to do?
 
Old 06-16-2009, 05:13 AM   #6
gitecravirs
Member
 
Registered: Mar 2009
Posts: 40

Original Poster
Rep: Reputation: 15
Quote:
Originally Posted by gitecravirs View Post
No, i have intensionally made it for ipv6 network only.that is why i have used 'inet6' instead of 'inet',so now what to do?
And also when i restart my network by "/etc/init.d/networking restart" command then its last stanza shows--ifconfig: can not resolve `up': Unknown host
Failed to bring up eth0. what things should i try so that i would be able to get "2001:468::3" address on eth0 interface.[note:- earliar i was able to get this addr. on eth0 but now suddenly im not getting it]

Thanks for Replying...
 
Old 06-17-2009, 02:24 AM   #7
peonuser
Member
 
Registered: Mar 2008
Location: Where ever I am.
Distribution: Various
Posts: 177
Blog Entries: 167

Rep: Reputation: 21
Quote:
Originally Posted by gitecravirs View Post
And also when i restart my network by "/etc/init.d/networking restart" command then its last stanza shows--ifconfig: can not resolve `up': Unknown host
Failed to bring up eth0. what things should i try so that i would be able to get "2001:468::3" address on eth0 interface.[note:- earliar i was able to get this addr. on eth0 but now suddenly im not getting it]

Thanks for Replying...
$ sudo ifdown eth0
$ sudo ifup eth0

I am sure that is what you did from the command line. I usually do not those commands in interfaces. interfaces is a data file not a command file from what little I understand.
 
Old 06-17-2009, 05:16 AM   #8
gitecravirs
Member
 
Registered: Mar 2009
Posts: 40

Original Poster
Rep: Reputation: 15
Quote:
Originally Posted by peonuser View Post
$ sudo ifdown eth0
$ sudo ifup eth0

I am sure that is what you did from the command line. I usually do not those commands in interfaces. interfaces is a data file not a command file from what little I understand.
I tried above commands from the command line. it gives following outputs whenever im using these commands:
# sudo ifdown eth0
ifconfig: can not resolve `down': Unknown host
# sudo ifup eth0
ifconfig: can not resolve `up': Unknown host
I also tried "ifconfig eth0 down" & "ifconfig eth0 up" but still its waste....Help Me..
 
Old 06-17-2009, 05:28 AM   #9
EricTRA
LQ Guru
 
Registered: May 2009
Location: Gibraltar, Gibraltar
Distribution: Fedora 20 with Awesome WM
Posts: 6,805
Blog Entries: 1

Rep: Reputation: 1295Reputation: 1295Reputation: 1295Reputation: 1295Reputation: 1295Reputation: 1295Reputation: 1295Reputation: 1295Reputation: 1295
Try

ip link set eth1 up

For more info on this command(group) type man ip, it comes with a lot of options to assign address, subnet and all other possibilities.

Kind regards,

Eric
 
Old 06-17-2009, 06:20 AM   #10
gitecravirs
Member
 
Registered: Mar 2009
Posts: 40

Original Poster
Rep: Reputation: 15
Quote:
Originally Posted by EricTRA View Post
Try

ip link set eth1 up

For more info on this command(group) type man ip, it comes with a lot of options to assign address, subnet and all other possibilities.

Kind regards,

Eric
I tried this command also, but still im not getting ipv6 static ip as 2001:468::3 on eth0 interface.
 
Old 06-17-2009, 06:56 AM   #11
EricTRA
LQ Guru
 
Registered: May 2009
Location: Gibraltar, Gibraltar
Distribution: Fedora 20 with Awesome WM
Posts: 6,805
Blog Entries: 1

Rep: Reputation: 1295Reputation: 1295Reputation: 1295Reputation: 1295Reputation: 1295Reputation: 1295Reputation: 1295Reputation: 1295Reputation: 1295
Quote:
Originally Posted by gitecravirs View Post
I tried this command also, but still im not getting ipv6 static ip as 2001:468::3 on eth0 interface.
Try to add the configuration again to the device using the ip command rather than editing the interfaces file. For the exact syntax read the man page of ip (man ip), because I'm not sure but it should be something like this:

ip address add eth1 local 2001:468::3 scope global

Again I'm not sure about this so please read the man page for correct syntax.

After setting it succesfully, shut down the interface and bring it up again, to see if it works. If it works looking at what got written in your interfaces file should show if you had forgotten something before.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
failed to bring up eth0 aspinnler Debian 19 02-28-2006 07:56 PM
failed to bring up eth0 aspinnler Debian 0 02-26-2006 01:59 PM
ifup eth0 failed, failed to bring eth0 MKSrivastava Debian 1 12-07-2005 10:35 AM
failed to bring eth0 up k_brother Linux - Newbie 2 10-17-2003 10:30 AM
Failed to bring eth0 up amphibious Linux - Newbie 1 09-25-2003 04:12 PM


All times are GMT -5. The time now is 05:09 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration