LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices

Reply
 
Search this Thread
Old 09-10-2004, 04:00 PM   #1
mandrakemikael
Member
 
Registered: Aug 2004
Distribution: gentoo <3
Posts: 39

Rep: Reputation: 15
failed dependencies to installed packages??


i have been wondering this problem for quite a while now. many installer scripts complain about failed dependencies to packages i have installed with my distro (mdk10.0). i give an example:

$ rpm --install xmms-flac-1.1.0-0.fdr.16.rh80.i386.rpm
warning: xmms-flac-1.1.0-0.fdr.16.rh80.i386.rpm: V3 DSA signature: NOKEY, key ID 8df56d05
error: Failed dependencies:
xmms >= 1:1.2.7 is needed by xmms-flac-1.1.0-0.fdr.16.rh80
libid3-3.8.so.3 is needed by xmms-flac-1.1.0-0.fdr.16.rh80

$ xmms --version
xmms 1.2.9

$ locate libid3-3
/usr/local/lib/libid3-3.8.so.3.0.0
/usr/local/lib/libid3-3.8.so.3

OR

checking for XMMS - version >= 1.0.0... no
*** The xmms-config script installed by XMMS could not be found.
*** If XMMS was installed in PREFIX, make sure PREFIX/bin is in
*** your path, or set the XMMS_CONFIG environment variable to the
*** full path to xmms-config.
configure: error: *** XMMS >= 1.0.0 not installed - please install first ***


i have this problem with several packages, not just xmms. is there a simple universal cure for this?

Last edited by mandrakemikael; 09-10-2004 at 04:11 PM.
 
Old 09-10-2004, 04:26 PM   #2
Mara
Moderator
 
Registered: Feb 2002
Location: Grenoble
Distribution: Debian
Posts: 9,535

Rep: Reputation: 148Reputation: 148
In the second case I think it may be connected with xmms-devel package. Do you have it? Probably not. If such an error occurs when compiling a program from source, first check devel package for the program/library that seems to be causing it.

First case... Not sure. If it happens for many libraries and devels don't help, you may have a broken database. In such case
rpmdb --rebuilddb
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Failed dependencies! Please help! ananya Slackware 10 03-05-2005 03:52 AM
failed dependencies david2 Linux - Newbie 2 04-08-2004 06:16 AM
I recieve a failed dependencies error, but I have all required dependencies Laptop2250 Linux - Software 15 02-03-2004 07:58 PM
RPM 'failed dependencies': Why can I not install any rpm packages? leontini Linux - Newbie 7 09-16-2003 12:44 AM
Failed dependencies phinsman Linux - Newbie 2 08-26-2003 07:24 PM


All times are GMT -5. The time now is 09:25 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration