LinuxQuestions.org
Support LQ: Use code LQ3 and save $3 on Domain Registration
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 10-28-2012, 07:28 PM   #1
Nizzok
LQ Newbie
 
Registered: Dec 2009
Posts: 29

Rep: Reputation: 0
Failed 12.10 upgrade, grub rescue errors: incompatible license.


I was trying to re-install 12.10 from a usb but it failed/crashed, upon reboot I am left in grub rescue mode. I have reset the prefix and root locations, but when I run
Code:
insmod normal
the result I get is
Code:
error: incompatible license
. The issue I have now is that I can no longer boot from USB, and my x201 doesn't have an optical drive, so I need to fix this (if possible) through the rescue terminal. I don't want to format the drive completely because I have a dual-boot set up, but the documentation on grub rescue is terrible and I have followed as many tutorials as I could before punting, and asking for help here. Thanks in advance


A bit of background here: I had a failed or interrupted upgrade to quantal from precise (I interrupted it because it looked frozen). I was able to clean it up to the point that it worked, but the os was still pretty buggy. I had to fix a lot of packages manually w
Code:
sudo dpkg-reconfigure
(-a didn't work so I went through and did the problem packages manually with --f). Additionally the software-sources GUI didn't load. I got frustrated with trying to install a third-party pkg (qgis) but the repositories were not behaving properly, so I tried to do a clean install from a usb (no optical drive).

please help! I'll provide any info I can to be helpful, but I haven't dealt with this stuff before
 
Old 10-29-2012, 12:06 PM   #2
Snark1994
Senior Member
 
Registered: Sep 2010
Location: Wales, UK
Distribution: Arch
Posts: 1,632
Blog Entries: 3

Rep: Reputation: 345Reputation: 345Reputation: 345Reputation: 345
License? It can't be from Ubuntu, you don't need a license for that... Do you know what software it's talking about?

EDIT: hm, http://ubuntuforums.org/showthread.php?t=1861552 seems to be about your problem - and suggests it's something to do with RAID. Do you have a RAID setup?

Last edited by Snark1994; 10-29-2012 at 12:12 PM.
 
Old 10-30-2012, 12:54 AM   #3
Nizzok
LQ Newbie
 
Registered: Dec 2009
Posts: 29

Original Poster
Rep: Reputation: 0
Unhappy

[QUOTE=Snark1994;4817501]License? It can't be from Ubuntu, you don't need a license for that... Do you know what software it's talking about?

Snark, I assure that's the result I get from the grub rescue terminal, I have set the root and path parameters properly in so far as I can find the usr/lib/grub folder and I can only navigate one partition of four with the terminal, ergo I have a farqed Linux set up sitting on top of a multi boot.

Re: raid, shouldn't have anything to do w why I can't access the USB from the boot menu or why the grub terminal gives me the license error. Trying to research trying to get the bios to recognize a USB

Last edited by Nizzok; 10-30-2012 at 01:17 AM.
 
Old 10-31-2012, 06:43 PM   #4
Snark1994
Senior Member
 
Registered: Sep 2010
Location: Wales, UK
Distribution: Arch
Posts: 1,632
Blog Entries: 3

Rep: Reputation: 345Reputation: 345Reputation: 345Reputation: 345
No, it shouldn't, but it seems that the license error is linked in some cases with a RAID setup - so do you have a RAID setup?

And what happens if you try to boot from USB? How far does it get?
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Grub File Not found Grub Rescue Error on External Sata to USB Drive imayneed Linux - Newbie 11 08-22-2012 03:56 AM
'incompatible implicit declaration' errors when compiling -Pb- Linux - Software 6 11-18-2010 01:39 AM
GCC errors after a failed upgrade sleepylight Linux - Software 2 01-21-2009 04:12 PM
rescue grub with CD1 failed abd_bela Debian 3 01-20-2009 05:59 AM
Today's kernel upgrade incompatible with my nvidia driver epsilon72 Fedora 3 04-13-2007 11:26 PM


All times are GMT -5. The time now is 08:05 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration