LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 06-25-2013, 04:54 PM   #1
kennygreenwald
LQ Newbie
 
Registered: Jun 2013
Posts: 3

Rep: Reputation: Disabled
F-key maps


I'm having an issue with my function keys in the terminal on my centos 6.4 machine. Whenever I press F1, for example, the screen prints A. F2 prints B, F3 prints C, etc. In short, I need this to not happen. This does NOT happen on my gui screen, just in the terminals. All of the basic keyboard settings are correct and quite frankly I'm just not 100% on where to change these specific mapping settings. I attempted to search Google and these forums to no avail.
Any help would be appreciated, keep in mind I'm still a bit of a Linux n00b so if you need any more info I'd be glad to supply it.
Thanks!
 
Old 06-26-2013, 12:51 PM   #2
RockDoctor
Senior Member
 
Registered: Nov 2003
Location: Minnesota, US
Distribution: Fedora, Linux Mint, Ubuntu
Posts: 1,514

Rep: Reputation: 325Reputation: 325Reputation: 325Reputation: 325
Does this help?
 
Old 06-26-2013, 01:59 PM   #3
kennygreenwald
LQ Newbie
 
Registered: Jun 2013
Posts: 3

Original Poster
Rep: Reputation: Disabled
I had tried manually editing the keymap but nothing changed. I actually just removed all of the F-key entries on the keymap in the hopes that it would just send the default key code but I'm still getting just A, B, C, D, etc.
I also noticed another mapping issue where my Backspace key is sending ^? as opposed to ^H. The delete key normally sends ^? but on Centos 6.4 it's sending something crazy like ^[[3~ which is just an ESC character with some gobbledygook at the end.
I made a virtual machine on my PC and loaded a fresh CentOS 6.4 to do some tests and make sure that I hadn't just messed something up but I'm getting the same results. I tried a different keyboard and I tried the same keyboard on another machine running Centos 5 and that one sends the appropriate codes (^? for Del, ^H for Backspace, and the F-keys work normally).
Is there anywhere that I can look for these changes? Maybe they're being changed during init? or maybe somewhere in root's user profile or something?
Oh and also my TERM is set to Linux, I've tried changing it to ansi and vt100 and all that stuff and nothing changed.
 
Old 06-26-2013, 03:02 PM   #4
kennygreenwald
LQ Newbie
 
Registered: Jun 2013
Posts: 3

Original Poster
Rep: Reputation: Disabled
Okay so I believe I've pinpointed the problem. After combing through the keymap (again) I noticed that when I dumpkeys to a file it has a bunch of strings in it that are changing how most keys work. The problem is that my keymap doesn't have these string values, they are being added somewhere else. I've changed /etc/sysconfig/keyboard to use my keymap but those strings are still getting loaded after every reboot.
Does anyone know where this would be happening? This is definitely the cause of my f-key issues AND the Del and BS keys sending the wrong codes.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
SSH skips public key authentication for a key, but works with another key simopal6 Linux - General 1 07-06-2011 09:33 AM
Google maps versus Nokia's OVI maps TheIndependentAquarius General 8 05-30-2011 05:26 AM
Suse 10.2 Win key maps it like start menu...i want to change it..how supersubu123 SUSE / openSUSE 2 05-22-2007 01:58 PM
no maps in firefox (again) BCarey Linux - Software 22 10-20-2006 10:16 PM
Ut2004 How To Get All Of The Maps!! AC97Conquerer Linux - Games 2 03-25-2005 02:37 AM


All times are GMT -5. The time now is 06:44 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration