LinuxQuestions.org
Visit the LQ Articles and Editorials section
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices

Reply
 
Search this Thread
Old 08-13-2003, 10:50 AM   #1
msisto
LQ Newbie
 
Registered: Aug 2003
Posts: 3

Rep: Reputation: 0
Extremely slow kppp internet connection


Hi, I am a newbie to Linux. I have a Zoom external 56k V.92 modem and Mandrake 9.1. The modem is in the serial port, ttys0 I think - I only have one serial port on the computer, which is a Dell Latitude 840 notebook. I have a Freeserve internet account. First of all, I have used the modem and Freeserve in Windows XP (I am dual booting) and it works fine, which is why I am thinking it is a problem with my Linux set up.

I have read some HOW-TO's such as the modem and serial pages, but most of it is too complicated for me to understand in order to fix the problem. When I connect to Freeserve using kppp, it takes so long for a page to load often they just time out. Everything goes so slowly I can't use the Internet under Linux.

I have queried the modem using kppp and it does return information, and it is set to the correct port. Has anybody had this problem, or any suggestions please as I am at a loss as to how to fix this. I don't think it is the Freeserve ISP that is the problem because it works much much faster under Windows.

Thank you
Maz
 
Old 08-13-2003, 10:54 AM   #2
ksgill
Senior Member
 
Registered: Apr 2003
Location: Toronto, Canada
Distribution: Ubuntu Jaunty (9.04)
Posts: 1,044

Rep: Reputation: 45
theres a kppp help file, it talks about slow kppp speeds. Here is what it says about your problem:
10.1. Questions about Dialling
10.10.1.1. I can't get kppp to work. kppp tells me pppd has died or that a timeout has expired. What's going on?

Did you read this manual carefully? Here are once more the most common pitfalls:

Click on the Details button. kppp will you give an excerpt from the PPP log messages (may not work on non-Linux® systems, or even on some Linux® distributions). The log will help you to track down the bug.

Make sure that pppd is the actual pppd binary not a script

Make sure that pppd is setuid root. You may set this mode by issuing chmod u+s pppd as root.

Make sure that your /etc/ppp/options file exists and that it doesn't contain any conflicting entries. If in doubt: Leave this file empty.

Make sure that you don't use the option lock as an argument for pppd (kppp is already taking care of device locking).

Remove the lock option from both your /etc/ppp/options and ˜/.ppprc files!

Using the symbolic link /dev/modem may cause some conflicts. Eliminate this source of trouble by using the real device, i.e. /dev/cuaX or /dev/ttySX.

Note
COM1 equals ttyS0, COM2 is ttyS1 and so on.

Make sure you set the right permission. In case of trouble you might want to run it as root first and then later, when everything is working fine give it less harmful permission if you can not afford to run kppp setuid root. The proper way to proceed would probably be creating a modem group.

You might be launching pppd too early, i.e. before the remote server is ready to negotiate a PPP connection. If you are using a login script, you should use the built-in terminal to verify your login procedure. Some providers will require you to issue a simple Send or Send ppp to launch PPP. Some users even reported, that they had to append Pause 1 or Pause 2 to their script to solve timing conflicts.

If nothing helps, you might obtain some debugging info from your systems log by issuing:

# tail /var/log/messages

10.10.1.2. Why does kppp tell me Unable to open the modem?

This means that kppp doesn't have permissions to open the modem device or that you selected a modem device on the Modem Tab Dialog that is not valid. First make sure you selected the right modem device. Once you are sure you have selected the right modem device, you must give kppp the right permission to access the modem device and to be able to modify /etc/resolv.conf in case you want kppp to configure DNS correctly for you. If you can afford to run kppp setuid root this would solve all access problems for you, if not you will have to figure out what the right permissions are for your purposes. In order to give kppp setuid root permissions do the following:

% su root
# chown root:root $KDEDIR/bin/kppp
# chmod +s $KDEDIR/bin/kppp
# exit


10.10.1.3. Why does kppp tell me it can't create a modem lock file?

This in most instances means that you have installed kppp without SETUID bit on while you, the person executing kppp, doesn't have write access to the lock file directory which by default is /var/lock. This for example is the case on Red Hat® systems. Check the modem dialog for the precise location you have chosen. The solution is easy -- either run kppp SETUID if you can afford to, or give regular users write access to /var/lock or create a modem group that will have access to the /var/lock file.

10.10.1.4. Why is kppp installed with the SETUID bit on?

para>There is no need for the SETUID bit, if you know a bit of UNIX® systems administration. Simply create a modem group, add all users that you want to give access to the modem to that group and make the modem device read/writable for that group. Also if you want DNS configuration to work with kppp, then /etc/resolv.conf must be read/writable by the members of that group. The same counts for /etc/ppp/pap-secrets and /etc/ppp/chap-secrets if you want to use the built-in PAP or CHAP support, respectively.

The kppp team has lately done a lot of work to make kppp setuid-safe. But it's up to you to decide if you install and how you install it.

You might also want to read the Security section.

10.10.1.5. What do I do when kppp just sits there and waits with the message: Expecting OK

Have you played with the CR/LF setting? Try CR, LF or CR/LF.

Alternatively, your modem might need some time to respond to its intialization. Open the Modem Commands dialog on the Modem tab and adjust the Pre-Init and Post-Init delays. See if you are successful when drastically increasing their values, and then do some fine-tuning later.

10.10.1.6. The connection works fine, but I can't start any applications!

You have probably selected the Auto Configure Host Name option, and the X Server has problems connecting to your newly named host. If you really need this option (and chances are you really don't), you are unfortunately on your own to set up the appropriate authorisations. Issuing xhost + before starting the connection would do the job, but be warned of the security risks involved, since this effectively gives everyone else access to your X Server.

10.10.1.7. kppp reports a successful connection, but Konqueror just says Unknown host hostname, and Netscape® reports The server does not have a DNS entry.

Try pinging another server by its IP number, e.g. ping 195.0.254.76. If that works, you could try the following:

Check if you have provided kppp with at least one DNS address.

Check the contents of /etc/host.conf. There should be a line saying something similar to order hosts, bind. The bind keyword advises the resolver library to include a name server query when performing an address lookup. If such a line is not there, try adding it.

10.10.1.8. How do I make kppp send a \n or a \r

Just send an empty string such as in the following script:

Send # send an empty string
Expect ID:
Send itsme
Expect word:
Send forgot
Expect granted
Send ppp


10.10.1.9. How can I stop kppp complaining: Can't create lock file?

This happens because you don't have permissions to create a lock file. If you chose to use a lock file, you must have write permision to the directory (typically /var/lock). This is of course no problem if you have given kppp setuid permissions. Please read the section on Lock files.

10.10.1.10. Why is my modem making so much noise when dialling?

Click on Setup, then Modem. You can control the modem volume here in three steps: Off, medium and high. For most modems, medium or high result in the same volume. If changing this setting doesn't work, make sure the correct settings for your modem are specified in Setup, Modem, Modem Commands.

10.10.1.11. I turned the modem volume to ‘Off’ and verified the modem commands, but I still hear that awful noise during dialling. Why?

The volume initialisation string can get lost if your modem can't cope with the speed it is receiving commands from kppp. Increase the value of Post-Init Delay in Setup, Modem, Modem Commands.

10.10.1.12. kppp keeps reporting unusual modem speeds like ‘115200’ or ‘57600’

Many modems only report the speed of the serial line and not the speed over the telephone line as default. You must configure these modems to report the true line speed by adding some commands to the modem init or dial strings. For many modems this command is ATW2. If you want to add it to the dial string (which normally starts with ATD), the new dial string would be ATW2D.

10.10.1.13. Why does kppp report ‘Unknown speed’

New modems often have very complex connection messages like CONNECT LAP.M/V42.bis/115000:RX/31200:TX, and kppp cannot parse this message correctly. Turn on Show Log and you'll see the connection speed.

10.10.1.14. I get a slow connection speed

If you are not satisfied with the modem speed, make sure you've set the connection speed (you can reach it by clicking on Setup, Device, Connection Speed) to 57600 or higher. Make sure your serial ports support higher speeds. Many older systems based on i486 do not work correctly if you set the speed to 115200. If you have an old 8250 UART chip, it won't work. If you have a 16550 or 16550A it should work flawlessly.

Additionally, you should consult your modem manual to look for init strings that enable a high speed mode.

10.10.1.15. I get a REALLY slow connection speed!

If data drips on at a rate of just a few bytes per second, you should check your hardware setup. If moving your mouse speeds up the transmission this is definitely a hardware issue!

You can obtain some information about your serial port with setserial -a /dev/ttySx and check for interrupt conflicts with other components of your system. The KControl module Information might also be of help here.
 
Old 09-10-2003, 03:57 PM   #3
ithaycu
LQ Newbie
 
Registered: Feb 2003
Location: Ohio
Distribution: Slackware 10.2
Posts: 16

Rep: Reputation: 0
I am having similar problems and have tried the suggestions found in the help file and other posts. I have been unable to locate the posting method used on this message board. Needless to say I have been dealing with an internet connection that max out at 800 Bytes/s nothing to write home about and in fact it's quite frustrating.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
New Fedora Internet connection slow slow slow matrim Fedora 9 07-29-2005 01:39 PM
Internet connection with KPPP dies (Modem HSP56MR) seraph-seph Slackware 11 07-09-2005 01:18 PM
Extremely Slow Internet (DNS problem?) AdmiralFreezbee Linux - Networking 1 04-02-2005 09:18 AM
very slow internet conection w/ kppp matt_w_lambert Linux - Software 8 08-31-2003 04:31 PM
kppp-connection -> programs start very slow Burna Linux - Networking 0 07-12-2003 01:12 AM


All times are GMT -5. The time now is 11:47 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration