LinuxQuestions.org
Latest LQ Deal: Complete CCNA, CCNP & Red Hat Certification Training Bundle
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 01-20-2010, 11:50 PM   #16
jo_smithey
LQ Newbie
 
Registered: Jan 2010
Posts: 11

Original Poster
Rep: Reputation: 0

Quote:
Originally Posted by cantab View Post
At the moment the drive in question is connected to the USB adapter you have, correct?

In that case, the relevant device SHOULD be
/dev/disk/by-id/usb-JMicron_USB_to_ATA.ATAPI_Bridge_152D203380B6-0:0-part1

But that device isn't there!

This means one of two things. Either the hard drive isn't properly connected to the USB adapter, or it has a broken partition table.

To determine which, run
Code:
sudo fdisk -l "/dev/disk/by-id/usb-JMicron_USB_to_ATA.ATAPI_Bridge_152D203380B6-0:0"
If the drive is connected properly, you will get some output. If it is not, you will get nothing.

edit: also, if these long disk ids are bothering you, 'ls -l /dev/disk/by-id' will tell you where the symlinks point to, which is the more usual '/dev/sdb1' or similar
sudo fdisk -l "/dev/disk/by-id/usb-JMicron_USB_to_ATA.ATAPI_Bridge_152D203380B6-0:0"

no output

I'm pretty sure the drive is connected properly because as I said early Windows XP detects the drive but it can't be viewed under "My Computer" nor "Disk Management". Someone else had suggested that I should install the drivers for the USB adapter however, I recall reading somewhere that the drivers are only needed for Windows 98 and older (and I can't find the drivers CD). The only other thing I could think of are the jumpers. The instructions from the USB adapter state to remove the jumper, as this will revert the settings of the HD to factory default.
 
Old 01-21-2010, 12:40 AM   #17
lugoteehalt
Senior Member
 
Registered: Sep 2003
Location: UK
Distribution: Debian
Posts: 1,215
Blog Entries: 2

Rep: Reputation: 49
Quote:
Originally Posted by jo_smithey View Post
sudo mount -t vfat /dev/sda1 /mnt/myDrive

Code:
root@ubuntu:/mnt/myDrive# sudo mount -t vfat /dev/sda1 /mnt/myDrive
mount: wrong fs type, bad option, bad superblock on /dev/sda1,
       missing codepage or helper program, or other error
       In some cases useful info is found in syslog - try
       dmesg | tail  or so
dmesg | tail

Code:
 VFS: Can't find a valid FAT filesystem on dev sda1.
Are we trying to mount the internal drive /dev/sda apparently or the external drive, connected by a USB thing??

If we are after the sda thing we are basically getting there. The above messages *probably* say it is there and so on, it is just that the file system type is wrong - it is not vfat - or the file system is buggered. Is there any reason to believe it is buggered?

Try it with -t ntfs as originally. Try it with sda2 instead of sda1. Does -t auto make any sense? Could look in mount's manual.

Don't know, have you already posted the output of
Code:
sudo fdisk -l
?
 
Old 01-21-2010, 12:57 AM   #18
cantab
Member
 
Registered: Oct 2009
Location: England
Distribution: *buntu, Vector
Posts: 499

Rep: Reputation: 102Reputation: 102
To be honest it would be best if the problematic drive was put back inside the Windows XP desktop, as an ATA slave drive. These USB adapters and enclosures can be a bit finicky, especially under Linux. With the drive connected 'normally', you will be able to read any data that is there for reading.

Last edited by cantab; 01-21-2010 at 12:58 AM.
 
Old 01-21-2010, 09:01 AM   #19
jo_smithey
LQ Newbie
 
Registered: Jan 2010
Posts: 11

Original Poster
Rep: Reputation: 0
Quote:
Originally Posted by lugoteehalt View Post
Are we trying to mount the internal drive /dev/sda apparently or the external drive, connected by a USB thing??

If we are after the sda thing we are basically getting there. The above messages *probably* say it is there and so on, it is just that the file system type is wrong - it is not vfat - or the file system is buggered. Is there any reason to believe it is buggered?

Try it with -t ntfs as originally. Try it with sda2 instead of sda1. Does -t auto make any sense? Could look in mount's manual.

Don't know, have you already posted the output of
Code:
sudo fdisk -l
?
We are trying to mount the 3.5" HD to the PC via the USB Adapter. I'll try your suggestions when I get home this afternoon. fdisk -l should be posted on the first page but I'll post a new one to see if anything changed.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
How to mount external hard drive vitalstrike82 SUSE / openSUSE 3 02-17-2008 01:27 AM
Cannot mount external hard drive thisObject Linux - Software 4 12-07-2006 12:53 AM
Can't mount external hard drive...HELP! Stevetgn Linux - Hardware 4 10-18-2005 08:38 PM
can't mount fs on external hard drive fatblueduck Linux - General 11 06-10-2005 04:03 PM
external hard drive mount omarbohsali Linux - Newbie 4 04-27-2005 10:24 PM


All times are GMT -5. The time now is 04:23 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration