LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 01-21-2007, 03:06 PM   #16
slybob
Member
 
Registered: Aug 2006
Location: Brighton - UK
Distribution: Ubuntu 6.06
Posts: 34

Rep: Reputation: 15
Suse, Ubuntu and Windows XP


Nothing like the tried and tested.
We have a 140gb USB drive formatted with Vfat. It works fine with Windows, Suse and Ubuntu. I think vfat is the usual formatting for most modern USB storage devices especially solid state so I think it has fairly universal compatability. I myself am a little confused about the differance between the various fats. Did work tho :-)
 
Old 01-27-2007, 05:03 PM   #17
jimbo111
LQ Newbie
 
Registered: Jan 2007
Distribution: Ubuntu 6.10
Posts: 3

Rep: Reputation: 0
Unhappy still having trouble with this myself

Hello everyone,

I new to this forum and linux so plese bear with me. I'm running Ubuntu 6.10 Edgy Eft and am unable to read data off of my external 250GB USB hard drive. The drive is formatted as FAT32 and I have the following entry in my /etc/fstab :

/dev/sda1 /media/TREKSTOR vfat rw,users,noauto 0 0

TREKSTOR is the name of the usb drive. The permissions on this directory are:

drwxr-xr-x 154 jmaroulis jmaroulis 32768 1970-01-01 01:00 TREKSTOR

I'm still unable to write to this external drive either as the user or even root. Would anyone have a solution to this annoying problem?

Many thanks
 
Old 01-27-2007, 08:37 PM   #18
slybob
Member
 
Registered: Aug 2006
Location: Brighton - UK
Distribution: Ubuntu 6.06
Posts: 34

Rep: Reputation: 15
Might be helpfull if I explain what the entry in fstab is doing,

Code:
/dev/sda1 /media/TREKSTOR vfat rw,users,noauto 0 0
/dev/sda1/ = device name

/media/TREKSTOR = mount point. This has to be an existing directory on you root fle system. for instance, for my ntfs hard drive I have /media/ntft and for my reiserfs harddrive I have /media/reiserfs

vfat = file system i.e. ntfs, fat32, ext3, reiserfs,

rw = read/write can be "ro" for read only

users = "rw" applies to all users logging into your system. "nouser" would mean only root has access.

noauto = will not mount on boot. "auto" mounts on boot.

0 0 = somthing to do with the order of backing up. go ask a guru!

Fix

I think you will be okay with editing your /etc/fstab with

Code:
/dev/sda1 /media/usb auto rw,users,auto 0 0
if you do start(kde start) --> run command --> "kdesu kate" you can edit /etc/fstab as root.

then, in the terminal input,

Code:
sudo mkdir /media/usb/
- we have to make this mount point exist.

then

Code:
sudo mount /media/usb/
and you should be able to access any USB drive that you put into you computer. . .hopefully :-)
 
Old 01-28-2007, 07:33 PM   #19
erockallstar
LQ Newbie
 
Registered: Nov 2006
Posts: 14

Original Poster
Rep: Reputation: 0
Finally

I finally got it working with ntfs-3g. I was able to figure out the mounting situation. It came down to a matter of putting a capital letter.
 
Old 01-29-2007, 01:51 AM   #20
jimbo111
LQ Newbie
 
Registered: Jan 2007
Distribution: Ubuntu 6.10
Posts: 3

Rep: Reputation: 0
Unhappy still having trouble with this myself

Quote:
Originally Posted by slybob
Might be helpfull if I explain what the entry in fstab is doing,

Code:
/dev/sda1 /media/TREKSTOR vfat rw,users,noauto 0 0
/dev/sda1/ = device name

/media/TREKSTOR = mount point. This has to be an existing directory on you root fle system. for instance, for my ntfs hard drive I have /media/ntft and for my reiserfs harddrive I have /media/reiserfs

vfat = file system i.e. ntfs, fat32, ext3, reiserfs,

rw = read/write can be "ro" for read only

users = "rw" applies to all users logging into your system. "nouser" would mean only root has access.

noauto = will not mount on boot. "auto" mounts on boot.

0 0 = somthing to do with the order of backing up. go ask a guru!

Fix

I think you will be okay with editing your /etc/fstab with

Code:
/dev/sda1 /media/usb auto rw,users,auto 0 0
if you do start(kde start) --> run command --> "kdesu kate" you can edit /etc/fstab as root.

then, in the terminal input,

Code:
sudo mkdir /media/usb/
- we have to make this mount point exist.

then

Code:
sudo mount /media/usb/
and you should be able to access any USB drive that you put into you computer. . .hopefully :-)

Thanks very much for your help on this slybob. I tried out what you suggested but unfortunately it did not work. I created a new directory as follows:

drwxrwxrwx 2 jmaroulis jmaroulis 4096 2007-01-29 07:19 usb

(By the way, when I did create this, the "usb" part was then highlighted in green, I don't know what this means...)

My /etc/fstab contains the following entry:

/dev/sda1 /media/usb auto rw,users,auto 0 0


When I fired up my external usb hard drive, it connects fine, icon created on the desktop, I can see the files, but the permissions on /media/usb get "reset" to the following:

drwxr-xr-x 154 jmaroulis jmaroulis 32768 1970-01-01 01:00 usb

And as a result, I'm unable to write to the drive (in fact, no user including root can either)...Would you or anyone have any further suggestions? Any help is appreciated.

Many thanks
 
Old 01-29-2007, 04:25 AM   #21
Junior Hacker
Senior Member
 
Registered: Jan 2005
Location: North America
Distribution: Debian testing Mandriva Ubuntu
Posts: 2,687

Rep: Reputation: 61
Have you tried writing to it as root or sudo from terminal?

mv -fra filename /mnt/data
or
cp -fra filename /mnt/data

The -f is for force without confirmation (so you don't have to hit (y) to confirm for each individual file).

The -r is for recursive, for a folder/directory, to make sure everything within gets moved also, if applicable.

The -a is for all files including hidden files if applicable.

Bash may say it failed to preserve permissions/ownership which is just the way it is with fat32.

Quote from Tinkster:

FAT inherently knows
nothing of linux permissions and ownerships. You can't
mimic linux perms on FAT

Last edited by Junior Hacker; 01-29-2007 at 04:36 AM.
 
Old 01-29-2007, 03:08 PM   #22
jimbo111
LQ Newbie
 
Registered: Jan 2007
Distribution: Ubuntu 6.10
Posts: 3

Rep: Reputation: 0
problem now fixed

Thanks to Junior Hacker and slybob for your help on this. Strange thing happened. I remember using a Windows application called SwissKnife to format my 250GB drive as Windows was unable to format a partition that big under FAT32. The format took less than a minute, so did it really format the drive?
I started to run QTParted in order to partition my external drive, as perhaps Ubuntu was not recognizing the file-system as FAT32 but NTFS as it was before I formatted it. After it read the drive and noted what file system was on it, I went ahead and resized the drive and created a new partition and formatted it to FAT32. After restarting the external hard-drive, I was now able to write to both partitions, weird.
I then put the size back to it's original and everything is now working fine. I will definitely keep slybob's settings for fstab and his full explanation and Junior Hacker's "force" commands as that helped the thought process.

Good bunch of people in this forum.

Cheers
 
Old 01-29-2007, 04:40 PM   #23
Junior Hacker
Senior Member
 
Registered: Jan 2005
Location: North America
Distribution: Debian testing Mandriva Ubuntu
Posts: 2,687

Rep: Reputation: 61
Another smart move for anybody else who may read this thread.

When ever you go to install a Linux distribution, it is wise to plug in every peripheral you have or think you may use in the future and turn it on before starting the distro installation. Chances are your distro will set everything up right.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Unable to write to external Hard Drive in Bittorent wearetheborg Linux - Hardware 2 11-07-2006 06:56 AM
Not able to set write permissions on external hard drive. jpen8560 Linux - Hardware 19 03-22-2006 11:44 AM
Can you write Knoppix 4.0.2 DVD to an External Hard Drive? knoppixguy Linux - Distributions 1 01-12-2006 03:51 PM
Write permissions for external hard drive kg4ysy Linux - Hardware 1 05-19-2005 06:36 AM
Write to external USB hard drive Rob Roye Linux - Software 6 07-06-2004 05:15 PM


All times are GMT -5. The time now is 03:09 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration