-   Linux - Newbie (
-   -   external hard drive and flash disk connected to usb doesn't show (

algerinbeijing 10-25-2010 05:55 AM

external hard drive and flash disk connected to usb doesn't show
a friend of mine just given me an old 2004 IBM NetVista 8305 desktop and suggested to use Linux Ubuntu which is something new to me. So i installed it via USB memory stick & it works. After installation of the OS I am impressed with functionality & speed.

Now my problem: when i conect the external hard drive via usb it doesn't show & i tried my usb flash disc it showed the same problem. I tried both disk in my laptop (Windows XP) & it works.

Please advise

camorri 10-25-2010 06:36 AM

Open a konsole, and run the command 'sudo lsusb' ( just what is between the quotes ), and post the results, of course with the devices connected you can not see. You will have to enter the root password for the command to work.

Disk drives have to be mounted, as do memory sticks. You should see someoutput like this:


Bus 001 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 002 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 002 Device 004: ID 0781:5530 SanDisk Corp.
The last line is my memory stick. Could you also post the version of Ubuntu you installed?

fbobraga 10-25-2010 06:43 AM

A Google search showed that this machine has weird USB ports: mounting the drives by hand may work, but, I think, the "automagically" mount will not work for anything

tij 10-25-2010 08:05 PM

You could also try opening a terminal and typing fdisk-l with the hard drive plugged into your computer. You should be able to decipher the correct drive based on size. For example, if you have a 250 GB drive look for something like "Disk /dev/sdb: 250 GB." Look below this listing for something like
"/dev/sdb2..." The "/dev/sdb2" is the important part here. It tells your system where to find this unmounted drive. In order to mount the drive /dev/sdb2, open a terminal and type "sudo mount /dev/sdb2 /some/mount/point" where /some/mount/point is an empty file (you can create it/name it whatever you want). You should now be able to open /some/mount/point (or whatever you named the file) and see the contents of your drive.

If you want this drive to automatically mount every time you boot your system, look into the /etc/fstab file.

tailinlinux 10-25-2010 09:18 PM

log as root

type /etc/init.d/haldaemon restart
then enter

algerinbeijing 11-02-2010 06:13 AM

Hi, first of all thank you for the fast response. Sorry for my late reply as i am struggling to find out the cause of the problem. This is my first time to use this OS - UBUNTU 10.04.

I have tried all your advises with the help of my friend (who advise me to use Ubuntu) & we found some of them are correct but still doesn't solve the problem. I end up buying a new case (due to the chip not compatible) for my external hard (seagate barracuda) & now it works. But putting together my flash drives (2GB each) & the external HDD only one of them will show.

Awhile ago all my external drives are working after I removed my wireless USB adapter from TP-Link (TL-WN821N). I tried to install it back, remove all the external drives & install the drives back one by one & only 1 drive showed up.

I was wondering how this thing happen since the first time I use this TP-Link adapter it works starightaway with Ubuntu.

Thanks n regards,

camorri 11-02-2010 09:10 AM

There is no straight forward answer to your question.


I was wondering how this thing happen since the first time I use this TP-Link adapter it works starightaway with Ubuntu.
To help yourself, you need to use some of the commands like 'lsusb' to display the usb devices that Ubuntu is seeing at any given point in time. The system to detect a hot plugged device is quite complicated, and there may be a problem with it.

If the TP-Link adapter worked at one point, this tells me the driver got installed, and the device got activated. Removing the hardware will not remove the driver, so it is still there. There are command to activate the adapter. Ubuntu 10.04 has an applet installed by default called Network Manager. You can access it from System-->Preferences-->Network Connections. This will bring up an application that shows the installed adapter(s), wired and wireless. There may be an icon on the top bar that looks like a 'radar' symbol. You can click it to see if your wireless adapter is connected to a network.

To tell for sure if an adapter is active, from a konsole run the command 'sudo ifconfig'. The output will show the status of the installed adapters. They may be down, in which case nothing is shown. To activate an adapter, like eth0, the command would be 'sudo ifconfig eth0 up'. For sudo, you need the root password. The wireless adapter would be named something like 'wlan0'. ( it could be different ). Activating the adapter, will not necessarily cause it to connect to a network. The gui tools are for that, or command line...

As for the different USB devices not showing up, there are many possibilities for that problem. It could be an IRQ problem or even a BIOS configuration problem. From here I can not tell.

You can find NetVista documentation online through IBM web sites. That may help you out with BIOS settings. If you can not find it, post the exact model information for the system. It will be on the serial number tag for the system. It will be 8305- something. There are many models possible.

Hope this helps.

algerinbeijing 11-06-2010 09:35 PM

Hi, thanks for your response. I followed your advise to check the Network Connections and everything is shown as what you described. I discussed your advise with my friend & told me to try to connect the TP-link in every port & see whats the outcome. There are 6 USB ports with my computer (2 @ front panel & 4 @ back). 2 USB ports @ the back are used for mouse & keyboard. On the beginning I always connect the TP-Link on the front port. When I transferred it @ the back everything are shown & works fine. I observed this situation for several days & seems no problem anymore. But still wondering! Anyway my problem is solve now. Big thanks to you and the rest who contribute there ideas.

camorri 11-07-2010 04:56 AM

Glad it is resolved.

Right now I have an issue with a usb ups not being detected. I have read a lot of threads on this topic. Seems on some systems the from ports are on a longer cable than the back ports. The delay of the cable may have caused the problem, or there could be a problem with the cable.

All times are GMT -5. The time now is 02:27 AM.