LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 06-01-2016, 06:06 PM   #1
kenw232
Member
 
Registered: May 2006
Posts: 78

Rep: Reputation: 2
Extended characters in terminal not working?


I'm running CentOS 7. I'm using SecureCRT 6 and set my terminal emulation type to ANSI but don't see the extended characters. Why?

This is what I see when I do stuff in the terminal:
http://sites.extremehosting.ca/temp/terminal.jpg

server(/etc): set | grep TERM
TERM=ansi

locale.conf:LANG="en_US.UTF-8"
 
Old 06-02-2016, 12:31 AM   #2
Yury_T
Member
 
Registered: Aug 2008
Distribution: Slackware
Posts: 51
Blog Entries: 6

Rep: Reputation: 16
Might be you don't have utf8 enabled for your console.
Look for/set this in kernel command line (in lilo.conf and such) " vt.default_utf8=1 ".

If snapshot was from xterm or such, then check in xterm whether you have environment variable XTERM_LOCALE with "en_US.UTF-8". You might have to edit your ~/.bashrc and ~/.profile and put the same LANG setting there (I don't remember off the top of my head which is for logins and which is for common runs of shell).
 
Old 06-02-2016, 12:35 AM   #3
kenw232
Member
 
Registered: May 2006
Posts: 78

Original Poster
Rep: Reputation: 2
I had to change fonts, and set UTF8 which became available after I did it in SecureCRT.

Thanks.
 
Old 06-15-2016, 07:21 AM   #4
Tim Abracadabra
Member
 
Registered: May 2014
Location: USA, Wherever I may Roam
Distribution: Debian w/Xfce, LFS 7.9, ++
Posts: 117

Rep: Reputation: Disabled
Thanks for the resolution.
When you get the chance, can you mark this thread as solved?
Thanks
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Extended ASCII characters on Framebuffer Console BoraxMan Linux - Desktop 3 12-12-2011 12:10 PM
[SOLVED] Remove all lines containing extended characters hattori.hanzo Programming 8 11-09-2010 07:24 AM
using extended ascii characters sasser Linux - Newbie 2 04-06-2010 09:50 AM
bash printing extended ASCII characters nutthick Programming 6 02-04-2005 03:15 PM
Extended ASCII characters in UNIX MatSzor Programming 5 05-15-2004 10:57 PM


All times are GMT -5. The time now is 10:39 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration