LinuxQuestions.org
Support LQ: Use code LQ3 and save $3 on Domain Registration
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 07-23-2012, 09:49 AM   #1
jideck
LQ Newbie
 
Registered: Dec 2010
Posts: 10

Rep: Reputation: 0
Question export display don't work AIX ->fedora17


Hello! need some help
try to export display från server (aix) to my fedora desktop.
steps done:


ON HOST
ssh -x aixserver
DISABLED IPTABLES AND SELINUX
vi /etc/ssh/sshd_config
PermitRootLogin yes
xhost+ aixserver
xhost
INET:aixserver

on server:
export display 10.12.14.15:0.1 (OK)
ping 10.12.14.15 (OK)
echo @DISPLAY
10.12.14.15:0.1
xclock
Error:Can't open Display........ (as well as the TSM config don't start)
what more to do?
 
Old 07-23-2012, 10:03 AM   #2
TB0ne
LQ Guru
 
Registered: Jul 2003
Location: Birmingham, Alabama
Distribution: SuSE, RedHat, Slack,CentOS
Posts: 17,926

Rep: Reputation: 3690Reputation: 3690Reputation: 3690Reputation: 3690Reputation: 3690Reputation: 3690Reputation: 3690Reputation: 3690Reputation: 3690Reputation: 3690Reputation: 3690
Quote:
Originally Posted by jideck View Post
Hello! need some help
try to export display från server (aix) to my fedora desktop.
steps done:


ON HOST
ssh -x aixserver
DISABLED IPTABLES AND SELINUX
vi /etc/ssh/sshd_config
PermitRootLogin yes
xhost+ aixserver
xhost
INET:aixserver

on server:
export display 10.12.14.15:0.1 (OK)
ping 10.12.14.15 (OK)
echo @DISPLAY
10.12.14.15:0.1
xclock
Error:Can't open Display........ (as well as the TSM config don't start)
what more to do?
First, permitting root login over a network connection is a VERY BAD IDEA, and you should never need to do that. And you don't need to edit the SSH config file for X windows, unless its for the X forwarding parameter.

Chances are, your local (Fedora) X server isn't allowing incoming connections. In a terminal window, do a "ps -ef | grep -i nolisten", and see what comes up. You'll probably see your X server started with that parameter, which means it won't allow a remote X system to open a window, no matter what else you do.

If you enable X forwarding in the sshd_config file, you should be able to use the fowarding mechanism to run it like:
Code:
ssh -X AIXBOX "X application to run"
...and it'll pop up. Or, the simpler way to do it is to edit the /etc/sysconfig/displaymanager file, and look for the "DISPLAYMANAGER_XSERVER_TCP_PORT_6000_OPEN=" line, and change it to YES. You'll have to reboot your Fedora box, and when you do, you'll see the "-NOLISTEN" parameter will be gone from your X server. From there, run your "xhost <aixbox>", or "xhost +", and you should be working.
 
1 members found this post helpful.
Old 07-23-2012, 10:17 AM   #3
jideck
LQ Newbie
 
Registered: Dec 2010
Posts: 10

Original Poster
Rep: Reputation: 0
]# ps -ef |grep -i nolisten
root 1185 1177 0 09:58 tty1 00:03:06 /usr/bin/Xorg :0 -background none -logverbose 7 -auth /var/run/gdm/auth-for-gdm-aTnYZc/database -seat seat0 -nolisten tcp vt1
root 4649 3776 0 16:13 pts/4 00:00:00 grep --color=auto -i nolisten


# xhost
access control disabled, clients can connect from any host
INET:aixserver
SI:localuser:john12

Last edited by jideck; 07-23-2012 at 10:18 AM. Reason: adding stuff
 
Old 07-23-2012, 10:25 AM   #4
jideck
LQ Newbie
 
Registered: Dec 2010
Posts: 10

Original Poster
Rep: Reputation: 0
ssh -X

Code:
ssh -X AIXBOX "X application to run"
same result as before tested also with -Y

enabling root is temporary
 
Old 07-23-2012, 10:33 AM   #5
jideck
LQ Newbie
 
Registered: Dec 2010
Posts: 10

Original Poster
Rep: Reputation: 0
/etc/sysconfig/displaymanager is not there and I can't find it


result on server is the same
> echo $DISPLAY
fedorabox:0.1

xclock
Error: Can't open display:fedorabox:0.1
 
Old 07-23-2012, 10:39 AM   #6
jideck
LQ Newbie
 
Registered: Dec 2010
Posts: 10

Original Poster
Rep: Reputation: 0
cat sshd_conf on aixbox

AllowTcpForwarding yes
#GatewayPorts no
X11Forwarding yes
X11DisplayOffset 10
X11UseLocalhost yes

cat ssh_conf fedorabox

# Host *
# ForwardAgent no
ForwardX11 yes
ForwardX11Trusted yes
GSSAPIAuthentication yes
 
Old 07-23-2012, 12:10 PM   #7
TB0ne
LQ Guru
 
Registered: Jul 2003
Location: Birmingham, Alabama
Distribution: SuSE, RedHat, Slack,CentOS
Posts: 17,926

Rep: Reputation: 3690Reputation: 3690Reputation: 3690Reputation: 3690Reputation: 3690Reputation: 3690Reputation: 3690Reputation: 3690Reputation: 3690Reputation: 3690Reputation: 3690
..and until you remove the "-nolisten" from your X server on your Fedora system, NOTHING you try will allow incoming X sessions. That file is there in openSUSE, but you can also try running "gdmsetup", and allowing remote connections there. Again, you will have to reboot for things to take effect.

I'm no expert in Fedora, but until the "-nolisten" flag is gone from your X server, it WILL NOT WORK. Check the files in /etc/X11, and also look for a parameter called "DisallowTCP", as another course of action. Normally, the displaymanager file contains that flag, and other scripts will then look at it, and set variables accordingly.
 
1 members found this post helpful.
Old 07-24-2012, 03:19 AM   #8
jideck
LQ Newbie
 
Registered: Dec 2010
Posts: 10

Original Poster
Rep: Reputation: 0
Quote:
Originally Posted by TB0ne View Post
...and it'll pop up. Or, the simpler way to do it is to edit the /etc/sysconfig/displaymanager file, and look for the "DISPLAYMANAGER_XSERVER_TCP_PORT_6000_OPEN=" line, and change it to YES. You'll have to reboot your Fedora box, and when you do, you'll see the "-NOLISTEN" parameter will be gone from your X server. From there, run your "xhost <aixbox>", or "xhost +", and you should be working.
thanks for reply but I can't find "/etc/sysconfig/displaymanager" maybe becouse its Fedora 17 so can this file has another name??
 
Old 07-24-2012, 03:22 AM   #9
jideck
LQ Newbie
 
Registered: Dec 2010
Posts: 10

Original Poster
Rep: Reputation: 0
Quote:
Originally Posted by TB0ne View Post
..and until you remove the "-nolisten" from your X server on your Fedora system, NOTHING you try will allow incoming X sessions. That file is there in openSUSE, but you can also try running "gdmsetup", and allowing remote connections there. Again, you will have to reboot for things to take effect.

I'm no expert in Fedora, but until the "-nolisten" flag is gone from your X server, it WILL NOT WORK. Check the files in /etc/X11, and also look for a parameter called "DisallowTCP", as another course of action. Normally, the displaymanager file contains that flag, and other scripts will then look at it, and set variables accordingly.
txs again but I don't know what to do with this -nolisten , how shood I remove it?
 
Old 07-24-2012, 03:53 AM   #10
jideck
LQ Newbie
 
Registered: Dec 2010
Posts: 10

Original Poster
Rep: Reputation: 0
gdmsetup
bash: gdmsetup: command not found...
Similar command is: 'dmsetup'


I work on Fedora 3.4.5-2.fc17.x86_64, I tryed dmsetup, but I can't find anythig there about nollist or X
it is about devices and file system only.

ps -ef | grep X
root 1185 1177 0 Jul23 tty1 00:04:56 /usr/bin/Xorg :0 -background none -logverbose 7 -auth /var/run/gdm/auth-for-gdm-aTnYZc/database -seat seat0 -nolisten tcp vt1

Last edited by jideck; 07-24-2012 at 03:56 AM.
 
Old 07-24-2012, 04:23 AM   #11
jideck
LQ Newbie
 
Registered: Dec 2010
Posts: 10

Original Poster
Rep: Reputation: 0
/etc/X11/xinit/xserverrc shood have the entry and disable nolisten but this file dont exist on my "defalut" system

]# ls /etc/X11/xinit/
Xclients Xclients.d xinitrc xinitrc-common xinitrc.d xinput.d xinputrc Xsession

 
Old 07-30-2012, 06:08 AM   #12
jideck
LQ Newbie
 
Registered: Dec 2010
Posts: 10

Original Poster
Rep: Reputation: 0
I tryed

# systemctl status sshd.service

enable openssh server:

# systemctl enable sshd.service
ln -s '/usr/lib/systemd/system/sshd.service' '/etc/systemd/system/multi-user.target.wants/sshd.service'

and finally run:

# systemctl start sshd.service

and log in as root (the su - somehow diable xforwarding)
and its works fine of cource I have to disable root login whene installation nad configuration wizard of TSM 6.3 is done.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
How to edit .bashrc such that I don't need to export on every new session? golmschenk Linux - Newbie 3 03-07-2011 10:20 PM
export display and Gtk-WARNING **: cannot open display: zimma Linux - Server 0 04-24-2009 03:51 AM
What is the difference between DISPLAY= and export DISPLAY=?? john test Linux - Newbie 4 09-01-2008 07:41 PM
export AIX $DISPLAY to Ubuntu Doomhammer AIX 4 09-20-2007 10:18 PM
Samba - don't display shares if you don't have permissions? kailun Linux - Server 3 05-07-2007 08:00 PM


All times are GMT -5. The time now is 08:57 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration