LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 06-17-2003, 05:59 PM   #16
DrOzz
Senior Member
 
Registered: May 2003
Location: Sydney, Nova Scotia, Canada
Distribution: slackware
Posts: 4,185

Rep: Reputation: 59

did you use the -i with rpm or -U when trying to install the newer version of gcc?
 
Old 06-17-2003, 06:25 PM   #17
Genesis
Member
 
Registered: Jun 2003
Distribution: Slackware 9
Posts: 45

Original Poster
Rep: Reputation: 15
I used -i for install. If you have AIM post your sn here so I can talk to you on there. Thanks. Also, I wasnt trying to install a newer version. The kernel source would not install with the curennt gc. I was trying to install one older than the one already installed. And gc needs cp or something. CPP I think.

Last edited by Genesis; 06-17-2003 at 06:30 PM.
 
Old 06-17-2003, 06:55 PM   #18
DrOzz
Senior Member
 
Registered: May 2003
Location: Sydney, Nova Scotia, Canada
Distribution: slackware
Posts: 4,185

Rep: Reputation: 59
well if you say:
gcc >= 2.96-98 is needed by kernel-source-2.4.20-18.9
then wouldn't you want to install a newer version of gcc, cause obviously by looking at that dependancy it says you need gcc greater than or equal to 2.96..


oh and no i don't have aim
 
Old 06-17-2003, 06:59 PM   #19
Genesis
Member
 
Registered: Jun 2003
Distribution: Slackware 9
Posts: 45

Original Poster
Rep: Reputation: 15
Yes but...

Yes but... when I install the newer version of gcc (3. something) the linux kernel source installer says it require version 2. something.
 
Old 06-17-2003, 07:10 PM   #20
DrOzz
Senior Member
 
Registered: May 2003
Location: Sydney, Nova Scotia, Canada
Distribution: slackware
Posts: 4,185

Rep: Reputation: 59
you know what d00d, you lost me now...i understand what your saying but somewheres along the lines you did something wrong cause there is no need to be going through all this....so this is my ultimatum....reboot your computer and select your old kernel from the list and then install the nvidia drivers....and keep using this kernel the hell with the other one....go to the prompt and issue the command rpm -e kernel-2.4-20 or whatever it is...

.....and thats my final answer :O:P
 
Old 06-17-2003, 07:41 PM   #21
Genesis
Member
 
Registered: Jun 2003
Distribution: Slackware 9
Posts: 45

Original Poster
Rep: Reputation: 15
I think im going with suse

I think I am going to go with suse Linux... Gonna install it now...
 
Old 10-21-2003, 03:58 PM   #22
InZaN3_CrIcKeT
LQ Newbie
 
Registered: Oct 2003
Posts: 20

Rep: Reputation: 0
I know this is an old post, but I just installed RedHat yesteray. Also, I may end up figuring this out, but if anybody sees this post, I'd appreciate a response as I know you guys know the answer. How do I edit the /ect/inittab file from the console (while using the 3 option)?
 
Old 10-21-2003, 04:43 PM   #23
vasudevadas
Member
 
Registered: Jul 2003
Location: Bedford, UK
Distribution: Slackware 11.0, LFS 6.1
Posts: 519

Rep: Reputation: 30
As root, type:

vi /etc/inittab

and edit the file. I suppose I should ask at this point: you familiar with vi? (It will be a problem if you're not, vi cannot be intuited).
 
Old 10-21-2003, 05:17 PM   #24
InZaN3_CrIcKeT
LQ Newbie
 
Registered: Oct 2003
Posts: 20

Rep: Reputation: 0
Unfortunately not. :-(
 
Old 10-22-2003, 01:27 PM   #25
vasudevadas
Member
 
Registered: Jul 2003
Location: Bedford, UK
Distribution: Slackware 11.0, LFS 6.1
Posts: 519

Rep: Reputation: 30
If you can use some other text editor to edit the file then fine, but you have to be able to do it as root.

If you have to use vi, do this:

vi /etc/inittab

then position the cursor over the 3 in "id:3:initdefault:". Now press the following keys, in this order:

lowercase s
5
escape
:
w
q
return

and you have just edited your /etc/inittab to make you computer boot up into x server by default.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
exiting x-server Shin Natsume Linux - Newbie 2 04-01-2005 02:56 AM
Exiting X server Thommy Mandriva 6 02-02-2005 03:12 AM
Exiting X server arcpromo Linux - Software 1 08-14-2004 07:05 PM
Exiting X server to install nvidia driver odogg Linux - Newbie 1 11-26-2003 01:05 PM
exiting x server zexter Linux - Software 5 11-02-2003 01:14 AM


All times are GMT -5. The time now is 01:03 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration