LinuxQuestions.org
LinuxAnswers - the LQ Linux tutorial section.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices

Reply
 
LinkBack Search this Thread
Old 07-04-2011, 04:41 AM   #1
Ruarscampbell
LQ Newbie
 
Registered: Jul 2011
Posts: 4

Rep: Reputation: Disabled
Unhappy executing "DOS/Windows executable" files from "/media"


It seems all .exe files work from my /home folder, however as this didn't have enough space I installed a game(World of Warcraft) onto one of the file systems in /media folder. The game worked perfectly when I played it on Linux Mint 9 but when I upgraded to Linux mint 11 it wasn't marked as executable. When I attempt to change the permissions from properties to "allow executing file as program", it instantly deselects the box and double clicking has no effect. I've tried the "chmod +x" command from the terminal and that has no effect either. I can't move the file to my "/home" folder as it's too large. Any help please?

Last edited by Ruarscampbell; 07-04-2011 at 05:06 AM.
 
Old 07-04-2011, 05:09 AM   #2
colucix
Moderator
 
Registered: Sep 2003
Location: Bologna
Distribution: CentOS 6.5 OpenSuSE 12.3
Posts: 10,362

Rep: Reputation: 1910Reputation: 1910Reputation: 1910Reputation: 1910Reputation: 1910Reputation: 1910Reputation: 1910Reputation: 1910Reputation: 1910Reputation: 1910Reputation: 1910
Maybe the /media filesystem was mounted with the noexec option. What are the current mount options (you can verify using the mount command without arguments)? Is there an entry in /etc/fstab for this filesystem?
 
Old 07-04-2011, 09:14 AM   #3
i92guboj
Gentoo support team
 
Registered: May 2008
Location: Lucena, Córdoba (Spain)
Distribution: Gentoo
Posts: 4,029

Rep: Reputation: 368Reputation: 368Reputation: 368Reputation: 368
I don't think you need +x for .exe files to work, since they are not loaded using the ELF loader. They are open by wine just like oowriter would open your .doc files. Maybe you just need to install wine, or otherwise, make sure that exe files are associated to wine.
 
1 members found this post helpful.
Old 07-04-2011, 11:14 AM   #4
DavidMcCann
Senior Member
 
Registered: Jul 2006
Location: London
Distribution: CentOS, Salix
Posts: 2,826

Rep: Reputation: 724Reputation: 724Reputation: 724Reputation: 724Reputation: 724Reputation: 724Reputation: 724
Assuming you actually re-installed Wine after installing a new Mint, there's probably just a problem with the Wine path. Wine should have programs in
/home/yourname/.wine/drive_c/Program Files
which it will call
c:\Program Files
You need to create a drive letter for where the files live. Run the Wine configuration tool and check what you've done. I have the root partition set up as z: so /media/wine/ would be z:\media\wine. You could, of course, name your special directory w: so that you'd run something like w:\program\program.exe.
 
Old 07-05-2011, 04:32 AM   #5
Ruarscampbell
LQ Newbie
 
Registered: Jul 2011
Posts: 4

Original Poster
Rep: Reputation: Disabled
Quote:
Originally Posted by colucix View Post
Maybe the /media filesystem was mounted with the noexec option. What are the current mount options (you can verify using the mount command without arguments)? Is there an entry in /etc/fstab for this filesystem?
There is no entry in /etc/fstab for the filesystem, when I use the mount command it's already mounted according to /dev/sda5 and shows no mount options. To all the others asking about wine, thank you, but I have re-installed wine when I got Linux Mint 11 and I have downloaded the .exe file into the wine "c:" file. But thankyou for trying it was probably my fault for not explaining that.
 
Old 07-05-2011, 09:14 AM   #6
colucix
Moderator
 
Registered: Sep 2003
Location: Bologna
Distribution: CentOS 6.5 OpenSuSE 12.3
Posts: 10,362

Rep: Reputation: 1910Reputation: 1910Reputation: 1910Reputation: 1910Reputation: 1910Reputation: 1910Reputation: 1910Reputation: 1910Reputation: 1910Reputation: 1910Reputation: 1910
Quote:
Originally Posted by Ruarscampbell View Post
when I use the mount command it's already mounted according to /dev/sda5 and shows no mount options.
Some option should appear, e.g. /dev/sda5 on /media/disk type ext3 (rw,nosuid,nodev). At least the rw or ro option should be there.
 
Old 07-05-2011, 10:37 AM   #7
Ruarscampbell
LQ Newbie
 
Registered: Jul 2011
Posts: 4

Original Poster
Rep: Reputation: Disabled
Quote:
Originally Posted by colucix View Post
Some option should appear, e.g. /dev/sda5 on /media/disk type ext3 (rw,nosuid,nodev).
I've copied and pasted the entire terminal command and response here:

famcam@famcam-desktop ~ $ mount /media/secondpt
mount: according to mtab, /dev/sda5 is already mounted on /media/secondpt
mount failed

Have I done something wrong?
 
Old 07-05-2011, 10:47 AM   #8
colucix
Moderator
 
Registered: Sep 2003
Location: Bologna
Distribution: CentOS 6.5 OpenSuSE 12.3
Posts: 10,362

Rep: Reputation: 1910Reputation: 1910Reputation: 1910Reputation: 1910Reputation: 1910Reputation: 1910Reputation: 1910Reputation: 1910Reputation: 1910Reputation: 1910Reputation: 1910
Your command tries to mount /media/secondpt, hence the error message. To see the already mounted files and their mount options just run the mount command alone (without options and without arguments).
 
Old 07-05-2011, 10:58 AM   #9
Ruarscampbell
LQ Newbie
 
Registered: Jul 2011
Posts: 4

Original Poster
Rep: Reputation: Disabled
woops, sorry. So after running the mount command the options for /media/secondpt are these:

/dev/sda5 on /media/secondpt type fuseblk (rw,nosuid,nodev,allow_other,blksize=4096,default_permissions)
 
Old 07-05-2011, 11:07 AM   #10
colucix
Moderator
 
Registered: Sep 2003
Location: Bologna
Distribution: CentOS 6.5 OpenSuSE 12.3
Posts: 10,362

Rep: Reputation: 1910Reputation: 1910Reputation: 1910Reputation: 1910Reputation: 1910Reputation: 1910Reputation: 1910Reputation: 1910Reputation: 1910Reputation: 1910Reputation: 1910
Well, it looks like there is no problem with exec permissions. Anyway, you can give it a try and remount the filesystem marking all files as executables:
Code:
mount -o remount,mode=0777,exec /media/secondpt
This advice is from the official wine FAQ, here.
 
Old 07-05-2011, 05:48 PM   #11
jefro
Guru
 
Registered: Mar 2008
Posts: 10,255

Rep: Reputation: 1256Reputation: 1256Reputation: 1256Reputation: 1256Reputation: 1256Reputation: 1256Reputation: 1256Reputation: 1256Reputation: 1256
/media is usually for removable media. Don't mount to media make a different folder.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
[SOLVED] Errors executing shell script: "command not found" and "no such file or directory" eko000 Linux - Newbie 1 01-14-2011 07:54 AM
How to stop files moved to Linux from Windows via USB being marked "executable"? rnturn Linux - General 4 09-28-2010 07:32 PM
Moving text files between Windows and Linux: Unicode and "executable" problems AchubaNanoiaBR Linux - Newbie 2 07-04-2009 04:15 PM
"list dynamic dependency" of an executable using command other than "ldd" Amrita@3086 Solaris / OpenSolaris 3 04-04-2007 04:56 AM
Cedega and Fat32 (Invalid path "." given for "--use-dos-cwd") bdox Linux - Games 0 03-26-2005 02:48 AM


All times are GMT -5. The time now is 11:56 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration