LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 08-02-2010, 03:48 AM   #16
linuxlover.chaitanya
Senior Member
 
Registered: Apr 2008
Location: Nagpur, India
Distribution: Cent OS 5/6, Ubuntu Server 10.04
Posts: 4,629

Rep: Reputation: Disabled

Yes you can delete it that way. You need to be sure you give the command on the right directory.

Eric beat me with the typing speed.
 
Old 08-02-2010, 03:50 AM   #17
Xanios
Member
 
Registered: Jul 2010
Posts: 216

Original Poster
Rep: Reputation: 30
Hi,

it still doesn't get deleted. $dir/cacert.pem still remains.
 
Old 08-02-2010, 03:55 AM   #18
EricTRA
LQ Guru
 
Registered: May 2009
Location: Gibraltar, Gibraltar
Distribution: Fedora 20 with Awesome WM
Posts: 6,805
Blog Entries: 1

Rep: Reputation: 1295Reputation: 1295Reputation: 1295Reputation: 1295Reputation: 1295Reputation: 1295Reputation: 1295Reputation: 1295Reputation: 1295
Hello,

Are you logged in as root or as regular user? If regular user try executing the command with sudo?
Code:
sudo rm -r /etc/ssl/CA/cacert.pm
Kind regards,

Eric
 
Old 08-02-2010, 04:02 AM   #19
Xanios
Member
 
Registered: Jul 2010
Posts: 216

Original Poster
Rep: Reputation: 30
still can't.

Code:
xanios@ubuntu:~$ sudo rm -r /etc/ssl/CA/cacert.pm
[sudo] password for xanios: 
rm: cannot remove `/etc/ssl/CA/cacert.pm': No such file or directory
does it mean i have to delete it using this:

Code:
sudo rm -r /etc/ssl/CA/$dir/cacert.pem
 
Old 08-02-2010, 04:04 AM   #20
linuxlover.chaitanya
Senior Member
 
Registered: Apr 2008
Location: Nagpur, India
Distribution: Cent OS 5/6, Ubuntu Server 10.04
Posts: 4,629

Rep: Reputation: Disabled
That is what I said. You need to be sure of the location of the certificate and at which location you give the command. It says there is no file you are trying to delete. Either the location is incorrect or the filename. verify both.
 
Old 08-02-2010, 04:08 AM   #21
Xanios
Member
 
Registered: Jul 2010
Posts: 216

Original Poster
Rep: Reputation: 30
Hi,

When i first created the CA Certificate, i issued the command at home directory:

Code:
xanios@ubuntu:~$ /usr/lib/ssl/misc/CA.pl -newca
i supposed that is called home directory. so by right when i delete the certificate from the same home directory, it should work.
 
Old 08-02-2010, 04:21 AM   #22
EricTRA
LQ Guru
 
Registered: May 2009
Location: Gibraltar, Gibraltar
Distribution: Fedora 20 with Awesome WM
Posts: 6,805
Blog Entries: 1

Rep: Reputation: 1295Reputation: 1295Reputation: 1295Reputation: 1295Reputation: 1295Reputation: 1295Reputation: 1295Reputation: 1295Reputation: 1295
Hello,

When you create a certificate with OpenSSL it uses the /etc/ssl/openssl.conf file to get the preferences. Did you check that file as I posted for the location of where the CA certificate will be saved? Check the directory as linuxlover.chaitanya indicated:
Code:
ls -al /etc/ssl/CA
to see if the file exists.

One thing comes to mind. When you executed the command did you accept the default or did you provide a name for the certificate? The first question when you run
Code:
/usr/lib/ssl/misc/CA.pl -newca
is to provide a filename or press enter to create.

If you typed a name for the certificate then of course cacert will not exist. Post the output of the command typed above to see what's in that directory.

Kind regards,

Eric
 
Old 08-02-2010, 04:23 AM   #23
Xanios
Member
 
Registered: Jul 2010
Posts: 216

Original Poster
Rep: Reputation: 30
Hi,

Code:
xaniosg@ubuntu:~$ sudo ls -al /etc/ssl/CA
[sudo] password for xanios: 
ls: cannot access /etc/ssl/CA: No such file or directory
I did not provide a name for the certificate, i just press 'enter'. So it's the default one.

Code:
[ CA_default ]
dir		= ./demoCA		# Where everything is kept
certificate	= $dir/cacert.pem <<	# The CA certificate

Last edited by Xanios; 08-02-2010 at 04:25 AM.
 
Old 08-02-2010, 04:36 AM   #24
linuxlover.chaitanya
Senior Member
 
Registered: Apr 2008
Location: Nagpur, India
Distribution: Cent OS 5/6, Ubuntu Server 10.04
Posts: 4,629

Rep: Reputation: Disabled
Your directory where certificate is located is demoCA
 
Old 08-02-2010, 04:40 AM   #25
Xanios
Member
 
Registered: Jul 2010
Posts: 216

Original Poster
Rep: Reputation: 30
Hello,

Okay thanks, didn't notice it.

So i should go into demoCA first and delete the file which is:

Code:
xanios@ubuntu:~$ cd demoCA
xanios@ubuntu:~/demoCA$ sudo rm -r /etc/ssl/CA/cacert.pm
[sudo] password for xanios: 
rm: cannot remove `/etc/ssl/CA/cacert.pm': No such file or directory
cd [something] is to go into a directory right.
but why they still give me 'cannot remove...'
Sorry, quite new in linux

Last edited by Xanios; 08-02-2010 at 04:42 AM.
 
Old 08-02-2010, 04:42 AM   #26
EricTRA
LQ Guru
 
Registered: May 2009
Location: Gibraltar, Gibraltar
Distribution: Fedora 20 with Awesome WM
Posts: 6,805
Blog Entries: 1

Rep: Reputation: 1295Reputation: 1295Reputation: 1295Reputation: 1295Reputation: 1295Reputation: 1295Reputation: 1295Reputation: 1295Reputation: 1295
Hi,

Beaten by linuxlover.chaitanya this time

As indicated before, the openssl.conf file holds your default configuration and it says it's saving in ./demoCA. This means that where you execute the command to create the certificate, that's where a directory demoCA will be created holding your certificate files.

Since you executed the command in your home directory you should have that demoCA directory there.

Kind regards,

Eric
 
Old 08-02-2010, 04:43 AM   #27
EricTRA
LQ Guru
 
Registered: May 2009
Location: Gibraltar, Gibraltar
Distribution: Fedora 20 with Awesome WM
Posts: 6,805
Blog Entries: 1

Rep: Reputation: 1295Reputation: 1295Reputation: 1295Reputation: 1295Reputation: 1295Reputation: 1295Reputation: 1295Reputation: 1295Reputation: 1295
Quote:
Originally Posted by Xanios View Post
Hello,

Okay thanks, didn't notice it.

So i should go into demoCA first and delete the file which is:

Code:
xanios@ubuntu:~$ cd demoCA
xanios@ubuntu:~/demoCA$ sudo rm -r /etc/ssl/CA/cacert.pm
[sudo] password for xanios: 
rm: cannot remove `/etc/ssl/CA/cacert.pm': No such file or directory
cd [something] is to go into a directory right.
but why they still give me 'cannot remove...'
Sorry, quite new in linux
Hi,

When in the demoCA directory type:
Code:
ls -al
and post the output here.

Kind regards,

Eric
 
Old 08-02-2010, 04:45 AM   #28
EricTRA
LQ Guru
 
Registered: May 2009
Location: Gibraltar, Gibraltar
Distribution: Fedora 20 with Awesome WM
Posts: 6,805
Blog Entries: 1

Rep: Reputation: 1295Reputation: 1295Reputation: 1295Reputation: 1295Reputation: 1295Reputation: 1295Reputation: 1295Reputation: 1295Reputation: 1295
Oops,

Just noticed:

When you're in the demoCA dir just type:
Code:
sudo rm -r cacert.pem
and not
Code:
sudo rm -r /etc/ssl/CA/cacert.pm
Kind regards,

Eric
 
Old 08-02-2010, 04:46 AM   #29
Xanios
Member
 
Registered: Jul 2010
Posts: 216

Original Poster
Rep: Reputation: 30
Hi,

this is the output:

Code:
xanios@ubuntu:~/demoCA$ ls -al
total 44
drwxr-xr-x  6 xanios xanios 4096 2010-08-02 00:43 .
drwxr-xr-x 41 xanios xanios 4096 2010-08-02 00:44 ..
-rw-r--r--  1 xanios xanios 3477 2010-08-02 00:43 cacert.pem
-rw-r--r--  1 xanios xanios  704 2010-08-02 00:43 careq.pem
drwxr-xr-x  2 xanios xanios 4096 2010-08-02 00:41 certs
drwxr-xr-x  2 xanios xanios 4096 2010-08-02 00:41 crl
-rw-r--r--  1 xanios xanios    3 2010-08-02 02:27 crlnumber
-rw-r--r--  1 xanios xanios    0 2010-08-02 02:27 index.txt
-rw-r--r--  1 xanios xanios   21 2010-08-02 00:43 index.txt.attr
-rw-r--r--  1 xanios xanios    0 2010-08-02 00:41 index.txt.old
drwxr-xr-x  2 xanios xanios 4096 2010-08-02 00:43 newcerts
drwxr-xr-x  2 xanios xanios 4096 2010-08-02 00:41 private
-rw-r--r--  1 xanios xanios   17 2010-08-02 00:43 serial
 
Old 08-02-2010, 04:48 AM   #30
linuxlover.chaitanya
Senior Member
 
Registered: Apr 2008
Location: Nagpur, India
Distribution: Cent OS 5/6, Ubuntu Server 10.04
Posts: 4,629

Rep: Reputation: Disabled
Quote:
Originally Posted by Xanios View Post
Hello,

Okay thanks, didn't notice it.

So i should go into demoCA first and delete the file which is:

Code:
xanios@ubuntu:~$ cd demoCA
xanios@ubuntu:~/demoCA$ sudo rm -r /etc/ssl/CA/cacert.pm
[sudo] password for xanios: 
rm: cannot remove `/etc/ssl/CA/cacert.pm': No such file or directory
cd [something] is to go into a directory right.
but why they still give me 'cannot remove...'
Sorry, quite new in linux
You are still deleting the file from /etc/ssl/CA directory. You need to delete file from demoCA directory.

cd to demoCA with
cd demoCA and now
rm -v cacert.pem
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
LXer: Migration Assistant In Ubuntu 9.04 LXer Syndicated Linux News 0 01-08-2009 01:40 PM
not throws evolution setup assistant dissident_goodchild Linux - Software 0 11-16-2007 09:00 PM
Evolution pppoe setup in Ubuntu won't work with dsl Thane Ubuntu 1 08-16-2006 01:11 PM
evolution mail setup hariiyer Linux - Networking 1 03-03-2006 07:41 AM
Evolution - problems after first setup jburford Linux - Software 2 09-08-2002 04:14 PM


All times are GMT -5. The time now is 02:38 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration