LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 08-05-2010, 01:02 AM   #151
linuxlover.chaitanya
Senior Member
 
Registered: Apr 2008
Location: Nagpur, India
Distribution: Cent OS 5/6, Ubuntu Server 10.04
Posts: 4,629

Rep: Reputation: Disabled

Find out the permissions on the postfix directory.
 
Old 08-05-2010, 01:04 AM   #152
Xanios
Member
 
Registered: Jul 2010
Posts: 216

Original Poster
Rep: Reputation: 30
hmm, check out my #150 post :X sorry
 
Old 08-05-2010, 01:07 AM   #153
linuxlover.chaitanya
Senior Member
 
Registered: Apr 2008
Location: Nagpur, India
Distribution: Cent OS 5/6, Ubuntu Server 10.04
Posts: 4,629

Rep: Reputation: Disabled
Quote:
Originally Posted by Xanios View Post
Hmm, when i was trying to delete the file:

Code:
xanios@ubuntu:~$ rm -r /etc/postfix/sasl_passwd
rm: remove write-protected regular file `/etc/postfix/sasl_passwd'? [i pressed 'enter' here]
in my previous sasl_passwd file, the password is my REAL password for gmail account. that should be okay right? or should i just put 'password' instead?
You can stop postfix service and then delete the file. And then create file using echo command and you will need your real gmail account password to authenticate.
 
Old 08-05-2010, 01:19 AM   #154
Xanios
Member
 
Registered: Jul 2010
Posts: 216

Original Poster
Rep: Reputation: 30
stopped postfix and tried to delete the file, it still remains.
 
Old 08-05-2010, 01:21 AM   #155
Xanios
Member
 
Registered: Jul 2010
Posts: 216

Original Poster
Rep: Reputation: 30
there's an additional sasl_password file i had, do i have to remove that? that file won't affect the way sasl_passwd works?
 
Old 08-05-2010, 01:48 AM   #156
Xanios
Member
 
Registered: Jul 2010
Posts: 216

Original Poster
Rep: Reputation: 30
i realised one thing:

Code:
xanios@ubuntu:~$ telnet smtp.gmail.com 587
Trying 74.125.127.109...
telnet: Unable to connect to remote host: Connection refused
Is it because of this i keep get connection refused?
how to resolve..i'm still looking
 
Old 08-05-2010, 01:54 AM   #157
linuxlover.chaitanya
Senior Member
 
Registered: Apr 2008
Location: Nagpur, India
Distribution: Cent OS 5/6, Ubuntu Server 10.04
Posts: 4,629

Rep: Reputation: Disabled
http://ubuntu-tutorials.com/2008/11/...-smtpgmailcom/
 
Old 08-05-2010, 01:56 AM   #158
linuxlover.chaitanya
Senior Member
 
Registered: Apr 2008
Location: Nagpur, India
Distribution: Cent OS 5/6, Ubuntu Server 10.04
Posts: 4,629

Rep: Reputation: Disabled
I can telnet to smtp.gmail.com on 587 port successfully. You could have been denied for your excessive requests.
 
Old 08-05-2010, 02:02 AM   #159
Xanios
Member
 
Registered: Jul 2010
Posts: 216

Original Poster
Rep: Reputation: 30
Excessive requests? x_x

in the link they used relayhost = [smtp.gmail.com]:587, should i just change back to that?

add on:

tried that. still connection refused.

maybe my port 587 is blocked.

Last edited by Xanios; 08-05-2010 at 02:13 AM.
 
Old 08-05-2010, 02:22 AM   #160
Xanios
Member
 
Registered: Jul 2010
Posts: 216

Original Poster
Rep: Reputation: 30
i added this to master.cf:

Code:
#628      inet  n       -       -       -       -       qmqpd
pickup    fifo  n       -       -       60      1       pickup
cleanup   unix  n       -       -       -       0       cleanup
qmgr      fifo  n       -       n       300     1       qmgr
#qmgr     fifo  n       -       -       300     1       oqmgr
tlsmgr    unix  -       -       -       1000?   1       tlsmgr
rewrite   unix  -       -       -       -       -       trivial-rewrite
bounce    unix  -       -       -       -       0       bounce
defer     unix  -       -       -       -       0       bounce
trace     unix  -       -       -       -       0       bounce
verify    unix  -       -       -       -       1       verify
flush     unix  n       -       -       1000?   0       flush
proxymap  unix  -       -       n       -       -       proxymap
proxywrite unix -       -       n       -       1       proxymap
smtp      unix  -       -       -       -       -       smtp
587       inet  n       -       n       -       -       smtpd
the one that is in bold. saw it on the web that by adding that line would open a port 587, still my telnet to 587 failed.

stumped.

Last edited by Xanios; 08-05-2010 at 02:24 AM.
 
Old 08-05-2010, 02:25 AM   #161
linuxlover.chaitanya
Senior Member
 
Registered: Apr 2008
Location: Nagpur, India
Distribution: Cent OS 5/6, Ubuntu Server 10.04
Posts: 4,629

Rep: Reputation: Disabled
You can change back. But it would not matter. Port number is at their end and not yours. And I can telnet from my end. Google has policy where in they treat some number of requests in a particular amount of time to be spam. So you have to limit that. Not just google but most of the SMTP relays have relay limits per user or per IP. After that the requests are either banned or termed spam. This is done to prevent spams and bulk mails.
 
Old 08-05-2010, 02:26 AM   #162
linuxlover.chaitanya
Senior Member
 
Registered: Apr 2008
Location: Nagpur, India
Distribution: Cent OS 5/6, Ubuntu Server 10.04
Posts: 4,629

Rep: Reputation: Disabled
No you are not getting the point. It not the port at your end. It is the port at googles end.
 
Old 08-05-2010, 02:26 AM   #163
Xanios
Member
 
Registered: Jul 2010
Posts: 216

Original Poster
Rep: Reputation: 30
But how to limit that?x_x
 
Old 08-05-2010, 02:30 AM   #164
linuxlover.chaitanya
Senior Member
 
Registered: Apr 2008
Location: Nagpur, India
Distribution: Cent OS 5/6, Ubuntu Server 10.04
Posts: 4,629

Rep: Reputation: Disabled
You do not limit that. Its them who limit the requests for spam and bulk mailing. You can not control the server at their end and neither can you do anything about the policies. Those policies are there to prevent their servers from being misused for spamming.
 
Old 08-05-2010, 02:31 AM   #165
Xanios
Member
 
Registered: Jul 2010
Posts: 216

Original Poster
Rep: Reputation: 30
Oh okay.
So, is there no other way to solve the error?
Connection refused.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
LXer: Migration Assistant In Ubuntu 9.04 LXer Syndicated Linux News 0 01-08-2009 01:40 PM
not throws evolution setup assistant dissident_goodchild Linux - Software 0 11-16-2007 09:00 PM
Evolution pppoe setup in Ubuntu won't work with dsl Thane Ubuntu 1 08-16-2006 01:11 PM
evolution mail setup hariiyer Linux - Networking 1 03-03-2006 07:41 AM
Evolution - problems after first setup jburford Linux - Software 2 09-08-2002 04:14 PM


All times are GMT -5. The time now is 08:24 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration