LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Newbie (http://www.linuxquestions.org/questions/linux-newbie-8/)
-   -   Evolution sends mails but can't receive - LDA issue..?? (http://www.linuxquestions.org/questions/linux-newbie-8/evolution-sends-mails-but-cant-receive-lda-issue-4175430417/)

pramodbisht 10-04-2012 12:47 AM

Evolution sends mails but can't receive - LDA issue..??
 
Hi guys I have sendmail server running well also install dovecot (IMAP) and procmail along.
local users can send/receive mails using "mutt & mail" but with evolution can only send mails, can't receive???
here is output of related configs:-
sendmail.mc
---------------------------------------------------------
divert(-1)dnl
include(`/usr/share/sendmail-cf/m4/cf.m4')dnl
VERSIONID(`setup for linux')dnl
OSTYPE(`linux')dnl
define(`confDEF_USER_ID', ``8:12'')dnl
define(`confTO_CONNECT', `1m')dnl
define(`confTRY_NULL_MX_LIST', `True')dnl
define(`confDONT_PROBE_INTERFACES', `True')dnl
define(`PROCMAIL_MAILER_PATH', `/usr/bin/procmail')dnl
define(`ALIAS_FILE', `/etc/aliases')dnl
define(`STATUS_FILE', `/var/log/mail/statistics')dnl
define(`UUCP_MAILER_MAX', `2000000')dnl
define(`confUSERDB_SPEC', `/etc/mail/userdb.db')dnl
define(`confPRIVACY_FLAGS', `authwarnings,novrfy,noexpn,restrictqrun')dnl
define(`confAUTH_OPTIONS', `A')dnl
TRUST_AUTH_MECH(`EXTERNAL DIGEST-MD5 CRAM-MD5 LOGIN PLAIN')dnl
define(`confAUTH_MECHANISMS', `EXTERNAL GSSAPI DIGEST-MD5 CRAM-MD5 LOGIN PLAIN')dnl
define(`confTO_IDENT', `0')dnl
FEATURE(`no_default_msa', `dnl')dnl
FEATURE(`smrsh', `/usr/sbin/smrsh')dnl
FEATURE(`mailertable', `hash -o /etc/mail/mailertable.db')dnl
FEATURE(`virtusertable', `hash -o /etc/mail/virtusertable.db')dnl
FEATURE(local_procmail, `', `procmail -t -Y -a $h -d $u')dnl
FEATURE(`access_db', `hash -T<TMPF> -o /etc/mail/access.db')dnl
FEATURE(`blacklist_recipients')dnl
EXPOSED_USER(`root')dnl

DAEMON_OPTIONS(`Port=smtp,Addr=0.0.0.0, Name=MTA')dnl
MASQUERADE_AS(`mydomain.com')dnl
FEATURE(`masquerade_envelope')dnl
FEATURE(`masquerade_entire_domain')dnl
FEATURE(`always_add_domain')dnl
FEATURE(`allmasquerade')dnl
MASQUERADE_DOMAIN(`mydomain.com.')dnl
MAILER(smtp)dnl
MAILER(procmail)dnl
------------------------------------------------------------
[root@www conf.d]# dovecot -n
# 2.0.beta6 (3156315704ef): /etc/dovecot/dovecot.conf
# OS: Linux 2.6.32-71.el6.i686 i686 CentOS Linux release 6.0 (Final)
base_dir = /var/run/dovecot/
info_log_path = /var/log/dovecot
mail_location = maildir:~/Maildir
mail_privileged_group = mail
passdb {
args = dovecot
driver = pam
}
protocols = imap
service imap-login {
inet_listener imap {
port = 143
}
}
ssl_cert = </etc/pki/dovecot/certs/dovecot.pem
ssl_key = </etc/pki/dovecot/private/dovecot.pem
userdb {
driver = passwd
}
------------------------------------------------------------
# file: /etc/procmailrc
# system-wide settings for procmail
SHELL="/bin/bash"
SENDMAIL="/usr/sbin/sendmail -oi -t"
LOGFILE="/var/log/procmail.log"
DELIVER="/usr/libiexec/dovecot/deliver"
# Use the following if you get "destination user parameter (-d user) not given":
DROPPRIVS="YES"
# fallback:
DEFAULT="$HOME/Maildir/"
MAILDIR="$HOME/Maildir/"
:0 w
* ^X-Spam-Status: Yes
| $DELIVER -m spam
:0 w
| $DELIVER
----------------------------------------------------------------

FYI even i got mails under "/home/pramod/Maildir/new" when I send mails to user pramod.but mail not show-up when i check mail using evolution!?? I doubt in procmail.
also, Domainname = mydomain.com
Hostname = www.mydomain.com
Nameserver = www.mydomain.com (NS is working perfectlly!!)
Need your help!!


All times are GMT -5. The time now is 03:53 PM.