LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 05-27-2010, 12:26 PM   #1
er.rigney
LQ Newbie
 
Registered: Apr 2010
Location: CornVegas, IL
Distribution: Linux Ubuntu 10.04, Linux Mint
Posts: 15

Rep: Reputation: 1
Evolution 2.28.3 message filters not filtering to assigned folders?


I have created custom rules following: edit > message filters > incoming filter > (custom filter), none work. Also, by right clicking a message and, create rule from message > filter based by subject, sender, and recipients. Accepting all default (auto populated) conditons. None of the filters work at all? Seems this is a popular problem that has not found a solution except to use Thunderbird. Any real solutions, not including Thunderbird?

TIA,

Annoyed

BTW,

When I select a message that is supposed to be filtered to a specific folder and go to Message > Apply Filters. The message goes to the assigned folder, but I want it to skip the inbox all together.

Last edited by er.rigney; 05-27-2010 at 12:40 PM.
 
Old 05-27-2010, 12:40 PM   #2
spampig
Member
 
Registered: Feb 2010
Location: /Earth/UK/England/Hampshire
Distribution: Debian, Ubuntu, CentOS, Slackware
Posts: 262
Blog Entries: 2

Rep: Reputation: 56
I'm still running 2.2.8.1 and have no issues at all with the filters (that I use). All I ever do is R/C message > Create Rule from message > filter based on {blah}.

Make sure the match is actually set to what you want and physically give it an action, such as move to folder. If you don't do that it won't do anything. My guess is either you are not keying on the right headers, or you have not given it a distinct action to do.
 
Old 05-27-2010, 12:56 PM   #3
er.rigney
LQ Newbie
 
Registered: Apr 2010
Location: CornVegas, IL
Distribution: Linux Ubuntu 10.04, Linux Mint
Posts: 15

Original Poster
Rep: Reputation: 1
Spampig,

The filters work when I highlight the message and then select: Message > Apply Filters. So I know the filters work. The problem is to get them to skip the Inbox.

ER.

"Good intentions fall short sometimes"
 
Old 05-27-2010, 01:16 PM   #4
spampig
Member
 
Registered: Feb 2010
Location: /Earth/UK/England/Hampshire
Distribution: Debian, Ubuntu, CentOS, Slackware
Posts: 262
Blog Entries: 2

Rep: Reputation: 56
Weird. So they run, but won't run automatically?

Check this first:
http://www.go-evolution.org/FAQ#Why_...rs_not_work.3F
In particular 'stop processing' instruction creeping into a rule - a favorite 'wheel mouse' gotcha.

Other than that, perhaps the return of an old bug(?) assuming:
1. Your filters are set up on 'incoming' and not 'outgoing'?
2. Not sure,but is 'EDIT > PREFERENCES > MAIL PREFERENCES > JUNK > CHECK INCOMING MESSAGES FOR JUNK' checked? If so does unchecking it 'fix' this?
 
Old 05-27-2010, 02:01 PM   #5
er.rigney
LQ Newbie
 
Registered: Apr 2010
Location: CornVegas, IL
Distribution: Linux Ubuntu 10.04, Linux Mint
Posts: 15

Original Poster
Rep: Reputation: 1
Thumbs up Solved

...Yes they only run manually.

...They are set for incoming.

...Played with Junk filter, made no difference.

!!!Many Thanks!!!

Very simple solution for a very simple problem. The link you provided was exactly what fixed it... And I'll quote:

"If you want your filters to apply automatically and you are using an IMAP account, make sure you have enabled "Apply filters to new messages in INBOX on this server" under "Edit | Preferences | Email Accounts | Edit | Receiving Options | Options".

Made changes to this setting and restarted Evo. Presto, Change O, the filter works now.

ER.

"If at first you don't succeed. Failure may be your style!" - Quentin Crisp
 
Old 05-27-2010, 02:27 PM   #6
spampig
Member
 
Registered: Feb 2010
Location: /Earth/UK/England/Hampshire
Distribution: Debian, Ubuntu, CentOS, Slackware
Posts: 262
Blog Entries: 2

Rep: Reputation: 56
Fantastic ;-)
 
Old 11-08-2011, 03:11 PM   #7
AustinMarton
Member
 
Registered: May 2007
Location: New Zealand
Distribution: Ubuntu
Posts: 88

Rep: Reputation: 16
Excellent, appears to have solved the same problem for me.

The FAQ link has changed:
http://live.gnome.org/Evolution/FAQ#...rs_not_work.3F
 
  


Reply

Tags
evolution


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Evolution not automatically applying filters... xmnemonic Linux - Software 27 07-28-2011 08:36 AM
Evolution mail filters: some work, others don't rnturn Linux - Software 2 06-17-2010 09:38 AM
string case in Evolution Mail filters Nature Nut Linux - Newbie 0 03-25-2009 08:53 PM
Filters in Evolution Chriscrof Linux - Newbie 9 08-19-2008 04:29 PM
Ximian Evolution Filters (problem) CRego3D Linux - Software 4 02-07-2003 10:00 AM


All times are GMT -5. The time now is 02:07 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration