LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Newbie (http://www.linuxquestions.org/questions/linux-newbie-8/)
-   -   ethtool can't seem to enable wake-on-LAN (wol) on my NIC (http://www.linuxquestions.org/questions/linux-newbie-8/ethtool-cant-seem-to-enable-wake-on-lan-wol-on-my-nic-585981/)

bellsal 09-20-2007 12:41 AM

ethtool can't seem to enable wake-on-LAN (wol) on my NIC
 
Hi All,

I am trying to turn on my PC over the LAN, and I am having problems. Here is what I have done.

I have changed the BIOS parameters, turned off the PC without fully rebooting the system, and tested the Wake-on-LAN (WOL). The PC turned on and rebooted without any problems. I did this step this way to verify that I set up the BIOS correctly, and I did.

Once the PC fully booted into linux (Fedora 7), I shutdown the system with "shutdown -h now", and I was no longer able to wake the PC over LAN. This meant that linux had disabled WOL on my NIC. So, I have used ethtool to enable it, and here is the response I got.

[root@linux_server ~]# /sbin/ethtool -s eth0 wol g
Cannot get current wake-on-lan settings: Operation not supported
not setting wol


Uhmmm! Now, I am a bit confused why I am not able to enable WOL on my NIC with ethtool.

Then, I tried the following, and here are the responses:

[root@linux_server ~]# /sbin/ethtool -i eth0
driver: bridge
version: 2.2
firmware-version: N/A
bus-info: N/A


I have also tried the following:

[root@linux_server ~]# lspci
00:00.0 Host bridge: Intel Corporation 82845G/GL[Brookdale-G]/GE/PE DRAM Controller/Host-Hub Interface (rev 01)
00:02.0 VGA compatible controller: Intel Corporation 82845G/GL[Brookdale-G]/GE Chipset Integrated Graphics Device (rev 01)
00:1d.0 USB Controller: Intel Corporation 82801DB/DBL/DBM (ICH4/ICH4-L/ICH4-M) USB UHCI Controller #1 (rev 01)
00:1d.1 USB Controller: Intel Corporation 82801DB/DBL/DBM (ICH4/ICH4-L/ICH4-M) USB UHCI Controller #2 (rev 01)
00:1d.2 USB Controller: Intel Corporation 82801DB/DBL/DBM (ICH4/ICH4-L/ICH4-M) USB UHCI Controller #3 (rev 01)
00:1d.7 USB Controller: Intel Corporation 82801DB/DBM (ICH4/ICH4-M) USB2 EHCI Controller (rev 01)
00:1e.0 PCI bridge: Intel Corporation 82801 PCI Bridge (rev 81)
00:1f.0 ISA bridge: Intel Corporation 82801DB/DBL (ICH4/ICH4-L) LPC Interface Bridge (rev 01)
00:1f.1 IDE interface: Intel Corporation 82801DB (ICH4) IDE Controller (rev 01)
00:1f.5 Multimedia audio controller: Intel Corporation 82801DB/DBL/DBM (ICH4/ICH4-L/ICH4-M) AC'97 Audio Controller (rev 01)
05:08.0 Ethernet controller: Intel Corporation 82801DB PRO/100 VM (LOM) Ethernet Controller (rev 81)


Please share any suggestions on how I can make WOL work with Fedora 7 and my NIC.

Thank you so much in advanced

blackhole54 09-20-2007 05:50 AM

Quote:

Originally Posted by bellsal (Post 2897512)
[root@linux_server ~]# /sbin/ethtool -i eth0
driver: bridge
version: 2.2
firmware-version: N/A
bus-info: N/A

I may be out in left field here, but I am wondering about the driver listed. Is that the driver you would expect, or is it saying this connection is part of a bridge, or what?

You also might try ethtool w/o any parameters other than the device name and see if it gives you any clues or if you see anything suspicious.

Just to make sure we're not missing something obvious, does ifconfig show eth0 to be up?

bellsal 09-20-2007 11:17 PM

Hi Blackhole54,

Thank you for helping me with this problem; I really appreciate it. Here are the answers to your questions. I hope they help.

The connection is part of a bridge. My NIC is integrated onto the motherboard. This NIC is an Intel PRO/100 as you can see from the output of the lspci (see the original post).

When I tried ethtool w/o any parameters other than the device name, I didn't see anything suspicious; this is what I got:

[root@linux_server ~]# /sbin/ethtool eth0
Settings for eth0:
Link detected: yes


When I tried ifconfig, eth0 shows up, and nothing seem suspicious here. Here is its output:

[root@linux_server ~]# ifconfig

eth0 Link encap:Ethernet HWaddr 00:0B:CD:B3:0E:09
inet addr:192.168.0.3 Bcast:192.168.0.255 Mask:255.255.255.0
inet6 addr: fe80::20b:cdff:feb3:e09/64 Scope:Link
UP BROADCAST RUNNING MULTICAST MTU:1492 Metric:1
RX packets:18399 errors:0 dropped:0 overruns:0 frame:0
TX packets:24241 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:0
RX bytes:2683300 (2.5 MiB) TX bytes:22007624 (20.9 MiB)

lo Link encap:Local Loopback
inet addr:127.0.0.1 Mask:255.0.0.0
inet6 addr: ::1/128 Scope:Host
UP LOOPBACK RUNNING MTU:16436 Metric:1
RX packets:15242 errors:0 dropped:0 overruns:0 frame:0
TX packets:15242 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:0
RX bytes:139302828 (132.8 MiB) TX bytes:139302828 (132.8 MiB)

peth0 Link encap:Ethernet HWaddr 00:0B:CD:B3:0E:09
inet6 addr: fe80::20b:cdff:feb3:e09/64 Scope:Link
UP BROADCAST RUNNING MULTICAST MTU:1492 Metric:1
RX packets:18566 errors:0 dropped:0 overruns:0 frame:0
TX packets:24353 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:2954488 (2.8 MiB) TX bytes:22027088 (21.0 MiB)

virbr0 Link encap:Ethernet HWaddr 00:00:00:00:00:00
inet addr:192.168.122.1 Bcast:192.168.122.255 Mask:255.255.255.0
inet6 addr: fe80::200:ff:fe00:0/64 Scope:Link
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:0 errors:0 dropped:0 overruns:0 frame:0
TX packets:87 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:0
RX bytes:0 (0.0 b) TX bytes:16003 (15.6 KiB)

blackhole54 09-21-2007 12:05 AM

I am wondering if ethtool simply can't handle the fact that eth0 is part of a bridge.

Just to let you know, I have no experience with bridges. I have read an article or two about them and that is it. So forgive me if in my ignorance I say something stupid. :-/ Assuming you want to wake the computer up from the eth0 side of the bridge, I suggest trying to get it working w/o the bridge in place. If that works, then maybe the solution is to have your init script(s) first enable WOL with ethtool, and then set up the bridge.

Good luck. And please post back if you get it to work.

archtoad6 10-28-2007 05:28 AM

Interesting problem -- what happened?


All times are GMT -5. The time now is 11:29 AM.