LinuxQuestions.org
Latest LQ Deal: Complete CCNA, CCNP & Red Hat Certification Training Bundle
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 07-01-2004, 11:28 PM   #1
simonalex
LQ Newbie
 
Registered: May 2004
Location: Australia
Posts: 14

Rep: Reputation: 0
Ethernet network problems


Hey

I've been sharing my laptop and PC via crossover cable with Redhat 9 on both machines - but can no longer get it working since upgrading my PC to the 2.6.7 kernel (I plan to upgrade the laptop as well, once I've gotten the hardware sorted out).

I can ping each machine locally, but can no longer ping the other. The main difference I've noticed is, on the PC, ifconfig eth0 gives:

Code:
eth0      Link encap:UNSPEC  HWaddr 00-00-20-ED-00-32-3D-05-00-00-00-00-00-00-00-00
          inet addr:192.168.1.1  Bcast:192.168.1.255  Mask:255.255.255.0
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:108 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:0 (0.0 b)  TX bytes:3888 (3.7 Kb)
It's the first line that I'm not understanding (UNSPEC, long hw addr). Also, when I open System Settings -> network, a dialogue pops up, telling me:

"eth0 has an alias to module e100 in modules.conf, instead of currently loaded module ip1394!"

Additionally, an extra device, eth1, appears, "Intel EtherExpress/100", but has no settings, and disappears after pressing edit. lspci shows:

Code:
02:08.0 Ethernet controller: Intel Corp. 82801BD PRO/100 VE (CNR) Ethernet Controller (rev 81)
I'm guessing this is something to do with the ip1394 module (?), but on googling for a bit, I'm still not understanding it (I'm a newbie, hence the forum . I'm not very bright, so if anyone could offer any advice, it would be hugely appreciated.

Simon.
 
Old 07-02-2004, 12:19 AM   #2
zatriz
Member
 
Registered: Aug 2003
Location: Seattle, Wa
Distribution: Fedora,Trustix,Debian
Posts: 290

Rep: Reputation: 30
Im not exactly sure but it seems to me that the eth0 is mapped to the wrong hardware
Type dmesg and take a look at the results and make sure that the network card which i assume to be an intel card is loaded properly. Also i believe the ip1394 is refering to a firewire module. Try unloading it and check your /etc/modules.conf file and make sure that it is correct.

Last edited by zatriz; 07-02-2004 at 12:20 AM.
 
Old 07-02-2004, 01:21 AM   #3
simonalex
LQ Newbie
 
Registered: May 2004
Location: Australia
Posts: 14

Original Poster
Rep: Reputation: 0
Thanks for replying

I think you're right... dmesg shows

"ip1394: eth0: IEEE-1394 IPv4 over 1394 Ethernet (fw-host0)"

as the only mention of eth0 or the network card. modprobe.conf (which 2.6 kernel uses instead of modules.conf?) seems to be correct (so does modules.conf, for that matter). lsmod doesn't show any "ip1394", but does show "eth1394", which is used by "ieee1394".

Hmmm, I'm not sure why that is happening, time to hit google again.

Simon.
 
Old 07-21-2004, 03:18 AM   #4
chrissearle
LQ Newbie
 
Registered: Jul 2004
Distribution: debian
Posts: 2

Rep: Reputation: 0
Got the same problem.

I have both a firewire card and a realtek 8139 inbuilt net card.

The eth1394 module is loaded - as is both the 8139cp and 8139too module (I only need this latter but the former is newer and will load the latter if the card is too old)

You can get the network up (at least under debian with this net card):

/etc/init.d/networking stop
rmmod eth1394
rmmod 8139cp
rmmod 8139too
modprobe 8139too
/etc/init.d/networking start

Not sure if the too module must be reloaded but it seems to work this way.

Now - if anyone can point to how you either

1) Prevent a module from loading

or

2) Configure module loading so that eth0 gets the correct driver (maybe an alias ? not too sure on module config)
 
Old 07-21-2004, 04:26 AM   #5
simonalex
LQ Newbie
 
Registered: May 2004
Location: Australia
Posts: 14

Original Poster
Rep: Reputation: 0
Hey chrissearle

I got the card working in much the same way - bring eth* down, unload unwanted modules, load the correct ones, etc. I stopped it from loading the wrong modules in the first place by disabling firewire, but obviously not an option for you.

Just wanted to second the request for anyone who might know how to properly prevent the incorrect modules from loading in the first place - I'm (pretty) sure I have modprobe/modules.conf entries correct, which is the only thing I've heard might be causing it.

simon.
 
Old 08-16-2004, 11:31 PM   #6
GuidoS
LQ Newbie
 
Registered: Aug 2004
Location: Mesa, Arizona
Distribution: Debian Sarge - custom 2.6.7
Posts: 14

Rep: Reputation: 0
Hi there,

ran across the same behaviour when I added modules for using firewire with a camcorder. The ieee1394 took over eth0 while my "old" network card was eth1.

In the dmesg log it showed that the firewire modules loaded before the ethernet modules. I had used modconf to activate the ieee1394 stuff and sure enough, it added the modules to the /etc/modules file, which for whatever reason did not have my network driver in it.

After adding the network driver module (sis900, or in the case above it would be 8139cp) before the ieee1394 modules and rebooting I had my network back.

HTH,

Guido.
 
Old 08-25-2004, 02:57 AM   #7
chrissearle
LQ Newbie
 
Registered: Jul 2004
Distribution: debian
Posts: 2

Rep: Reputation: 0
Hmm - I gave this a try:

# /etc/modules: kernel modules to load at boot time.
#
# This file should contain the names of kernel modules that are
# to be loaded at boot time, one per line. Comments begin with
# a "#", and everything on the line after them are ignored.

8139cp
uhci-hcd
sd_mod
sg
ide-scsi
ohci1394
raw1394
ppa
visor
psmouse


I see the 8139cp module load - but - eth0 still goes to the firewire port. Only difference here is that eth1 didn't get setup at all. The script I used above to bounce the net still works fine.
 
Old 09-22-2004, 02:38 PM   #8
xround
Member
 
Registered: Oct 2003
Location: France
Distribution: RH9
Posts: 84

Rep: Reputation: 15
You can add your ethernet module (or modules you want) using
Code:
#! /bin/sh
#
# /etc/rc.d/rc.modules
#
#   - Load modules.  Called from /etc/rc.sysinit.
#

/sbin/modprobe modxx
in file rc.modules you create /etc/rc.d

Then do
# cd /etc
# ln -s rc.d/rc.modules rc.modules

And reboot. It work for me. The /etc/rc.modules is used in /etc/rc.sysinit file, to load your own modules.
You can still see eth1394, that may be loaded after rc.sysinit stuff

I found that reading controlling which modules load at boot


x.

PS: this was ok on a red hat linux 9. Don't know about other distros.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Ethernet network not responsive markbaber Linux - Networking 2 11-28-2005 07:03 AM
Ethernet Adsl Modem Driver Problems And Install Problems... akhilnair Linux - Hardware 12 11-28-2004 09:19 AM
Network Bridge- IR to Ethernet systemparadox Linux - Networking 2 08-18-2004 09:51 AM
Network Problems with Slackware 9.1 and VIA Compatible Fast Ethernet Adapter Hell Cheese Slackware 13 06-08-2004 12:11 AM
Network Installation through ethernet tricky_linux Linux - Software 0 04-09-2004 04:21 PM


All times are GMT -5. The time now is 09:58 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration