LinuxQuestions.org
Review your favorite Linux distribution.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 05-31-2005, 12:23 AM   #1
jared78
Member
 
Registered: Mar 2005
Distribution: Red Hat 9.0
Posts: 94

Rep: Reputation: 15
Ethereal,Yum Blues :(-->identical dependency loop exceeded


hye,
I am trying to install ethereal and confirmed from the manual that these five rpms have to be installed.
rpm -ivh glib-1.2.6-3.i386.rpm
rpm -ivh glib-devel-1.2.6-3.i386.rpm
rpm -ivh gtk+-1.2.6-7.i386.rpm
rpm -ivh gtk+-devel-1.2.6-7.i386.rpm
rpm -ivh libpcap-0.4-19.i386.rpm

I used rpm -ql <rpmname> to check to see if all the five rpms are installed.

Here is what I get.

[root@localhost root]# rpm -ql gtk+-devel
package gtk+-devel is not installed
[root@localhost root]# yum install gtk+-devel
Gathering header information file(s) from server(s)
Server: Fedora Linux / stable for Red Hat Linux 9 (i386)
Server: Macromedia Flash Player for Red Hat Linux 9
Server: Red Hat Linux 9 (i386)
Server: Red Hat Linux 9 (i386) updates
Finding updated packages
Downloading needed headers
Resolving dependencies
.......identical dependency loop exceeded
package XFree86-xfs needs XFree86-libs = 4.3.0-2 (not provided)
package XFree86 needs XFree86-libs = 4.3.0-2 (not provided)
package XFree86-twm needs XFree86-libs = 4.3.0-2 (not provided)

Here I tried installing the XFree86-libs.

[root@localhost root]# yum list XFree86-libs
Looking in Available Packages:
Name Arch Version Repo
--------------------------------------------------------------------------------
XFree86-libs i386 4.3.0-2.90.60.legacy redhat-updates

Looking in Installed Packages:
Name Arch Version Repo
--------------------------------------------------------------------------------
XFree86-libs i386 4.3.0-2 db

[root@localhost root]# yum upgrade XFree86-libs
Resolving dependencies
.....identical dependency loop exceeded.

It is giving identical loop exceeded for both gtk+-devel and XFree86-libs.
Also XFree86-libs is in Available Packages and Installed packages...how come?

What do I do next?

thanx in advance,
Jared
 
Old 06-20-2006, 12:16 PM   #2
jared78
Member
 
Registered: Mar 2005
Distribution: Red Hat 9.0
Posts: 94

Original Poster
Rep: Reputation: 15
never mind...
Ethereal is up and runnning
I still don't know what caused the problem,but it got installed.

Posting this so that folks don't need to get back to this thread which shows 0 replies.


thanks
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Yum dependency: beats me! linmix Linux - Software 1 02-21-2006 06:16 PM
Yum update dependency problems DJOtaku Fedora 6 12-11-2005 03:56 PM
yum missing dependencY puppet Linux - Software 6 10-26-2005 11:20 AM
Yum dependency problem lucifer623 Fedora 4 10-09-2005 02:51 PM
glibc-common dependency blues... sylk Linux - Software 4 09-19-2003 08:08 PM


All times are GMT -5. The time now is 10:53 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration