LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 07-02-2008, 02:36 AM   #1
av.dubey
Member
 
Registered: Nov 2007
Posts: 148

Rep: Reputation: 15
eth1 no such device in fedora 8


hi m using fedora 8 ..n m havin two NICs right now...
one is eth0 and the other is eth1..
actually i have installed snort on my lap and i have to use both the ethernet cards by giving them two static ips..

the problem is that when i do ifconfig -a ...its not showing eth1 its showing only eth0....
..can neone tell me how to configure eth1 in linux...
 
Old 07-02-2008, 06:20 AM   #2
camorri
LQ Guru
 
Registered: Nov 2002
Location: Somewhere inside 9.9 million sq. km. Canada
Distribution: Slackware 14.1, 14.2
Posts: 5,157

Rep: Reputation: 510Reputation: 510Reputation: 510Reputation: 510Reputation: 510Reputation: 510
eth1 is just a name created by udev rules when the system is booted. The second nic may be called eth2 or eth3 etc. Try different names to see if you can find out what the second nic is called.

Have a look here, this explains some of how udev works. It is not trivial. -->http://blogs.koolwal.net/2008/04/22/...ux-udev-issue/

Once you have the assigned name, configure the second nic as you did the first.

Hope this helps.
 
Old 07-02-2008, 12:12 PM   #3
av.dubey
Member
 
Registered: Nov 2007
Posts: 148

Original Poster
Rep: Reputation: 15
actually i have installed easyids on my machine..it has two nic...using netconfig i configured eth0 and gave it static ip..and for eth1 i manually made entry in /etc/sysconfig/network-scripts/ifcfg-eth1 file..
wen iam typing service network restart...its bringing the eth0 as well as eth1 successfully but wen iam typing ifconfig -a its not showing me eth1......
m not getting now wat shod i do for this..
 
Old 07-02-2008, 12:23 PM   #4
camorri
LQ Guru
 
Registered: Nov 2002
Location: Somewhere inside 9.9 million sq. km. Canada
Distribution: Slackware 14.1, 14.2
Posts: 5,157

Rep: Reputation: 510Reputation: 510Reputation: 510Reputation: 510Reputation: 510Reputation: 510
Are you sure it is still called eth1? If you read the threads I pointed you to, part of the problem is re-naming the hardware interface to something other than ethx. So the config file may work when booted, and then the name can change, do to rules for udev.

If this is not the case, and it is still named eth1, then I'm at a loss to explain why it doesn't show up with a /sbin/ifconfig command.
 
Old 07-02-2008, 01:34 PM   #5
Tinkster
Moderator
 
Registered: Apr 2002
Location: in a fallen world
Distribution: slackware by choice, others too :} ... android.
Posts: 23,067
Blog Entries: 11

Rep: Reputation: 910Reputation: 910Reputation: 910Reputation: 910Reputation: 910Reputation: 910Reputation: 910Reputation: 910
Quote:
Originally Posted by av.dubey View Post
actually i have installed easyids on my machine..it has two nic...using netconfig i configured eth0 and gave it static ip..and for eth1 i manually made entry in /etc/sysconfig/network-scripts/ifcfg-eth1 file..
wen iam typing service network restart...its bringing the eth0 as well as eth1 successfully but wen iam typing ifconfig -a its not showing me eth1......
m not getting now wat shod i do for this..
What does
lspci
say about the devices?
 
Old 07-03-2008, 02:10 AM   #6
av.dubey
Member
 
Registered: Nov 2007
Posts: 148

Original Poster
Rep: Reputation: 15
the output of lspci is as follows

[root@easyids1 ~]# lspci
00:00.0 Host bridge: Intel Corporation 82815 815 Chipset Host Bridge and Memory Controller Hub (rev 02)
00:02.0 VGA compatible controller: Intel Corporation 82815 Chipset Graphics Controller (CGC) (rev 02)
00:1e.0 PCI bridge: Intel Corporation 82801 PCI Bridge (rev 01)
00:1f.0 ISA bridge: Intel Corporation 82801BA ISA Bridge (LPC) (rev 01)
00:1f.1 IDE interface: Intel Corporation 82801BA IDE U100 Controller (rev 01)
00:1f.4 USB Controller: Intel Corporation 82801BA/BAM USB Controller #1 (rev 01)
00:1f.5 Multimedia audio controller: Intel Corporation 82801BA/BAM AC'97 Audio Controller (rev 01)
02:04.0 Ethernet controller: Unknown device 0001:8139 (rev 10)
02:08.0 Ethernet controller: Intel Corporation 82801BA/BAM/CA/CAM Ethernet Controller (rev 01)
 
Old 07-03-2008, 02:26 AM   #7
Mr. C.
Senior Member
 
Registered: Jun 2008
Posts: 2,529

Rep: Reputation: 61
Your device is not recognized by any driver currently installed in the system. The device is:

02:04.0 Ethernet controller: Unknown device 0001:8139 (rev 10)

The PCI device ID is 0x8139, which is a Realtek card. But that vendor ID of 0001 doesn't make sense to me. Show output if you could from

lspci -n
 
Old 07-03-2008, 04:19 AM   #8
av.dubey
Member
 
Registered: Nov 2007
Posts: 148

Original Poster
Rep: Reputation: 15
the output of lspci -n is as follows...

[root@easyids1 ~]# lspci -n
00:00.0 Class 0600: 8086:1130 (rev 02)
00:02.0 Class 0300: 8086:1132 (rev 02)
00:1e.0 Class 0604: 8086:244e (rev 01)
00:1f.0 Class 0601: 8086:2440 (rev 01)
00:1f.1 Class 0101: 8086:244b (rev 01)
00:1f.4 Class 0c03: 8086:2444 (rev 01)
00:1f.5 Class 0401: 8086:2445 (rev 01)
02:04.0 Class 0200: 0001:8139 (rev 10)
02:08.0 Class 0200: 8086:2449 (rev 01)


m online waitin for ur reply..
 
Old 07-03-2008, 05:49 AM   #9
av.dubey
Member
 
Registered: Nov 2007
Posts: 148

Original Poster
Rep: Reputation: 15
i think there is some problem with the driver thing...how will i come to know wats the driver required for it..whether its installed or not...
my /etc/modprobe.conf file is like this...


alias eth0 e100
alias scsi_hostadapter ata_piix
alias snd-card-0 snd-intel8x0
options snd-card-0 index=0
install snd-intel8x0 /sbin/modprobe --ignore-install snd-intel8x0 && /usr/sbin/alsactl restore >/dev/null 2>&1 || :
remove snd-intel8x0 { /usr/sbin/alsactl store >/dev/null 2>&1 || : ; }; /sbin/modprobe -r --ignore-remove snd-intel8x0
alias usb-controller uhci-hcd
 
Old 07-03-2008, 10:44 AM   #10
av.dubey
Member
 
Registered: Nov 2007
Posts: 148

Original Poster
Rep: Reputation: 15
ya finally i got it working...i typed lsmod and saw that e100 and 8139too drivers were there in system for the ethernet cards...so i added one line in /etc/modprobe.conf file and ifconfig started showing eth1..
thanks for ur cooperation...

well the line is
alias eth1 81390too
 
Old 07-03-2008, 01:03 PM   #11
Tinkster
Moderator
 
Registered: Apr 2002
Location: in a fallen world
Distribution: slackware by choice, others too :} ... android.
Posts: 23,067
Blog Entries: 11

Rep: Reputation: 910Reputation: 910Reputation: 910Reputation: 910Reputation: 910Reputation: 910Reputation: 910Reputation: 910
Well done, thanks for coming back and sharing the solution!


Cheers,
Tink
 
Old 07-04-2008, 09:11 AM   #12
av.dubey
Member
 
Registered: Nov 2007
Posts: 148

Original Poster
Rep: Reputation: 15
well i have got to learn a lot from this forum...whenever i had problem i have successfully got my solution here ..
so thanx a lot to u all for the support..
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
HOW TO CONNECT WI-FI IN LINUX GETTING 3c501 device eth1 does not seem to be present, kalyanammahesh Linux - Newbie 1 02-08-2008 05:22 AM
8139too device eth1 does not seem to be present Bob62683 Linux - Networking 1 08-31-2004 08:20 PM
Wlan_ng does not work : pcnet_cs device eth1 does not seem to be present, rjcamer Linux - Wireless Networking 0 03-26-2004 06:28 PM
eth1: Device not found jrihak Linux - Wireless Networking 2 01-10-2004 12:35 PM
eth1 no such device RinGz Linux - Networking 2 12-04-2003 04:47 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie

All times are GMT -5. The time now is 06:34 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration