LinuxQuestions.org
Support LQ: Use code LQ3 and save $3 on Domain Registration
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 05-12-2012, 09:56 PM   #1
HeadSpeakerJunky
LQ Newbie
 
Registered: May 2012
Posts: 2

Rep: Reputation: Disabled
ETH1 goes down when ETH0 is disabled or unplugged


Pretty new to linux and recently built a file server utilizing an old PC. I installed a new 1 GB NIC following the vendors instruction without issue and I am able to get an IP and ping the interface when ETH0 is also plugged in. But when I try to pull the cable for ETH0 (old onboard card) I lose ETH1 (new 1 GB card) as well. Any ideas to what is going on?

NIC hardware:
ETH1 00:0b.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL-8169 Gigabit Ethernet (rev 10)

ETH0 00:0d.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL-8139/8139C/8139C+ (rev 10)


Here is the ifconfig.


eth0 Link encap:Ethernet HWaddr 00:50:2C:051:6B
inet addr:192.168.1.201 Bcast:192.168.1.255 Mask:255.255.255.0
inet6 addr: fe80::250:2cff:fe05:d16b/64 Scope:Link
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:340014174 errors:0 dropped:0 overruns:0 frame:0
TX packets:258254949 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:1652336234 (1575.7 Mb) TX bytes:707605757 (674.8 Mb)
Interrupt:18 Base address:0xd800

eth1 Link encap:Ethernet HWaddr 00:0A:CD:1C:19:32
inet addr:192.168.1.71 Bcast:192.168.1.255 Mask:255.255.255.0
inet6 addr: fe80::20a:cdff:fe1c:1932/64 Scope:Link
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:5166 errors:0 dropped:0 overruns:0 frame:0
TX packets:160 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:403611 (394.1 Kb) TX bytes:8242 (8.0 Kb)
Interrupt:19 Base address:0x6000
 
Old 05-12-2012, 11:43 PM   #2
Ser Olmy
Senior Member
 
Registered: Jan 2012
Distribution: Slackware
Posts: 2,404

Rep: Reputation: Disabled
Are you sure you haven't got the cards mixed up (eth0 vs eth1)?

What does ethtool (and/or mii-tool) report for eth0 and eth1 when you unplug a cable?
 
Old 05-13-2012, 07:30 AM   #3
jtarin
Member
 
Registered: May 2010
Location: Vladivostok, Russia
Distribution: LinuxMint 17
Posts: 103

Rep: Reputation: 23
Check your bios you might be able to disable the onboard without affecting the other....if that is what you want.
 
Old 05-13-2012, 10:18 AM   #4
HeadSpeakerJunky
LQ Newbie
 
Registered: May 2012
Posts: 2

Original Poster
Rep: Reputation: Disabled
What exactly am I looking at for ethtool command? I am positive that I have the NICs correct. If I remove ETH1 cable ETH0 continues to work but for some reason if I remove ETH0 ETH1 also goes down.

Disabling the NIC in the bios is what I would like to do, but for whatever reason ETH1 will not work without ETH0 being connected.
 
Old 05-13-2012, 11:29 AM   #5
Ser Olmy
Senior Member
 
Registered: Jan 2012
Distribution: Slackware
Posts: 2,404

Rep: Reputation: Disabled
ethtool will tell you the link state of the NIC (the last line). That will tell you if the link on eth1 is actually reported as down, and/or if perhaps the link on eth0 is still reported as up, even with the cable being unplugged.

I've never heard of a case where the state of one NIC somehow affected another. In your case, the NICs in question aren't even using the same driver, so this is quite a mystery. My guess is that this is caused by the link state of eth0 remaining as "up" when the cable is disconnected.

(Or this isn't related to the link at all, but rather to the IP address bound to eth0.)

Last edited by Ser Olmy; 05-13-2012 at 11:33 AM.
 
Old 05-13-2012, 08:13 PM   #6
chrism01
LQ Guru
 
Registered: Aug 2004
Location: Sydney
Distribution: Centos 6.8, Centos 5.10
Posts: 17,241

Rep: Reputation: 2325Reputation: 2325Reputation: 2325Reputation: 2325Reputation: 2325Reputation: 2325Reputation: 2325Reputation: 2325Reputation: 2325Reputation: 2325Reputation: 2325
Personally I'd edit the relevant files (RHEL = /etc/sysconfig/network-scripts/ifcfg-eth0, ifcfg-eth1) and set ONBOOT=yes for ETH1, ONBOOT=no for ETH0, then 'service network restart'
Customise that stuff as needed for your distro.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
eth1 interface goes down if eth0 interfaces cable is unplugged? harshalshete Linux - Networking 3 10-21-2011 08:49 AM
2 Nics problem: Eth1 disabled Eth0 YAOMK Linux - Networking 5 11-30-2008 05:11 AM
both eth0 and eth1 ping fail when one ethernet cable is unplugged powah Linux - Networking 12 04-10-2007 03:54 PM
howto acess intrnet thru eth1(wireless card)in winXP via briging in linux(eth0-eth1) labhesh_popli Linux - Wireless Networking 1 09-21-2006 02:11 AM
eth1 added, mysql connections FROM this machine are from eth1. Need bound to eth0??? kreese Linux - Networking 9 03-31-2004 01:12 PM


All times are GMT -5. The time now is 06:58 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration