LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 04-16-2002, 12:31 PM   #1
BoldKiller
Member
 
Registered: Apr 2002
Location: Montreal, Quebec
Distribution: Debian, Gentoo, RedHat
Posts: 142

Rep: Reputation: 15
Eth0 problem


I know there are similar questions already posted on the subject but none completely answered my question!

I am running Red Hat on a 486 for server testing purpose.

Initially I used 7.0. In setup, I told him what card I was using and the system asked my for the setup info (I have a DHCP on an NT Server). It was working fine (could ping other computers without problems).

Lately, I upgraded to 7.2. Actually I installed a fresh copy. The setup asked me for the card type and told me he found it but did not ask for setup info (dhcp, ip, mask, etc...)

I know I have to use ifconfig to setup the card. The problem is the card uses non standart io and IRQ. (io = 300 IRQ = 5) I have tried many variation to try and include those setting in the ifconfig command but with no luck. Can someone please help me!

To summarize:
I need to know how to setup the eth0 device to work
- io = 300
- IRQ = 5
- Type = Ne2000 compatible (ISA model) (no PCI bus on the 486!!)
- Using a DHCP

Thanks in advance for any help!
 
Old 04-16-2002, 01:41 PM   #2
Mara
Moderator
 
Registered: Feb 2002
Location: Grenoble
Distribution: Debian
Posts: 9,569

Rep: Reputation: 171Reputation: 171

insmod ne2 irq=5 io=0x300
then use ifconfig to configure eth0.
Insmod installs module for your nic and setups hardware (that's why you use hardware parameters with it).
One thing, it may be ne2 or ne. One of them will work.
 
Old 04-16-2002, 03:55 PM   #3
BoldKiller
Member
 
Registered: Apr 2002
Location: Montreal, Quebec
Distribution: Debian, Gentoo, RedHat
Posts: 142

Original Poster
Rep: Reputation: 15
Thanks for that, now how do I tell ifconfig to use DHCP ??

While on subject, why is it called ifconfig and not lets say ipconfig??

Thanks in advance!
 
Old 04-16-2002, 06:07 PM   #4
augamecock
Member
 
Registered: Feb 2002
Location: Atlanta, GA
Distribution: Debian
Posts: 78

Rep: Reputation: 15
You could try /sbin/pump

That's what I always used when I used DHCP
 
Old 04-16-2002, 06:58 PM   #5
BoldKiller
Member
 
Registered: Apr 2002
Location: Montreal, Quebec
Distribution: Debian, Gentoo, RedHat
Posts: 142

Original Poster
Rep: Reputation: 15
tried the insmod ne2 irq=5 io=0x300 says unknown module.

tried the insmod ne irq=5 io=0x300 gives me a list of errors.
5 path fallowed with : " unresolved symbols"

Any other idea??
 
Old 04-16-2002, 08:41 PM   #6
DMR
Member
 
Registered: Jun 2001
Location: Fairfax, California
Distribution: RH 9.0, RH 7.3, Mandrake 8.0
Posts: 986

Rep: Reputation: 30
Quote:
Originally posted by BoldKiller
tried the insmod ne2 irq=5 io=0x300 says unknown module.
Right- it should be ne. Also, IRQ 5 and an I/O address of 300 are pretty standard; have you configured the card itself for those settings via jumpers or software? If the card doesn't have jumpers, it should have come with some (probably DOS-based) configuration/utility floppy. If you don't have the software, you can try isapnptools.

Quote:
tried the insmod ne irq=5 io=0x300 gives me a list of errors.
5 path fallowed with : " unresolved symbols"
The ne driver is dependent on 8390.o, which must load before ne. Insmod isn't smart enough to know this; try updating the dependency database by running depmod -a, then do:
modprobe eth0
or
modprobe ne io=0x300 irq=5

If you get no errors, run lsmod and verify that the driver is in the resulting list of loaded modules.
After that, put the following in /etc/resolv.conf:

alias eth0 ne
options ne io=0x300 irq=5


As far as DHCP goes, you'll need to be running a DHCP client daemon. Augamemcock mentioned pump, dhcpcd is the other common one. Redhat 7.2 uses the graphical utility NEAT (NEtwork Administration Tool) to set up your networking parameters; just type neat at a command prompt to run it. You'll find the option to enable DHCP there.
 
Old 04-17-2002, 04:29 PM   #7
BoldKiller
Member
 
Registered: Apr 2002
Location: Montreal, Quebec
Distribution: Debian, Gentoo, RedHat
Posts: 142

Original Poster
Rep: Reputation: 15
Let me just rephrase my question. I'm new to Linux, so I need help with the Linux part of the configuration.

My network uses a DHCP on an NT server.
My card uses io=300, IRQ=5. (That is a fact I am sure of, it was configured like that by me a long time ago! And RedHat 7.0 installed it at those parameters.)


What I would like to is to have a full procedure as to how to make the installation. I have read on linuxdocumentation about it but what they were saying did not work (the only how-to I found was for RH 6.0).

DMR: I tried the NEAT command and it said: unknow Bash command (or similar to this).

Please dont asume I know what you are talking about unless it is Network related. I am completely new at this Linux stuff! (made my first step with DOS and been working with NT server since then)

Note: My linux box is a 486, I have xserver working on it (with window maker). But if you could give me the procedure for the command line I would really appreciate it!!

Thanks in advance!
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Problem withInternet, DHCP, connect with eth0 down work, connect with eth0 up not zowey Linux - Networking 1 03-12-2004 11:05 AM
Problem with eth0 raicar Linux - Networking 0 03-01-2004 10:46 AM
eth0:1 problem Dirt Linux - Networking 4 06-12-2003 05:19 PM
eth0 problem the_dash_71 Linux - Networking 1 06-12-2003 01:20 PM
Help please -Eth0 problem strangesame Linux - Newbie 5 01-08-2002 02:05 AM


All times are GMT -5. The time now is 02:54 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration