LinuxQuestions.org
Latest LQ Deal: Complete CCNA, CCNP & Red Hat Certification Training Bundle
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 09-16-2003, 08:04 AM   #1
Limelight
LQ Newbie
 
Registered: Sep 2003
Distribution: RedHat Enterprise WS 2.1
Posts: 4

Rep: Reputation: 0
Question eth0 interface not auto starting


Hello...

I recently installed Red Hat Linux Enterprise Edition 2.1 WS. This is my first Linux OS install and I'm having a bit of trouble with my ethernet adapter.

When I boot the machine, the loader gives me two options, 2.4.9-e12smp or 2.4.9-e12. It's been defaulting to the smp option, so that's what I've been using.

I also have the machine configured to automatically go to a GUI login screen. So far, I've been using the KDE interface.

When I get logged in to the KDE desktop, at a shell prompt I type "ifconfig" and it will only list the lo interface.

Then, I'll type insmod e1000 (the ethernet adap. is an itegrated Intel) and the module will load. Then when I do an ifconfig, I'll see both the lo and the eth0 interface. Also, once the eth0 interface is active, it keeps all of the settings that I previously gave it such as IP address, default gateway, and DNS servers.

So I guess my question is, is there a way I can get the OS to automatically activate the eth0 interface upon boot? It seems to work just fine if I manually activate via the shell. Is there a file or files that work like a STARTUP.NCF file on a Novell server that tell the machine what to load?

Sorry for the long post...just trying to be thorough. Thanks!
 
Old 09-16-2003, 08:39 AM   #2
Demonbane
LQ Guru
 
Registered: Aug 2003
Location: Sydney, Australia
Distribution: Gentoo
Posts: 1,796

Rep: Reputation: 47
Not sure if it's different for the enterprise edition, but do you have a /etc/sysconfig/network-scripts/ifcfg-eth0 file?
 
Old 09-16-2003, 09:11 AM   #3
Limelight
LQ Newbie
 
Registered: Sep 2003
Distribution: RedHat Enterprise WS 2.1
Posts: 4

Original Poster
Rep: Reputation: 0
Demonbane,

Yes, that files does exist on my system. There's a line in that file that reads ONBOOT=YES, so I figure
that because of that switch, the system should at least be trying to start the interface
upon boot. Is there a bootlog file that I could look at to see if the system even tried
to start it?

Thanks!
 
Old 09-16-2003, 09:40 AM   #4
Demonbane
LQ Guru
 
Registered: Aug 2003
Location: Sydney, Australia
Distribution: Gentoo
Posts: 1,796

Rep: Reputation: 47
you can take a look at /var/log/messages, try adding

Alias eth0 e1000

to your /etc/modules.conf, if it's not at least trying to bring up the nic.
 
Old 09-16-2003, 10:33 AM   #5
Limelight
LQ Newbie
 
Registered: Sep 2003
Distribution: RedHat Enterprise WS 2.1
Posts: 4

Original Poster
Rep: Reputation: 0
Demonbane...

Okay, well, I checked the /var/log/messages file and saw some references to e1000 and something about an invalid parameter parm_irq.

Then, when I checked the /etc/modules.conf file, I saw two lines in there:

alias eth0 e1000
alias options irq=10

I got rid of the alias options line, rebooted the system, and all is now good.

Thank you very much for your suggestions!
 
Old 09-16-2003, 06:52 PM   #6
another_eric
LQ Newbie
 
Registered: Sep 2003
Location: Los Angeles
Distribution: 9.1
Posts: 7

Rep: Reputation: 0
from linux admin textbook

Had replied with info but hadn't read all the other replys. looks like you figured it out.

There is a text that I found helpful:
Linux Administration, A Beginner's Guide, Third Edition
by Steve Graham and Steve Shaw
McGraw Hill

Last edited by another_eric; 09-16-2003 at 06:59 PM.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Internet (eth0 interface) does not auto-start sekelsenmat Linux - Networking 7 09-13-2005 10:10 AM
Bringing up interface eth0 Delaying eth0 initialization. [ FA bansal_ashok Linux - Networking 4 05-27-2005 10:09 AM
eth0 Auto Connect, How to auto start on logon cornish Linux - Networking 2 05-09-2005 12:02 PM
Bringing up interface eth0: determining ip information for eth0... failed ralphethomas Linux - Networking 0 01-24-2004 05:33 PM
eth0 interface... InSane103 Linux - Networking 1 07-12-2003 11:26 AM


All times are GMT -5. The time now is 06:07 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration