LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 02-14-2003, 08:13 PM   #1
snocked
Member
 
Registered: Dec 2002
Location: St. Louis, MO
Distribution: Slackware 9.1
Posts: 482

Rep: Reputation: 30
eth0 failed, but works


I've installed SuSE 8.1 countless times on this pc (connected to a router, which is hooked to a cable modem), and eth0 has always loaded and showed my ip/netmask during booting; however, today, after installing it, it says "eth0 failed", and not "eth0....failed". I have access to the Internet and it works fine, but this "eth0 failed" bothers me. Any ideas on where I can look to see why eth0 is failing when it's not even trying ... before the failed message appears?

here's my ifconfig:

linux:/home/snocked # ifconfig
eth0 Link encap:Ethernet HWaddr 00:50:8D:A6:1F:14
inet addr:192.168.0.2 Bcast:192.168.0.255 Mask:255.255.255.0
inet6 addr: fe80::250:8dff:fea6:1f14/10 Scope:Link
UP BROADCAST NOTRAILERS RUNNING MULTICAST MTU:1500 Metric:1
RX packets:1045 errors:0 dropped:0 overruns:0 frame:0
TX packets:1074 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:100
RX bytes:524943 (512.6 Kb) TX bytes:163175 (159.3 Kb)
Interrupt:11 Base address:0xe000

lo Link encap:Local Loopback
inet addr:127.0.0.1 Mask:255.0.0.0
inet6 addr: ::1/128 Scope:Host
UP LOOPBACK RUNNING MTU:16436 Metric:1
RX packets:40 errors:0 dropped:0 overruns:0 frame:0
TX packets:40 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:0
RX bytes:2456 (2.3 Kb) TX bytes:2456 (2.3 Kb)


Last edited by snocked; 02-14-2003 at 08:22 PM.
 
Old 02-14-2003, 08:26 PM   #2
MasterC
LQ Guru
 
Registered: Mar 2002
Location: Salt Lake City, UT - USA
Distribution: Gentoo ; LFS ; Kubuntu
Posts: 12,612

Rep: Reputation: 68
/var/log/messages That or dmesg|less This is the place to look for boot errors, and address them.

Cool
 
Old 02-14-2003, 08:36 PM   #3
snocked
Member
 
Registered: Dec 2002
Location: St. Louis, MO
Distribution: Slackware 9.1
Posts: 482

Original Poster
Rep: Reputation: 30
these two look problematic in /var/log/messages:
Feb 14 20:25:42 linux dhcpcd[1890]: infinite IP address lease time. Exiting
Feb 14 20:27:43 linux kernel: eth0: no IPv6 routers present

these eth0 look normal:
Feb 14 20:27:23 linux kernel: 8139too Fast Ethernet driver 0.9.26
Feb 14 20:27:23 linux kernel: eth0: RealTek RTL8139 Fast Ethernet at 0xf896e000, 00:50:8d:a6:1f:14, IRQ 11
Feb 14 20:27:23 linux kernel: eth0: Identified 8139 chip type 'RTL-8139C'
Feb 14 20:27:23 linux kernel: eth0: Setting 100mbps full-duplex based on auto-negotiated partner ability 45e1.
Feb 14 20:27:31 linux kernel: IPv6 v0.8 for NET4.0
Feb 14 20:27:31 linux kernel: IPv6 over IPv4 tunneling driver

dmesg:
eth0: no IPv6 routers present

Any ideas what I should do?

Last edited by snocked; 02-14-2003 at 08:39 PM.
 
Old 02-14-2003, 09:20 PM   #4
MasterC
LQ Guru
 
Registered: Mar 2002
Location: Salt Lake City, UT - USA
Distribution: Gentoo ; LFS ; Kubuntu
Posts: 12,612

Rep: Reputation: 68
Sure, you could climb through your rc files and locate the section that searches for the IPv6 router (which you don't have) and comment out the line that looks for it. However, being SuSE it will cut off your hand for doing so It seems to not like actual tampering with the rc scripts directly, that's the job of some gui tool that you should never touch (or at least that seems to be what SuSe would like to believe ). I personally wouldn't even give it a second glance, live with the error, it's causing no problems, and it's simply saying you don't have an IPv6 router, no biggie there.

Cool
 
Old 02-14-2003, 09:38 PM   #5
snocked
Member
 
Registered: Dec 2002
Location: St. Louis, MO
Distribution: Slackware 9.1
Posts: 482

Original Poster
Rep: Reputation: 30
You're right. I shouldn't worry; however, I can't get past it in my head.
 
Old 02-14-2003, 09:42 PM   #6
MasterC
LQ Guru
 
Registered: Mar 2002
Location: Salt Lake City, UT - USA
Distribution: Gentoo ; LFS ; Kubuntu
Posts: 12,612

Rep: Reputation: 68
That's cool, if you want to hunt down the problem, try to find which rc starts that. It may be written quite cryptically, and rough to decipher, however that'd be more than likely the place to go to remove or comment out a line starting that and causing that specific error. You may also look into xinetd (spelling?) and see if it's getting started (or executing the error) in there.

You do have 1 other option, get a router that conforms to IPv6

Cool
 
Old 02-14-2003, 11:46 PM   #7
snocked
Member
 
Registered: Dec 2002
Location: St. Louis, MO
Distribution: Slackware 9.1
Posts: 482

Original Poster
Rep: Reputation: 30
My router does support IPv6. I've installed SuSE 8.1 at least 6 times on this pc and the eth0 and network settings were all automatically configured correctly all the previous times. All of a sudden on this recent install, eth0 fails it's driving me crazy. The whole reason I was interested in linux was because of the networking side, and now I'm getting very discouraged. Everything is working perfectly in Windows.
 
Old 02-15-2003, 01:33 AM   #8
MasterC
LQ Guru
 
Registered: Mar 2002
Location: Salt Lake City, UT - USA
Distribution: Gentoo ; LFS ; Kubuntu
Posts: 12,612

Rep: Reputation: 68
I don't mean for this to sound as it's going to...

Why don't you figure out networking then if you are interested in how it works in linux Not saying you don't know a whole lot about networking, but if you are installing SuSE (and from the sounds of it, that is all) and just, boom, the default install is "working" and now all of a sudden "not working" then it doesn't sound like you are all that interested in the networking side of linux. To more nicely word this:
Have you checked into some how-to's on linux networking with the IPv6 protocol, have you read up on linux networking tutorials and applied them to your setup? Have you checked into kernel options on configuring this protocol?

Again, I appologize for making it sound the way it does, however if you really are "interested" in the networking aspect of Linux, one would think there would be more involved in your network setup than a default SuSE install, and things just "working"

Cool
 
Old 02-15-2003, 02:32 AM   #9
snocked
Member
 
Registered: Dec 2002
Location: St. Louis, MO
Distribution: Slackware 9.1
Posts: 482

Original Poster
Rep: Reputation: 30
No, don't worry. I understand what you mean, but this is my first time using linux. I first installed it a few months ago. I just don't understand how default autoconfiguring worked so many times before and now all of a sudden doesn't work on the same hardware. I can't tell if it's an issue with my ethernet card or my router because both worked before in SuSE and windows, and now doesn't work just in SuSE.

I also found out at the SuSE site my onboard ethernet card RTL8139's support status is a "?". It's not listed as fully supported or problematic; however, in the support database, they said RTL8139 wasn't supported by the module in the 2.4.x kernel. It says to edit an entry in /etc/modules.conf, but what mine says is different from theirs. I'm very confused.
 
Old 02-15-2003, 02:38 AM   #10
MasterC
LQ Guru
 
Registered: Mar 2002
Location: Salt Lake City, UT - USA
Distribution: Gentoo ; LFS ; Kubuntu
Posts: 12,612

Rep: Reputation: 68
The module that is used for those cards is now called 8139too not rtl8139 or whatever it used to be. I don't know if that'll help you when looking for info on it. Also, those cards are definitely supported in linux. That makes up a large portion of the cards on the market, so it'd be sort of a bad idea for linux not to have a driver for it Yeah, the realtek 8139 based cards definitely work on the later kernels (at least 2.4.10 and up) and probably all of the 2.4.x series, and probably by default. I don't think it's a hardware problem at all, probably just 1 little package that didn't get installed for some very odd reason this time. I wish I knew more about SuSE and what the hell they have going on in their minds when they are making their distro, but I can't help with this problem all that much since it's appearing to be a SuSE style problem, and more-so meaning it's a SuSE specific problem since IPv6 support is in the kernel itself.



Good Luck, and I'm glad you didn't take my above post the wrong way

Cool
 
Old 02-15-2003, 03:04 AM   #11
snocked
Member
 
Registered: Dec 2002
Location: St. Louis, MO
Distribution: Slackware 9.1
Posts: 482

Original Poster
Rep: Reputation: 30
The module listed in my /etc/modules.conf for eth0 was nvnet, not rtl8139 or whatever they have listed. Thanks for the help though.
 
Old 08-04-2003, 06:53 AM   #12
nonamenobody
Member
 
Registered: Oct 2002
Posts: 138

Rep: Reputation: 22
Sorry for reviving this very old thread, I just found it whilst googling for 'infinite IP address lease time'.

>> Feb 14 20:25:42 linux dhcpcd[1890]: infinite IP address lease time. Exiting
>> Feb 14 20:27:43 linux kernel: eth0: no IPv6 routers present

The second message is usual, it is just for information (my system gives it but nothing fails).

The first message is an error message, however it is inconsequential. It is basically saying that you have your DHCP lease for as long as you need it and their is no point running dhcpcd, so it is quiting. You can overcome this error by telling dhcpcd to suggest a lease time to the DHCP server. In SuSE 8.2 this is done by editing the 'DHCLIENT_LEASE_TIME' variable '/etc/sysconfig/network/dhcp'. If you enter a lease time of (say) 24 hours (ie. 86400 seconds), hopefully your DHCP server should accept this and everything should work fine. Alternatively you may be able to change the DHCP settings on your router so that is gives a finite lease time.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
eth0: [Failed] antiliphe Linux - Networking 1 09-17-2004 05:09 PM
Bringing up interface eth0: determining ip information for eth0... failed ralphethomas Linux - Networking 0 01-24-2004 05:33 PM
Boot Message: 'eth0 failed' but still works? olias Mandriva 11 12-31-2003 05:50 PM
Eth0 failed message buddaguy Linux - Networking 2 01-12-2002 02:33 AM
...eth0 [Failed] Nooooobie Linux - Newbie 22 10-21-2001 10:07 PM


All times are GMT -5. The time now is 05:50 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration