LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 04-20-2002, 03:08 AM   #1
tumnus
Member
 
Registered: Apr 2002
Location: La Jolla, CA
Distribution: Redhat 8.0
Posts: 60

Rep: Reputation: 15
eth0 error


hello
i have just installed redhat linux 7.2 and have never used linux before and when starting up i always fail on the loading of eth0
i have swapped out the network card with a new one also and i still get the same error
does anyone have any suggestions?
 
Old 04-20-2002, 03:32 AM   #2
Mara
Moderator
 
Registered: Feb 2002
Location: Grenoble
Distribution: Debian
Posts: 9,568

Rep: Reputation: 164Reputation: 164

Boot into run command ifconfig and send the results of it. And write what nic you're using.
 
Old 04-20-2002, 07:42 AM   #3
alinas
Member
 
Registered: Apr 2002
Location: UK, Sywell, EGBK
Distribution: RHEL, SuSE, CentOS, Debian, Ubuntu
Posts: 60

Rep: Reputation: 20
I am assuming your card is detected, otherwise you wouldn't be getting the error message in the first place...
Login as root, and run the ifconfig command. You should see two paragraphs, one for lo (loopback device) and one for eth0.

Correctly configured eth0 shows something similar to:
eth0 Link ....
inet addr: 192.168.42.100 Mask 255.0.0.0
UP BROADCAST RUNNING ....
....

If you don't see the eth0 paragraph, or the UP flag, try command:
ifconfig eth0 up

Then run ifconfig again.

If you have configured your card for DHCP, you will not have the inet addr (192.168.42.100 in this case).

cheers,
alina
 
Old 04-20-2002, 10:47 AM   #4
Rodcl
Member
 
Registered: Apr 2002
Location: Manchester, England
Distribution: Slackware 9.1
Posts: 113

Rep: Reputation: 15
try this ...

get in to your BIOS and disable plug and play OS,
if enabled it means that the BIOS will do the plug and play work rather than the OS.
I had the same problem with my sound card, it was detected but i could not load the modules for some strange reason.
I disabled this option and worked!!

best of luck!!
 
Old 04-20-2002, 03:10 PM   #5
tumnus
Member
 
Registered: Apr 2002
Location: La Jolla, CA
Distribution: Redhat 8.0
Posts: 60

Original Poster
Rep: Reputation: 15
i ran the ifconfig eth0 up command to get it to say both of the paragraphs under ifconfig, and now it says:

eth0 Link encap:Ethernet HWaddr 00:C0:F0:5B:F3:B7
UP BROADCAST RUNNING MTU:1500 Metric:1
RX packets:0 errors:0 dropped:0 overruns:0 frame:0
TX packets:4 errors:1 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:100
RX bytes:0 (0.0 b) TX bytes:2360 (2.3 Kb)
Interrupt:11 Base address:0x2c00

lo Link encap: Local Loopback
inet addr:127.0.0.1 Mask:255.0.0.0
UP LOOPBACK RUNNING MTU:16436 Metric:1
RX packets:28 errors:0 dropped:0 overruns:0 frame:0
TX packets:28 errors:1 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:0
RX bytes:1854 (1.8 Kb) TX bytes:1854 (1.8 Kb)
 
Old 04-21-2002, 02:37 AM   #6
tumnus
Member
 
Registered: Apr 2002
Location: La Jolla, CA
Distribution: Redhat 8.0
Posts: 60

Original Poster
Rep: Reputation: 15
hmmm
somehow i am currently viewing this web page from linux because internet started working
i have no idea how it eventually worked since im not firmiliar with linux yet, but oh well
thanks for your help, and i will just hope that once i restart i will be able to connect again
 
Old 05-25-2004, 01:50 PM   #7
master
Member
 
Registered: Oct 2003
Location: Birmingham/Eng/UK
Distribution: /Debian3.1/suse/XP/Win7
Posts: 677

Rep: Reputation: 30
hello i think iv got a similar problem when i start redhat 9 i get an nerror message saying "bcm4400 device eth0 not responding or not present delaying initialisation so i went in to my bios disabled pnp rebooted went in to a terminal as root typed "ifconfig" the feedback was
lo link encap:local loopback
inet addr:127.0.0.1 mask:255.0.0.0
rx packets:697 errors:0 dropped:0 overuns:0 frame:0
tx packets:697 errors:0 dropped:0 overuns:0 carrier:0
collisions:0 txqueuelen:0
rxbytes:47090 (45.9 kb) txbytes:47090(45.9kb)
i then typed "ifconfig eth0 up"the feedback was
"no such device" can any 1 help please
 
Old 05-25-2004, 04:14 PM   #8
Mara
Moderator
 
Registered: Feb 2002
Location: Grenoble
Distribution: Debian
Posts: 9,568

Rep: Reputation: 164Reputation: 164
master, Is the card in when you get the error? What kind of a NIC is it?
 
Old 05-26-2004, 03:58 AM   #9
alinas
Member
 
Registered: Apr 2002
Location: UK, Sywell, EGBK
Distribution: RHEL, SuSE, CentOS, Debian, Ubuntu
Posts: 60

Rep: Reputation: 20
master,
I guess your card is not configured at all!

As user root, type:

redhat-config-network

That (on RedHat 9) brings up the Network Configuration window. Press "New", and follow the instructions...
Once the card is listed in the window, use "Edit" to assign IP address and so on.
Once you do, remember to activate the card, and do "File --> Save" before you close the window.

All this can be achieved at the command line, but the GUI is solid and helpful, so why not...
 
Old 05-26-2004, 03:49 PM   #10
master
Member
 
Registered: Oct 2003
Location: Birmingham/Eng/UK
Distribution: /Debian3.1/suse/XP/Win7
Posts: 677

Rep: Reputation: 30
yes the card is in when i get the error it is even showing in
"/etc/modules.conf"it is a "broadcom bcm4401 ethernet"
 
Old 05-26-2004, 04:14 PM   #11
master
Member
 
Registered: Oct 2003
Location: Birmingham/Eng/UK
Distribution: /Debian3.1/suse/XP/Win7
Posts: 677

Rep: Reputation: 30
hello again when i go in to network config
click on new,click on ethernet, my card is listedit is a "bcm4400 (eth0)"it is highlighted i click forward i click on "statically set ip address" it asks me to fill in 3 boxes
"address" i put in my ip address
"subnetmask"255.255.248.0
"defaultgateway"82.36.64.1
i click "forward"
message says u have selected the following information
device eth0bcm4400) automatically obtain ip address
setting with:none click apply
i know have another box up ther is a choice of boxes to click on "hardware" "dns" "hosts"
if i clik on hardware it says
description = ethernet
type = ethernet
device = eth0
if i click on "dns" it says
hostname = blueyonder.co.uk
primary dns = 62.31.144.39
secondary dns = 195.188.53.175
teritory dns = this space is blank
dns search path = this space is blank
if i click on hosts it says
ip = 127.0.0.1
name = blueyonder.co.uk
aliases = this space is left blank
if i then click on activate it says "bcm4400"device eth0 does not seem to be present delaying initialisation"
 
Old 05-26-2004, 11:49 PM   #12
master
Member
 
Registered: Oct 2003
Location: Birmingham/Eng/UK
Distribution: /Debian3.1/suse/XP/Win7
Posts: 677

Rep: Reputation: 30
come opn folks im getting desperate
 
Old 05-27-2004, 03:28 PM   #13
master
Member
 
Registered: Oct 2003
Location: Birmingham/Eng/UK
Distribution: /Debian3.1/suse/XP/Win7
Posts: 677

Rep: Reputation: 30
ok can any 1 tell me why it must be in eth0 and not lets say eth1
 
Old 05-27-2004, 04:25 PM   #14
master
Member
 
Registered: Oct 2003
Location: Birmingham/Eng/UK
Distribution: /Debian3.1/suse/XP/Win7
Posts: 677

Rep: Reputation: 30
hello again iv cracked it just want to sat thanks to every 1 who helped when i turned my comp off and back on again kudzu detected my nic and now im a surfing
 
Old 01-14-2006, 01:38 AM   #15
liangtp
LQ Newbie
 
Registered: Jan 2006
Location: putrajaya malaysia
Distribution: RH Linux Enterprise 4.0
Posts: 7

Rep: Reputation: 0
hi master, may i know how you cracked it?
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Bringing up interface eth0 error tommytomato Linux - Networking 1 11-06-2005 12:56 AM
Error while initializing eth0 blpriya12 Linux - General 3 05-09-2005 10:13 AM
Booting Error (eth0 won't load) julienroger Linux - Newbie 4 08-15-2004 02:00 AM
Bringing up interface eth0 error tommytomato Linux - Newbie 11 05-19-2004 10:10 PM
newb help please. 2 NIC eth0 error ratty007 Linux - Networking 5 11-29-2003 05:42 AM


All times are GMT -5. The time now is 01:33 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration