LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 03-16-2012, 03:22 AM   #16
windstory
Member
 
Registered: Nov 2008
Posts: 486

Original Poster
Rep: Reputation: 36

smilemukul/ After failure of 1st tip, I followed send tip, but same result.

And I disabled iptables.

This is "/etc/sysconfig/network-scripts/ifcfg-eth0"

Quote:
DEVICE=eth0
BOOTPROTO=none
IPADDR=192.168.0.4
NETMASK=255.255.255.0
GATEWAY=192.168.0.1
HWADDR=08:00:27:d3:08:db
NM_CONTROLLED=yes
ONBOOT=yes
TYPE=Ethernet
USERCTL=no
PEERDNS=yes
IPV6INIT=no
And the result of "ifconfig eth0".
Quote:
[root@localhost Documents]# ifconfig eth0
eth0 Link encap:Ethernet HWaddr 08:00:273:08B
inet addr:192.168.0.4 Bcast:192.168.0.255 Mask:255.255.255.0
inet6 addr: fe80::a00:27ff:fed3:8db/64 Scope:Link
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:0 errors:0 dropped:0 overruns:0 frame:0
TX packets:44 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:0 (0.0 b) TX bytes:6666 (6.5 KiB)
"192.168.0.102" is from the result of dhcp ip address which is from 1st tip. And it's from Linux.
 
Old 03-16-2012, 03:33 AM   #17
smilemukul
Member
 
Registered: Jun 2009
Distribution: Redhat,CentOS,Ubuntu,Puppet
Posts: 292

Rep: Reputation: 34
If you are following my 2nd tip i.e, dhcp then why are you assigning the ip details in "/etc/sysconfig/network-scripts/ifcfg-eth0", remove the ip details from the config file as,
IPADDR=192.168.0.4
NETMASK=255.255.255.0
GATEWAY=192.168.0.1

& edit BOOTPROTO=dhcp. I hope you had not check my steps what I had mentioned.
 
1 members found this post helpful.
Old 03-16-2012, 03:57 AM   #18
windstory
Member
 
Registered: Nov 2008
Posts: 486

Original Poster
Rep: Reputation: 36
smilemukul/ After failure of 1st tip, I've followed 2nd tip. And disabled iptables.

1. /etc/sysconfig/network-scripts/ifcfg-eth0
Quote:
DEVICE=eth0
BOOTPROTO=none
IPADDR=192.168.0.4
NETMASK=255.255.255.0
GATEWAY=192.168.0.1
HWADDR=08:00:27:d3:08:db
NM_CONTROLLED=yes
ONBOOT=yes
TYPE=Ethernet
USERCTL=no
PEERDNS=yes
IPV6INIT=no
2. the result of "ifconfig eth0".
Quote:
[root@localhost Documents]# ifconfig eth0
eth0 Link encap:Ethernet HWaddr 08:00:273:08B
inet addr:192.168.0.4 Bcast:192.168.0.255 Mask:255.255.255.0
inet6 addr: fe80::a00:27ff:fed3:8db/64 Scope:Link
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:0 errors:0 dropped:0 overruns:0 frame:0
TX packets:89 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:0 (0.0 b) TX bytes:16714 (16.3 KiB)
3. The ip "192.168.0.102" is from 1st tip's setting. And the ping command is execuded at Linux.
 
Old 03-16-2012, 04:04 AM   #19
smilemukul
Member
 
Registered: Jun 2009
Distribution: Redhat,CentOS,Ubuntu,Puppet
Posts: 292

Rep: Reputation: 34
/etc/sysconfig/network-scripts/ifcfg-eth0 is same as previous, you have to delete the ip details entries from the config file & add BOOTPROTO=dhcp
 
1 members found this post helpful.
Old 03-16-2012, 04:09 AM   #20
windstory
Member
 
Registered: Nov 2008
Posts: 486

Original Poster
Rep: Reputation: 36
smilemukul/

I changed "/etc/sysconfig/network-scripts/ifcfg-eth0".

Quote:
DEVICE=eth0
BOOTPROTO=dhcp
HWADDR=08:00:27:d3:08:db
NM_CONTROLLED=yes
ONBOOT=yes
TYPE=Ethernet
USERCTL=no
PEERDNS=yes
IPV6INIT=no
And "service network restart", and execute ping.
Quote:
[root@localhost Documents]# ping 192.168.0.1
PING 192.168.0.1 (192.168.0.1) 56(84) bytes of data.
From 192.168.0.102 icmp_seq=2 Destination Host Unreachable
From 192.168.0.102 icmp_seq=3 Destination Host Unreachable
From 192.168.0.102 icmp_seq=4 Destination Host Unreachable
 
Old 03-16-2012, 04:49 AM   #21
smilemukul
Member
 
Registered: Jun 2009
Distribution: Redhat,CentOS,Ubuntu,Puppet
Posts: 292

Rep: Reputation: 34
try to release the ip address through,

service network restart
dhcp -r
dhclient
 
1 members found this post helpful.
Old 03-16-2012, 05:27 AM   #22
windstory
Member
 
Registered: Nov 2008
Posts: 486

Original Poster
Rep: Reputation: 36
smilemukul/ At this time eth0 is not connect with network.

Quote:
[root@localhost Documents]# ifconfig
eth0 Link encap:Ethernet HWaddr 08:00:273:08B
inet6 addr: fe80::a00:27ff:fed3:8db/64 Scope:Link
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:0 errors:0 dropped:0 overruns:0 frame:0
TX packets:16 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:0 (0.0 b) TX bytes:3888 (3.7 KiB)

lo Link encap:Local Loopback
inet addr:127.0.0.1 Mask:255.0.0.0
inet6 addr: ::1/128 Scope:Host
UP LOOPBACK RUNNING MTU:16436 Metric:1
RX packets:48 errors:0 dropped:0 overruns:0 frame:0
TX packets:48 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:0
RX bytes:3080 (3.0 KiB) TX bytes:3080 (3.0 KiB)

[root@localhost Documents]# service network restart
Shutting down loopback interface: [ OK ]
Bringing up loopback interface: [ OK ]
 
Old 03-21-2012, 03:48 AM   #23
windstory
Member
 
Registered: Nov 2008
Posts: 486

Original Poster
Rep: Reputation: 36
smilemukul/ Thanks for your kind concerns.

However, for fixing this rproblem, I reinstalled scientific linux, but it became more serious problem.
 
Old 03-21-2012, 03:59 AM   #24
smilemukul
Member
 
Registered: Jun 2009
Distribution: Redhat,CentOS,Ubuntu,Puppet
Posts: 292

Rep: Reputation: 34
Are you able to connect to the web & if not then can print,

1. ifconfig eth0
2. Print status of ping google.com
3. /etc/sysconfig/network
4. /etc/sysconfig/network-scripts/ifcfg-eth0
5. iptables -L
6. hostname
7. export |grep proxy_http

Also let me know if you had configure any proxy server settings ?
 
1 members found this post helpful.
Old 03-21-2012, 10:46 PM   #25
windstory
Member
 
Registered: Nov 2008
Posts: 486

Original Poster
Rep: Reputation: 36
Everytime I should execute "service NetworkManager start" after booting.

1. ifconfig eth0
Quote:
[root@linux ~]# ifconfig -a
eth0 Link encap:Ethernet HWaddr 08:00:27:AE:64:B2
inet addr:192.168.0.4 Bcast:192.168.0.255 Mask:255.255.255.0
inet6 addr: fe80::a00:27ff:feae:64b2/64 Scope:Link
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:0 errors:0 dropped:0 overruns:0 frame:0
TX packets:39 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:0 (0.0 b) TX bytes:7667 (7.4 KiB)
2. Print status of ping google.com
Quote:
[root@linux ~]# ping google.com
ping: unknown host google.com
3. /etc/sysconfig/network
Quote:
NETWORKING=yes
HOSTNAME=linux.iptime.org
NETOWRKING_IPV6=no
GATEWAY=192.168.0.1
4. /etc/sysconfig/network-scripts/ifcfg-eth0
Quote:
TYPE=Ethernet
BOOTPROTO=none
DEFROUTE=yes
IPV4_FAILURE_FATAL=no
IPV6INIT=no
NAME="eth0"
UUID=d279b508-fa23-4f9f-81c8-d98ae0875eab
ONBOOT=yes
DEVICE=eth0
USERCTL=yes
HWADDR=08:00:27:AE:64:B2
IPADDR=192.168.0.4
PREFIX=24
GATEWAY=192.168.0.1
DNS1=8.8.8.8
5. iptables -L
* I disabled firewall and selinux for resolving this problem.
Quote:
[root@linux ~]# iptables -L
Chain INPUT (policy ACCEPT)
target prot opt source destination

Chain FORWARD (policy ACCEPT)
target prot opt source destination

Chain OUTPUT (policy ACCEPT)
target prot opt source destination
6. hostname
Quote:
[root@linux ~]# hostname
linux.iptime.org
*This is my domain, so I changed first word.

7. export |grep proxy_http
Quote:
[root@maestro ~]# export |grep proxy_http
[root@maestro ~]#
Also let me know if you had configure any proxy server settings ?
* I don't know how to set up proxy server.
 
Old 03-22-2012, 04:31 AM   #26
smilemukul
Member
 
Registered: Jun 2009
Distribution: Redhat,CentOS,Ubuntu,Puppet
Posts: 292

Rep: Reputation: 34
Are you able to ping to your gateway server & if not then there is some issue between your server & gateway.You can check
your hardware connections & cables.
 
1 members found this post helpful.
Old 03-22-2012, 02:36 PM   #27
windstory
Member
 
Registered: Nov 2008
Posts: 486

Original Poster
Rep: Reputation: 36
smilemukul/ Unfortuantelly the ping does not get to gateway. I'll check "your server & gateway" and network connections.

Thanks for your kind attention.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
trouble with eth0, cant connect to internet evgeni22 Linux - Networking 1 01-20-2010 03:01 PM
Can't connect to the internet no eth0 interface. okos Linux - Software 2 05-15-2008 05:11 PM
Cannot connect to internet,(DSL) eth0 not found Neoltlink Slackware 8 01-29-2006 04:45 PM
Can't connect to internet - eth0 not recognized guyfromcanada Fedora 14 10-04-2004 11:30 PM
eth0 seems to stop when I connect to the Internet kyutums Linux - Networking 4 06-19-2003 06:38 AM


All times are GMT -5. The time now is 02:50 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration