LinuxQuestions.org
Review your favorite Linux distribution.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 03-10-2011, 11:25 PM   #1
mridul chandhok
LQ Newbie
 
Registered: Jun 2010
Location: New Delhi, India
Distribution: Ubuntu
Posts: 17

Rep: Reputation: 0
Unhappy # /etc/sysctl.conf -p : permission denied


after adding the following lines in /etc/sysctl.conf file
#ORACLE PARAMETERS
kernel.shmall = 2097152
kernel.shmmax = 2147483648
kernel.shmmni = 4096
kernel.sem = 250 32000 100 128
fs.file-max = 65536
net.ipv4.ip_local_port_range = 1024 65000
net.core.rmem_default = 262144
net.core.rmem_max = 262144
net.core.wmem_default = 262144
net.core.wmem_max = 262144

:wq!

when i run command in vi editor
# /etc/sysctl.conf -p

it shows permission denied
 
Old 03-11-2011, 12:28 AM   #2
corp769
LQ Guru
 
Registered: Apr 2005
Posts: 5,817

Rep: Reputation: 1002Reputation: 1002Reputation: 1002Reputation: 1002Reputation: 1002Reputation: 1002Reputation: 1002Reputation: 1002
If you are editing the file as a standard user, you will not be able to do anything with that file because you need to be root to edit it.
 
0 members found this post helpful.
Old 03-11-2011, 01:06 AM   #3
JZL240I-U
Senior Member
 
Registered: Apr 2003
Location: Germany
Distribution: openSuSE 42.1_64+Tumbleweed-KDE, Mint 17.3
Posts: 4,035

Rep: Reputation: Disabled
Quote:
Originally Posted by mridul chandhok View Post
...
kernel.shmmni = 4096
...
"min"? Might cause a follow up error.
 
Old 03-11-2011, 01:13 AM   #4
corp769
LQ Guru
 
Registered: Apr 2005
Posts: 5,817

Rep: Reputation: 1002Reputation: 1002Reputation: 1002Reputation: 1002Reputation: 1002Reputation: 1002Reputation: 1002Reputation: 1002
Quote:
Originally Posted by JZL240I-U View Post
"min"? Might cause a follow up error.
Good catch, I didn't see that at first.
 
Old 03-11-2011, 07:06 AM   #5
mridul chandhok
LQ Newbie
 
Registered: Jun 2010
Location: New Delhi, India
Distribution: Ubuntu
Posts: 17

Original Poster
Rep: Reputation: 0
Quote:
Originally Posted by corp769 View Post
If you are editing the file as a standard user, you will not be able to do anything with that file because you need to be root to edit it.
i am at root still it shows the error permission denied
 
Old 03-11-2011, 07:16 AM   #6
rafatmb
LQ Newbie
 
Registered: Feb 2011
Posts: 27

Rep: Reputation: 3
If you really use Ubuntu, try to do:

sudo vi /etc/sysctl.conf

then type the root password

[]'s

Rafa
Linux, Linux and Linux! Suporte Linux
 
Old 03-11-2011, 07:34 AM   #7
mridul chandhok
LQ Newbie
 
Registered: Jun 2010
Location: New Delhi, India
Distribution: Ubuntu
Posts: 17

Original Poster
Rep: Reputation: 0
Quote:
Originally Posted by rafatmb View Post
If you really use Ubuntu, try to do:

sudo vi /etc/sysctl.conf

then type the root password

[]'s

Rafa
Linux, Linux and Linux! Suporte Linux
this is what exactly i am doing
at terminal
"
[mridul@localhost ~]$ su
password: // password entered
[root@localhost mridul]# sudo vi /etc/sysctl.conf // added the lines mentioned above in the file(sysctl.conf) saved it using :wq!
// when i give the following command it shows permission denied
[root@localhost mridul]# /etc/sysctl.conf -p
bash: /etc/sysctl.conf: permission denied
"
 
Old 03-11-2011, 07:46 AM   #8
JZL240I-U
Senior Member
 
Registered: Apr 2003
Location: Germany
Distribution: openSuSE 42.1_64+Tumbleweed-KDE, Mint 17.3
Posts: 4,035

Rep: Reputation: Disabled
Quote:
Originally Posted by mridul chandhok View Post
this is what exactly i am doing
at terminal
"
...
[root@localhost mridul]# /etc/sysctl.conf -p
bash: /etc/sysctl.conf: permission denied
"
Of course the .conf file is not executable, thus "permission denied". Try "/sbin/sysctl -p".

Last edited by JZL240I-U; 03-11-2011 at 07:48 AM.
 
1 members found this post helpful.
Old 03-11-2011, 08:18 AM   #9
mridul chandhok
LQ Newbie
 
Registered: Jun 2010
Location: New Delhi, India
Distribution: Ubuntu
Posts: 17

Original Poster
Rep: Reputation: 0
thanks a lot
 
Old 03-11-2011, 08:38 AM   #10
JZL240I-U
Senior Member
 
Registered: Apr 2003
Location: Germany
Distribution: openSuSE 42.1_64+Tumbleweed-KDE, Mint 17.3
Posts: 4,035

Rep: Reputation: Disabled
You are welcome .
 
1 members found this post helpful.
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
bash: /etc/ld.so.conf: Permission denied theKbStockpiler Linux - General 5 09-11-2010 05:01 PM
Permission Denied when trying to run /etc/vsftpd.conf Jack of Spades Linux - Newbie 2 06-10-2007 07:33 PM
/etc/make.conf >permission denied eytan *BSD 5 03-06-2005 09:48 PM
/etc/lilo.conf permission denied ginge12 Linux - Newbie 14 09-18-2003 08:18 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie

All times are GMT -5. The time now is 09:52 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration