LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices

Reply
 
Search this Thread
Old 06-21-2004, 03:52 AM   #1
sujith_marar
LQ Newbie
 
Registered: Apr 2004
Posts: 12

Rep: Reputation: 0
Unhappy /etc/initab problem


Dear Linux geeks,

Topic : /etc/inittab
I use
OS Details :
No. of OS s used Dual
First :Red Hat Linux 8.0 -3GB
Second : Win XP -35GB
BootLoader Used -GRUB

Problem : Recently I had a problem with the XServer with use of the following
command, startx, . After typing 'startx' at the command prompt
[root@localhost....]#startx
40 to 50 lines splash out in text, with one, probably 20th or 21st of the line, saying that
''screens not found''
OK agreed with that
Then I took my next step, typed at the command prompt, to check that whether there is any display by testing with a tool , normally comes with all Red Hat Distros,Xtest.
No Display do come . Wait for 10 seconds by going to next line without any cursor Then the root prompt gets displayed
It is as shown below
[root@localhost....]#Xtest
[root@localhost....]#
It means that the XServer has bug
Again agreed with that. So , proceeded to do the next step,
I went ahead and came to the 'etc' directory to make a change at the 'inittab' file so that I could start the X Display without going at the text mode, probably,root prompt and the startx command
Before making change to the the /etc/inittab file. the /etc/inittab file, with a few of the top lines, looked like this as shown below
[root@localhost..... /]$ more /etc/inittab
#
# inittab This file describes how the INIT process should set up
# the system in a certain run-level.
#
# Author: Miquel van Smoorenburg, <miquels@drinkel.nl.mugnet.org>
# Modified for RHS Linux by Marc Ewing and Donnie Barnes
#

# Default runlevel. The runlevels used by RHS are:
# 0 - halt (Do NOT set initdefault to this)
# 1 - Single user mode
# 2 - Multiuser, without NFS (The same as 3, if you do not have networking)
# 3 - Full multiuser mode
# 4 - unused
# 5 - X11
# 6 - reboot (Do NOT set initdefault to this)
#
id:3:initdefault:

# System initialization.
si::sysinit:/etc/rc.d/rc.sysinit

I changed /etc/inittab file by making the runlevel mode from id:3:initdefault
to id:5:initdefault.The changed file with few of the top lines is as shown below
[root@localhost... /]$ more /etc/inittab
#
# inittab This file describes how the INIT process should set up
# the system in a certain run-level.
#
# Author: Miquel van Smoorenburg, <miquels@drinkel.nl.mugnet.org>
# Modified for RHS Linux by Marc Ewing and Donnie Barnes
#

# Default runlevel. The runlevels used by RHS are:
# 0 - halt (Do NOT set initdefault to this)
# 1 - Single user mode
# 2 - Multiuser, without NFS (The same as 3, if you do not have networking)
# 3 - Full multiuser mode
# 4 - unused
# 5 - X11
# 6 - reboot (Do NOT set initdefault to this)
#
id:5:initdefault:

The next step took was restart the machine
Since I was using GRUB Loader for starting the OS , the first OS used is RedHat Linux 8
The I pressed the ENTER keyboard button to start the OS
The OS started nicely
Before making change to /etc/inittab, the process of starting the OS was in interactive mode displaying in green colour mode as OK for a series of modules
started before arriving at the root prompt and password
After making change to the /etc/inittab prompt
the interactive mode, in text mode does not appear at all , a series of text splashes out displaying one of lines them as follows

/etc/rc.d/.... respawn ..
Then , wait for a second,
A screen appears with grey as the outer colour box and blue as the inner colour
box saying that as shown below , with display not clear in human readable format
I want to start the X server as there is a bug in the Xserver
you need to start gdm
There is a button at the bottom which should be a human readable format ,but here it is not in human readable format but with as series of question marks
as shown below
???????
Then I press the Enter keyboard button, hoping it would work
A cursor waits for a long time not displaying anything, waits there.
I think something goofy type
I type some letters and the letters gets displayed . Here I cannot even do poweroff or even a shutdown operation to the machine It waits indefinitely as if 'Do whatever u want, I(Linux OS) am not going to come out )'. It is irritating to me saying how robust it is
I have to mannually reboot the machine

Please help me with the following options

1)How to go back to make changes to /etc/iniitab('as I canot enter the text prompt)and come back to the original Text mode, please provide with a series of actions to be taken(Like I explained Above)

2)There is a series of utilities in Grub like cat displaymemetc...,But there is no single utility to make changes to a file like /etc/inittab .Grub has utilities like find. not to mention some other utilities like Config, initrc , which can be help to me for changing(editing) the file from graphical mode to text mode . IF someone has tried this way, please help with showing some examples/links of making changes to the /etc/inittab

3)Is there is any other way of getting -Provide steps/examples/links

4)Give me the final option - ur answer

I am getting impatient , Linux is such a rock solid, it makes me to come to his(Linux OS) graveyard and provide him(Linux OS) a rebirth(reinstall!!!!(I do not prefer)


Hoping, someone would give ..........

Thanks
Sujit
 
Old 06-21-2004, 04:03 AM   #2
jschiwal
Guru
 
Registered: Aug 2001
Location: Fargo, ND
Distribution: SuSE AMD64
Posts: 15,733

Rep: Reputation: 654Reputation: 654Reputation: 654Reputation: 654Reputation: 654Reputation: 654
You need to get your video card and /etc/XF86Config-4 file setup before you will be able to use run level 5 as the default.
If you had started out with run level 5 and changed it to run level 3 for the time being, then you would be on the right track.

Give us details on your video card, computer model, monitor model and the contents of the XF86Config-4 file. Someone will probably be able to give you some advice. Often the solution is to load a driver setup program from the card manufacturer's web-site, and install it.

Last edited by jschiwal; 06-21-2004 at 04:08 AM.
 
Old 06-21-2004, 05:10 AM   #3
sujith_marar
LQ Newbie
 
Registered: Apr 2004
Posts: 12

Original Poster
Rep: Reputation: 0
/etc/inittab problem

Thanks for th reply,please read carefully my first posted thread How I go to the second step without doing the first step
I want is to come back to the text mode
Please read the current situation of my machine status that is this
as shown below
It is correct that i want to give the video details , the X-Configuration files .But I am totally stuck up with not being able to enter the Red Hat Linux 8.0 OS to reach out in interactive text mode (or at the root prompt) so that I can able to make changes to /etc/inittab file by making runlevel from id:5 to id:3 .The situation now arises is now that the graphical mode which is totally stuck up , but i want to come back to the text mode so that i can provide XConfigurator details .The present situation is now with me is that
1)GRUB is open(the only way I can enter) till the display where the interactive text mode was supposed to start in Linux OS(presently not as, the error is shown in the first thread), I can access up till this beginning level,forget that, I cannot go to the text mode at all, where i do I have a chance of editing from runlevel id:5 to id:3 . Is there a step from the GRUB tool by editing the /etc/inittab file and making runlevel change from id:5 to id:3
which utility in GRUB do provide facility for editing
For eg.
grub> cat /etc/inittab (Not this one.... )
Is there any utility in GRUB to edit the /etc/inittab file for making the runlevel from id:5 to id:3 so that i can revert back to text mode
Please show by example

2) any other operation needed, as arise from the above situation


thanks
Sujit

Last edited by sujith_marar; 06-21-2004 at 05:24 AM.
 
Old 06-29-2004, 06:10 PM   #4
jschiwal
Guru
 
Registered: Aug 2001
Location: Fargo, ND
Distribution: SuSE AMD64
Posts: 15,733

Rep: Reputation: 654Reputation: 654Reputation: 654Reputation: 654Reputation: 654Reputation: 654
You could boot up you install disk and use the options 'rescue' to enter the rescue system. I think that works for redhad.

Or you could boot up from you hard drive and use the option 'linux single'. Then use an editor to change your /etc/inittab file.

Last edited by jschiwal; 06-29-2004 at 06:13 PM.
 
Old 07-03-2004, 02:12 AM   #5
sujith_marar
LQ Newbie
 
Registered: Apr 2004
Posts: 12

Original Poster
Rep: Reputation: 0
Boot Up From /etc/initab

Hi Jschwall


Thanks for the reply
Are ur statements mean to say

After booting from the Hard Disk, Grub Loader screen displays
What ?here do i need to add in Kernel line
For ex is it this way
linux 1
or linux single at the end of the line
oR
Just After tha machine boots up, just any screen display before
Grub Loader or Is there any keyboard buttons to do that

Waiting for ur response

Thanks Sujit
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
No initab file found - No more processes left in this runlevel mrhansen Linux - Newbie 6 08-27-2004 02:17 PM
perl problem? apache problem? cgi problem? WorldBuilder Linux - Software 1 09-17-2003 07:45 PM


All times are GMT -5. The time now is 12:37 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration