LinuxQuestions.org
Register a domain and help support LQ
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices

Reply
 
LinkBack Search this Thread
Old 09-07-2004, 02:18 AM   #1
Sinope
Member
 
Registered: Aug 2004
Location: Chicago
Distribution: Debian testing/unstable
Posts: 82

Rep: Reputation: 15
/etc/fstab "user" option: not working?!


What's up with this? (see below)

I get the same error message for /mnt/floppy, /mnt/muvo, /dev/muvo, /dev/dvd, /mnt/dvd, &c&c. I can mount any of the above without difficulty, as long as I am root.
mount -a runs without error.

So... what the hell? Am I spelling "user" wrong or something?

Code:
~$ mount /dev/fd0
mount: must be superuser to use mount
~$ cat /etc/fstab
/dev/hdb1        /                ext2        defaults        1   1
/dev/hda1        /boot            ext2        defaults        1   2
/dev/hda3        /ntfs-c          ntfs        ro,umask=0222   1   0
/dev/cdrom0      /mnt/cdrom0      iso9660     noauto,ro,user  0   0
/dev/cdrom1      /mnt/cdrom1      iso9660     noauto,ro,user  0   0
/dev/dvd         /mnt/dvd         iso9660     noauto,ro,user  0   0
/dev/fd0         /mnt/floppy      auto        user,noauto     0   0
/dev/sda1        /mnt/usbdisk     vfat     user,noauto,umask=0002    0   0
/dev/muvo        /mnt/muvo        vfat     user,noauto,umask=0002    0   0
//MATRIX/SharedDocs  /mnt/smb/matrix  smbfs       user,noauto     0   0
//LIB/SharedDocs     /mnt/smb/lib     smbfs       user,noauto     0   0
devpts           /dev/pts         devpts      gid=5,mode=620  0   0
proc             /proc            proc        defaults        0   0
~$
Thanks for any help!

--S
 
Old 09-07-2004, 03:20 AM   #2
heema
Senior Member
 
Registered: Sep 2003
Location: Egypt
Distribution: Arch
Posts: 1,528

Rep: Reputation: 46
check out this site :

http://shilo.is-a-geek.com/slack/fstab12.html
 
Old 09-07-2004, 08:33 AM   #3
Sinope
Member
 
Registered: Aug 2004
Location: Chicago
Distribution: Debian testing/unstable
Posts: 82

Original Poster
Rep: Reputation: 15
Of course I looked at shilo's site.... that is my bible. But I'm still having this problem....

As you can see, I have permissions aplenty..... (I am in group "mount", of course.)

Code:
~$ ls -l /dev/cdrom* /dev/dvd /dev/sda1 /dev/fd0 /dev/muvo /dev/hdd /dev/hdc
lrwxrwxrwx  1 root root       8 2004-09-01 17:13 /dev/cdrom0 -> /dev/hdc
lrwxrwxrwx  1 root root       8 2004-09-03 20:41 /dev/cdrom1 -> /dev/hdd
lrwxrwxrwx  1 root root       8 2004-09-03 20:42 /dev/dvd -> /dev/hdd
brw-rw-r--  1 root mount  2,  0 1996-05-14 17:38 /dev/fd0
brw-rw-rw-  1 root mount 22,  0 2002-06-09 15:27 /dev/hdc
brw-rw-rw-  1 root mount 22, 64 2002-06-09 15:27 /dev/hdd
lrwxrwxrwx  1 root root       9 2004-09-07 00:59 /dev/muvo -> /dev/sda1
brwxrwxr-x  1 root mount  8,  1 1995-04-29 06:33 /dev/sda1
~$
~$
 
Old 09-07-2004, 10:31 AM   #4
gunter
Member
 
Registered: Jan 2003
Distribution: Gentoo
Posts: 65

Rep: Reputation: 15
Try mount /mnt/floppy instead of mount /dev/fd0

FYI.
user will only let the user that mounted the fs unmount it.

users will let any user unmount a fs regardless of who mounted it.

Try changing that option to see what happens.
 
Old 09-07-2004, 11:41 AM   #5
Sinope
Member
 
Registered: Aug 2004
Location: Chicago
Distribution: Debian testing/unstable
Posts: 82

Original Poster
Rep: Reputation: 15
This I know..... I can't MOUNT it to begin with, though! JIC I tried changing it:

Code:
~$ mount /mnt/floppy
mount: must be superuser to use mount
~$ grep 'fd0' /etc/fstab
/dev/fd0         /mnt/floppy      auto        user,noauto     0   0
~$ ls -l /etc/fstab
-rw-r--r--  1 root root 906 2004-09-07 03:13 /etc/fstab
~$ su -c 'vi /etc/fstab'
Password:
reading /etc/fstab

wrote /etc/fstab, 13 lines, 907 chars
~$ grep 'fd0' /etc/fstab
/dev/fd0         /mnt/floppy      auto        users,noauto     0   0
~$ mount /mnt/floppy
mount: must be superuser to use mount
~$ ls -l /dev/fd0 /mnt/floppy -d
brw-rw-r--  1 root mount 2, 0 1996-05-14 17:38 /dev/fd0
drwxr-xr-x  2 root root  4096 2002-03-16 02:34 /mnt/floppy/
~$
As far as I can tell, everything is in order.... what could the problem be ?!?!?

Getting frustrated.....



--S


EDIT: I almost forgot.... In case you were wondering...
Code:
~$ groups
users root adm www mount
:P

Last edited by Sinope; 09-07-2004 at 11:43 AM.
 
Old 09-12-2004, 06:04 PM   #6
cruzfernandez
LQ Newbie
 
Registered: Jun 2003
Posts: 5

Rep: Reputation: 0
it should be auto,user
 
Old 09-15-2004, 07:21 AM   #7
egag
Senior Member
 
Registered: Jul 2004
Location: Netherlands
Distribution: Slackware
Posts: 2,721

Rep: Reputation: 52
you have the same distro as i have, and i did:

edit the file /etc/sudoers using #visudo ( see " man visudo " ; if you don't know how to use vi, type " vimtutor " ; get's you going in 5-10 min's ),
i added the line : egag ALL=(ALL) NOPASSWD:ALL
and save it.

now i can mount by :
$sudo mount /mnt/cdrom
( right now, "egag " is able to use any command, you can restrict this to a few specefic commands....see examples in /etc/sudoers )

egag
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
bash script: using "select" to show multi-word options? (like "option 1"/"o zidane_tribal Programming 6 03-21-2013 10:35 AM
rpm -bp command not working says "-bp: unknown option" Niceman2005 Linux - Software 2 11-08-2004 01:36 AM
Apache "TARGET=" option not working kev_dude Linux - General 0 03-15-2004 01:07 AM
desktop icons for drives with option "user" fsbooks Linux - Software 0 01-08-2004 09:07 AM
anging "Protocol" option to "IMPS/2" in XF86Config-4 causes problems zstingx Linux - General 2 10-27-2003 09:47 AM


All times are GMT -5. The time now is 07:57 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration